can't remove computer from DPM RRS feed

  • Question

  • Hello,

    I'm relatively new to DPM so hopefully this question has a simple answer.

    I'm trying to clear a warning in my DPM.  Prior to my tenure here, a server was decommissioned without it being removed from DPM.  The warning is "Agent not reachable" (because the server isn't here anymore).  If I go to the Protection section, highlight "All Protection Groups", and sort by computer, it isn't there.  I've been through this section with a fine tooth comb, and I can't find it.

    However, if I go to the Management section, right-click the server and choose "Remove", it tells me I can't do anything until I remove all protected members on the associated computers from protection groups.  I've disabled protection and it shows as disabled, but I can't clear the warning permanently.  It always comes back.

    I tried a Powershell script I found online, but it essentially gives me the same error.

    Is there something I'm missing?


    Zachary Hamilton

    Friday, May 10, 2019 7:18 PM


All replies

  • Hello Zachary,

    If DPM agents are not removed from the DPM console, they will indeed have the status "Agent not reachable".

    With the GUI you cannot do much, but with the DPM Shell (PowerShell) you can, run the command below to remove the agent:


    Then you need to enter the name of the DPM server, and finally enter the name of the agent computer that you want to be removed.

    Once done, close the DPM console and start it up again, and the agent should be gone.

    Best regards,

    Blog: LinkedIn:

    Saturday, May 11, 2019 1:30 PM
  • Hi Leon,

    Thanks for your response.  Unfortunately, that is the Powershell script I found.  I even tried "Run as Administrator".  Here's what happens:

    WARNING: Connecting to DPM server:
    There is failure while removing production server
    C:\Program Files\Microsoft System Center 2012
    R2\DPM\DPM\bin\Remove-ProductionServer.ps1 : DPM was unable to remove the
    protected computer, which includes active or
    inactive protection on this DPM server.
    At line:1 char:1
    + remove-productionserver.ps1
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorExcep
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio

    Delete any active protection for this protected computer and then retry the oper


    Zachary Hamilton

    Monday, May 13, 2019 1:12 PM
  • You can refer to this, it should also apply to your DPM version of 2012:

    How to remove old retired or orphaned agents from DPM 2010

    If this doesn't work, you can run the following SQL query on your DPM database:

      SET @NOW = GETDATE() --Current date and time
      Update tbl_am_installedagent
      SET Deleted = '1', DeletedDateTime = @NOW, PatchID = NULL, ApprovedPatchByAdmin = NULL
      Where serverid in (select Serverid from tbl_am_server where serverName = 'FQDN')  -- replace with FQDN of protected server IE:  - Maintain the single quotes.

    Once this has been ran, restart your DPM console.

    Blog: LinkedIn:

    Monday, May 13, 2019 1:30 PM
  • Hi Leon,

    The first link didn't work.  I even tried the advice from 'Fred' in the comments.

    I ran the SQL above, and the result was '(0 row(s) affected)'.  The server 'vdovcsql201' is still listed in the Management section, agent status is still 'Disabled', and when I right-click and try to remove it, it still complains that I need to remove all protected members on the associated computers from protection groups.

    Just FYI, I'm running my Powershell and Command prompts elevated.

    Thanks again,


    Monday, May 13, 2019 2:22 PM
  • Which version and build of DPM 2012 are you running?

    The SQL query should work, you could also check manually in the server table to see if it's actually there:

    SELECT * FROM tbl_am_server WHERE serverName = ''

    If this returns nothing, then it does seem to be a GUI bug, because DPM stores everything in the database.

    You could also try rebooting the DPM server.

    Blog: LinkedIn:

    Monday, May 13, 2019 2:30 PM
  • DPM 2012 version is 4.2.1603.0 according to Control Panel.

    Your SQL code above returned a line!  ServerName is ''.  The NetbiosName and DomainName fields match up.  MarkedForDeletion is '0'.  There's a few other fields as well.



    Monday, May 13, 2019 2:46 PM
  • Check the version in the DPM console, Help > About Data Protection Manager.

    Ok so the server does exist, then it means that the first SQL query that I provided should work, double check that you ran the first SQL query properly and towards the correct database.

    Normally the PowerShell method should work in these scenarios, you could try giving the DPM server a reboot.

    Blog: LinkedIn:

    Monday, May 13, 2019 2:58 PM
  • First, my bad.  I didn't run that first SQL with the FQDN.  It worked.

    Second, I now have another warning: "A protection agent is not installed on in server cluster. Protection may fail if a failover occurs to (ID 369)"

    I finally talked to someone who knows a bit about what went on and got some historical context (I've only been here about 5 weeks).  Apparently there were two servers (201 & 202) in an SQL cluster (200).  Something happened, 201 freaked out, and it was turned off (at least six months ago).  There's only one server (202) in the cluster that's turned on.

    I'm guessing that we should probably remove the dead server from the cluster, but I'm not sure if I can do that and leave the cluster intact.  The cluster has it's own name and IP address.

    Did I mention I inherited a mess?  :-)

    Thanks for all the help!


    Monday, May 13, 2019 5:33 PM
  • Ok great to hear! The error makes sense if it indeed was a cluster, I would remove the node that has been decommissioned.

    You can run the cluster with only one cluster node left.

    Blog: LinkedIn:

    Monday, May 13, 2019 5:51 PM
  • I evacuated the dead node and all the relevant warnings are gone!  Very happy!

    Now, if only Microsoft would fix this one about "A new version of Windows Azure Backup Agent is available."  I've already got the most recent version.  There's already plenty of chatter about this error and no easy solution it seems.  Still, I'll take the victories where I can get them!

    Thanks again for all your help.


    Monday, May 13, 2019 7:16 PM