none
The machine-default permission settings do not grant..

    Question

  • iam geting the following error in Eventviewer?

    The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID 
    {680DFBF7-C92D-484D-84BE-06DC3DECCD68}
     and APPID 
    {680DFBF7-C92D-484D-84BE-06DC3DECCD68}
     to the user IIS APPPOOL\ASP.NET v4.0 SID (S-1-5-82-794271414-2547205055-1060673776-2579641347-304524694) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.


    Thursday, October 10, 2013 6:37 AM

Answers

  • Hi Giridhar,

    This error is being logged into the System event logs in Event Viewer due to inadequate permission for the farm admin account on the DCOM component 000C101C-0000-0000-C000-000000000046. In order to change the permission settings, perform the following steps:

    1. Open Component Service by clicking Start > Administrative Tools > Component Services.
    2. Navigate and expand the node Component Services > Computers > My Computer > DCOM Config.
    3. Right Click the sub node “000C101C-0000-0000-C000-000000000046” and select “Properties”.
    4. On the Properties dialog box, select Security tab. In most cases you will notice that the settings are grayed out. This is because the logged in user doesn’t have enough permissions on this component to change the settings. In order to provide this permissions, perform the steps described in next section “Change Component Service Owner and Permission”. You may need to restart the server after doing this.
    5. Once you set up the permission mentioned in previous step, in the Launch and Activation Permissions section in Security tab, select Customize option and click Edit.
    6. In the popup window, add the farm admin user account and check Local Launch and Local Activation permissions. 
    7. Restart IIS and SP Timer. If possible, restart the server itself.

    Reference: http://sajiviswam.wordpress.com/2011/04/15/the-machine-default-permission-settings-do-not-grant-local-activation-permission-for-the-com-server-application-with-clsid-000c101c-0000-0000-c000-000000000046-sharepoint-2010/

    Please inform me freely if you have any questions.

    Thanks

    Friday, October 11, 2013 5:20 AM
    Moderator

All replies

  • Hi Giridhar,

    This error is being logged into the System event logs in Event Viewer due to inadequate permission for the farm admin account on the DCOM component 000C101C-0000-0000-C000-000000000046. In order to change the permission settings, perform the following steps:

    1. Open Component Service by clicking Start > Administrative Tools > Component Services.
    2. Navigate and expand the node Component Services > Computers > My Computer > DCOM Config.
    3. Right Click the sub node “000C101C-0000-0000-C000-000000000046” and select “Properties”.
    4. On the Properties dialog box, select Security tab. In most cases you will notice that the settings are grayed out. This is because the logged in user doesn’t have enough permissions on this component to change the settings. In order to provide this permissions, perform the steps described in next section “Change Component Service Owner and Permission”. You may need to restart the server after doing this.
    5. Once you set up the permission mentioned in previous step, in the Launch and Activation Permissions section in Security tab, select Customize option and click Edit.
    6. In the popup window, add the farm admin user account and check Local Launch and Local Activation permissions. 
    7. Restart IIS and SP Timer. If possible, restart the server itself.

    Reference: http://sajiviswam.wordpress.com/2011/04/15/the-machine-default-permission-settings-do-not-grant-local-activation-permission-for-the-com-server-application-with-clsid-000c101c-0000-0000-c000-000000000046-sharepoint-2010/

    Please inform me freely if you have any questions.

    Thanks

    Friday, October 11, 2013 5:20 AM
    Moderator
  • Pasting the relevant section not copied from the referenced link in case the site goes away:

    Change Component Service Owner and Permission

    In the DCOM Config dialog box, you noticed that the settings are grayed out. In order to enable those settings, perform the following registry modification.

    1. Open Registry Editor by typing “regedit.exe” in Start > Run.
    2. Navigate and select the key “[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\{000C101C-0000-0000-C000-000000000046}]”
    3. Right click and select Permissions.
    4. In the popup windows, click Advanced.
    5. In the Advanced Security Settings windows, select Owner tab and change the owner to Administrators. Click OK to close the window.
    6. In the Permissions screen, select Administrators and check Full Control. Click OK to close the screen.
    7. Close the registry editor.

    Sunday, June 14, 2015 2:29 PM