none
sharepoint 2013 designer error Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature

    Question

  • Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature

    When we imported designer workflow from one environment to other server we are getting above error when we try to open the workflow in designer 2013

    New workflow creation is working fine but not this imported one.


    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead

    Wednesday, February 12, 2014 8:32 PM

Answers

All replies

  • Hi Amit ,

    According to your error message, it can be cause by the cache of SharePoint Designer.

    You can try the solution that deleting  the matching folder contents:

    %APPDATA%\Microsoft\Web Server Extensions\Cache

    %APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache

    %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache

    Reference: http://social.technet.microsoft.com/Forums/en-us/d0d28ad4-6df4-4568-8b55-32ef6789d347/sharepoint-designer-failed-to-load-this-workflow

    Best Regards,

    Eric


    Eric Tao
    TechNet Community Support

    Thursday, February 13, 2014 8:42 AM
  • Same issue here Amit, we have a production and test server and moving between the two using SharePoint Designer 2013 Sp1 seems to be causing the issue.  Create a new workflow is successfully though.  
    Thursday, April 17, 2014 7:24 PM
  • Did anyone find the solution. I am also getting the same error. I tried the suggested options but no luck

    V.S.

    Monday, October 27, 2014 12:17 PM
  • I created new wrokflow completely and it is working fine.

    V.S.

    Friday, October 31, 2014 6:22 AM
  • Deleting the cache actually CAUSED my problem. I was no longer able to open my workflow. After I restored all the deleted files from my Recycle Bin, I was once again able to work on my workflow.

    To completely replicate what I did: 1) Use Windows Explorer to delete the files; 2) Delete the files using Command Prompt; 3) Restore files from Recycle Bin. In between each step, I was re-launching Designer and attempting to open the workflow.

    Tuesday, March 10, 2015 8:38 PM
  • In my case I had to install this to make it work... even though I'm not using VS 2005
    Visual Studio 2005 extensions for .NET Framework 3.0 (Windows Workflow Foundation)
    http://www.microsoft.com/en-us/download/details.aspx?id=23072

    You need to restart SPD after installing the extensions

    • Proposed as answer by James Boman Wednesday, October 28, 2015 5:51 AM
    Monday, April 20, 2015 10:19 PM
  • Thanks!!!

    It's worked for me.

    Friday, August 28, 2015 5:53 AM
  • In my case I had to install this to make it work... even though I'm not using VS 2005
    Visual Studio 2005 extensions for .NET Framework 3.0 (Windows Workflow Foundation)
    http://www.microsoft.com/en-us/download/details.aspx?id=23072

    You need to restart SPD after installing the extensions

    This worked for me - thanks :)


    James Boman BSc. MCP:EAD -

    Wednesday, October 28, 2015 5:51 AM
  • Tank you! Clearing the Designer cache helped me with SharePoint Online. So, it applies to both on-premises and the cloud

    Denis

    Tuesday, January 26, 2016 3:41 PM
  • I have tried all of these items, along with uninstalling and reinstalling. We still continue to get the errors. Any other options we can try before starting this workflow all over? Workflow does continue to work as it should, just not opening for edits.

    Carrie Marshall

    Tuesday, June 21, 2016 6:06 PM
  • I still get the same error. This did not help resolve the error. 
    Tuesday, July 12, 2016 10:20 PM
  • Please try this to fix the issue:

    1. Install Hotfix  (SharePoint Designer 2013 hotfix package (Spd-x-none.msp): April 8, 2014)
      https://support.microsoft.com/en-us/kb/2727100
    2. Clear the Cache: (Delete all files/folders there)
      C:\Users\<username>\AppData\Local\Microsoft\WebsiteCache
      C:\Users\<username>\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache
      C:\Users\<username>\AppData\Roaming\Microsoft\Web Server Extensions\Cache

      (or use these commands if files are hidden)
      %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache
      %APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache
      %APPDATA%\Microsoft\Web Server Extensions\Cache
    3. Restart SharePoint Designer


    When my SPD opened back up I clicked on Workflows, then highlighted one of them, R-clicked and chose Workflow Settings.  When this opened up I chose Save and then Publish.  After this I clicked on Edit Workflow and it opened no problem. 

    Hope this helps!  :)


    Jennifer Knight (MCITP, MCPD)

    Thursday, October 13, 2016 3:58 PM
  • Yes it opened workflow, but it shows me empty after doing that, but actually it exists and have a complete set of instructions
    Friday, December 16, 2016 12:58 PM