none
Cannot Delete Subsite

    Question

  • SharePoint 2007

    Hi, I had issue with deleting sharepoint subsite. I tried all possiblities to delete sites from administration Site Settings, Manage Content & Structure, stsadm, powershell, sharepoint designer, but I got error:

    Error deleting Web site "/loc/penang/ittest2". You can't delete a site that has subsites.   at Microsoft.SharePoint.Library.SPRequestInternalClass.DeleteWeb(String bstrUrl)
       at Microsoft.SharePoint.Library.SPRequest.DeleteWeb(String bstrUrl)

    However, there was no subsite at all. I also run databaserepair to see if the site was corrupted but it was not.

    Could anyone can tell me why I can't delete and how can I delete this site.

    Thanks


    • Edited by Mike Walsh FIN Thursday, April 28, 2011 5:50 AM - SharePoint 2007 not needed in Title as default here. Added to text where it is useful but MOSS 2007 or WSS 3.0 more useful as more specific
    Thursday, April 28, 2011 2:01 AM

Answers

  • Hi Mr. T1,

    In WSS 3.0, if a sub site moved to a new location, you would probably meet this error caused by the incremental deployment job failed. But it had fixed in MOSS 2007. Can you find any errors in Event log and ULS log? Please move the site you want to delete just under the top site, and try to delete again (Click OK when it tells you that all sub sites will be deleted at the same time).

    Best regards,
    Emir

    • Marked as answer by David HM Thursday, May 05, 2011 8:11 AM
    Friday, April 29, 2011 9:51 AM

All replies

  • Hi Mr.T1,

    Try to delete the site using Site Content and Structure.

    Open the site with  http://site/_layouts/sitemanager.aspx and you will get list of all sites and subsites.

    Try to delete the site from there.

    hth


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Thursday, April 28, 2011 8:36 AM
  • Hi Pratik, as I mentioned above, I can't delete the site by using Site Content and Structure, here is the error when I try to delete:

    <error><message>Error deleting Web site &quot;/loc/penang/ittest2&quot;. You can&#39;t delete a site that has subsites.</message><full>Microsoft.SharePoint.SPException: Error deleting Web site &quot;/loc/penang/ittest2&quot;. You can&#39;t delete a site that has subsites. ---&gt; System.Runtime.InteropServices.COMException (0x81070944): Error deleting Web site &quot;/loc/penang/ittest2&quot;. You can&#39;t delete a site that has subsites. at Microsoft.SharePoint.Library.SPRequestInternalClass.DeleteWeb(String bstrUrl) at Microsoft.SharePoint.Library.SPRequest.DeleteWeb(String bstrUrl) --- End of inner exception stack trace --- at Microsoft.SharePoint.Library.SPRequest.DeleteWeb(String bstrUrl) at Microsoft.SharePoint.SPWeb.Delete() at Microsoft.SharePoint.Publishing.Internal.WebControls.DeleteRecursive.DeleteOp(ObjectSerializer objser) at Microsoft.SharePoint.Publishing.Internal.WebControls.SmtLongRunningJob.ApplyPostOrder(NodeOperator op, ObjectSerializer objser, UInt32&amp; numaffected) at Microsoft.SharePoint.Publishing.Internal.WebControls.DeleteRecursive.DoWork()</full><customData>Operation to Delete &#39;/loc/penang/ittest2&#39; Failed</customData></error>

    Please advise.

    Thanks

    Thursday, April 28, 2011 11:41 PM
  • Hi Mr. T1,

    In WSS 3.0, if a sub site moved to a new location, you would probably meet this error caused by the incremental deployment job failed. But it had fixed in MOSS 2007. Can you find any errors in Event log and ULS log? Please move the site you want to delete just under the top site, and try to delete again (Click OK when it tells you that all sub sites will be deleted at the same time).

    Best regards,
    Emir

    • Marked as answer by David HM Thursday, May 05, 2011 8:11 AM
    Friday, April 29, 2011 9:51 AM
  • Are you sure you don't have any meeting workspaces on your site?  These are also considered sub-sites and will prevent the deletion of your site.
    - Xenox G.
    Friday, April 29, 2011 1:25 PM
  • Silly question: did you use the -force paramter when trying the STSADM command?

    http://technet.microsoft.com/en-us/library/cc288016(office.12).aspx

    - M


    - Michael Mukalian - 2010 MS MVP SharePoint Services - MCTS: MOSS 2007 Configuration - http://www.mukalian.com/blog
    Saturday, April 30, 2011 4:20 PM