none
Visio - bug - The server failed to process the request

    Question

  • Hi

    When uploading a visio diagram into one of our sharepoint document libraries we then get a 'The Server failed to process the Request' error when we then try and view the document in the Web Browser. Does anyone know how to fix this?

    Thanks

    Thursday, July 25, 2013 4:55 PM

Answers

  • ...after talking to our SQL admins it turns out that a specific account did not have access to the underlying Content dbs. Once we gave it dbo rights then this error disappeared and the Visio in Browser option worked fine.
    • Marked as answer by sjb500 Friday, July 26, 2013 9:05 AM
    Friday, July 26, 2013 9:05 AM

All replies

  • Looking at the event logs on one of our front end web servers I see a combination of errors:

    Failed to get Vector Diagram for visio file; and

    Failed to get raster diagram for visio file...

    It's pointing to the fact that the Visio Graphics Service isn't configured correctly - but it looks fine to me from what I can tell. Can anyone shed any light on this?

    Thanks

    Friday, July 26, 2013 8:29 AM
  • ...after talking to our SQL admins it turns out that a specific account did not have access to the underlying Content dbs. Once we gave it dbo rights then this error disappeared and the Visio in Browser option worked fine.
    • Marked as answer by sjb500 Friday, July 26, 2013 9:05 AM
    Friday, July 26, 2013 9:05 AM
  • My account has SQL admin rights, so this "fix" did not work for me.
    • Proposed as answer by Anteru82 Monday, June 13, 2016 8:51 AM
    • Unproposed as answer by Anteru82 Monday, June 13, 2016 8:51 AM
    Monday, October 21, 2013 7:57 PM
  • Its not your account, its the account running the visio service that needs right.

    Adit

    • Proposed as answer by Xmantra Tuesday, October 14, 2014 7:47 PM
    Wednesday, January 08, 2014 7:10 PM
  • Hello SP experts, I am facing the same problem, "The server failed to process the request" - while accessing a Visio in SP2010 Exacts: Have created a Visio diagram to represent the health of some servers (via SCOM 2012 R2), saved the Visio (.vdw) in "Site Pages" and now when I am trying to access it from SP, it is throwing me an error "The server failed to process the request" I have installed Vision 2013 on the same server where SP is hosted, couldn't find any service running with respect to Visio on it though, any suggestions would be highly appreciated.... Thanks

    Faizan

    Tuesday, January 20, 2015 7:39 AM
  • I understand that this is an old thread. The following might be useful to other readers engaging this issue in the future.

    I experienced the same error message when provisioning a new instance of the Visio Graphics Service application for a new farm.  I first tested the approach presented by sjb500 and found that this approach did resolve the problem.  I then explored using a more limited permission approach.  Over the course of several attempts, I eventually found that I only need map the application pool identity to the SPDataAccess role to resolve the problem:


    Wednesday, April 01, 2015 6:56 PM
  • Stephan, where do you do that?
    Friday, April 01, 2016 8:28 PM
    1. Launch SSMS
    2. Open up Security, and then double-click on the service account used for the Visio Graphics Service application pool identity (eg, spApp).
    3. Select Mapping
    4. Select a database to see what roles the service account has been mapped to for that database.
    Friday, April 01, 2016 8:37 PM
  • I had to pull myself away from our upgrade POC for a few days...now back.  The user I have defined in SharePoint CA for the Visio Graphics Service is mapped to 11 databases (Search_Service_App, Secure_Store, etc) and different roles in each database...

    ...how, other than trial and error, did you ID the databases and roles to be modified?

    Thursday, April 07, 2016 7:53 PM