none
Remote desktop client is unable to connect when using remote desktop gateway RRS feed

  • Question

  • I opened a remote desktop gateway service on an Windows server (version 2008R2), which is used to connect the host of the inner network to the external workers. When connected, the user name Administrator and password of the gateway are entered. The input box appears immediately after the box is disappearing. No matter what is wrong, it can not be connected successfully, no matter I enter it. This is the case with the correct password or the wrong password. I use the Wireshark packet to observe, and find no packets or connections. By chance, I added an @, such as Administrator@hostname, in the username I entered, and I tried to serve in the service. Add a user with the @ user name on the device, and the system prompts the username to be illegal. Why is the remote desktop gateway landing to limit the @ character in the username, is it a remote desktop client bug?

    I tried to connect the remote desktop with Android client and MAC client, and it turned out to be successful.

    Thanks!Hope to get a reply as soon as possible.


    • Edited by czy.1 Saturday, August 4, 2018 9:51 AM
    Saturday, August 4, 2018 9:47 AM