none
Missing Site Actions on Rootpage

    Question

  • Hello everyone

    I've set up a SharePoint-Testenvironment  and I followed the instruction of the Administrators Companion but something is still wrong.

    I was working on a SharePoint-System one year ago (with full access) and the one I've set up now differs in some points.
    I understand the SharePoint architecture, meaning that I have a site collection (which actually starts as the rootpage) and under that I have my sites.

    Now my problem is, that I have a site collection (I can see site collection settings under the rootpage's settings) but I am missing some Options Site Actions Dropdown

    On the old system (that was set up for me) I had a lot more settings when I clicked on Site Action at the rootpage (e.g. Navigation, Users, and Site Structure). Those are missing now. When I click on Site Action as MOSS_Admin on the rootpage I just see the drop down that I have for common sites.

    Especially I am missing the Site Structure View where I can see every site and container in the current web application and furthermore work more convinient with the sites (moving them for instance).

    I am working on this issue for a whole day now, and I cant find anything...neither in the setup nor in the central administration. Maybe someone here can help me out

    best regards
    -- Marc


    Monday, May 05, 2008 11:24 AM

Answers

  •  gmagerr wrote:

    Did you look to see if the site features were enabled? Go to site actions / site features (if you can see that) make sure the publishing features are enabled see if that fixes it.



    This was not the solution, but it pointed me to the right direction.
    In a fresh install I created a Collaboration Portal instead of the Team Template and now everything is fine.

    Thanks
    Tuesday, May 06, 2008 2:32 PM

All replies

  • If you followed the admin companion, you probably used an account to set up the farm (other than MOSS_Admin) log in as that account and see if you get the correct menu drop downs. If so, add MOSS_Admin as a site admin. Also check you site features, sometimes when you don't have a site feature enabled you'll not see cetain menu actions.

    Monday, May 05, 2008 12:00 PM
  • Do you have a web application policy (from within Central Administration) that is overidding the permissions on the site collection? So it might look like you have full access, but the policy is preventing it?

     

     

    Monday, May 05, 2008 12:02 PM
  • Thanks for both replies.

    I used the MOSS_Admin account for the installation and I checked the web application policies. The policies had no entry for the users I am using, so I tried to add a policy which gives them full control but still these options are missing :-( (I checked all other permission settings).
    Monday, May 05, 2008 12:25 PM
  • I can't fix this.

    I guessed that something might be wrong with my SSPs and I found out that I only had a Adminsite (SSP) and a MySite. So I fixed the installation to the following

    SSPIntranet
    • SP - Intranet Admin (Port 19000)
    • SP - Intranet (Port 80)
    • SP - Intranet MySite (Port 19500)  <- I also tried to move this to a second SSP
    Afterwards I created a Site Collection in the Intranet webapp and checked the permissions, but still I don't see those Site Actions (to remind, I can see Site Collection Administration in the page settings but the structured view is missing there)

    regards
    -- Marc

    Tuesday, May 06, 2008 10:24 AM
  • Did you look to see if the site features were enabled? Go to site actions / site features (if you can see that) make sure the publishing features are enabled see if that fixes it.

    Tuesday, May 06, 2008 11:43 AM
  •  gmagerr wrote:

    Did you look to see if the site features were enabled? Go to site actions / site features (if you can see that) make sure the publishing features are enabled see if that fixes it.



    This was not the solution, but it pointed me to the right direction.
    In a fresh install I created a Collaboration Portal instead of the Team Template and now everything is fine.

    Thanks
    Tuesday, May 06, 2008 2:32 PM
  • this solves it:
    Site Features - Office SharePoint Server Publishing- Activate

    Before I had to activate
    Site Collection Features - Office SharePoint Server Publishing Infrastructure
    And when I could not activate some Site collection features I put the site on the same app pool as central administration (check this http://blog.thekid.me.uk/archive/2007/02/05/activating-office-sharepoint-server-publishing-infrastructure-access-denied.aspx)
    Friday, August 29, 2008 8:52 AM