SharePoint 2010 - MySite Host Root Site Collection is corrupted


  • We have a Production - DR environment, each consists of one SharePoint Server, we have configured mirroring between the two environment for the failover\failback, We have SharePoint 2010, SP1

    One very strange behavior we encountered while conducting failover test, is that when restoring then mounting the MySiteHost Content Database back up to DR, and trying to view the site collection list in the Application, it is not showing any details of the right side of the page, to isolate the issue, i took mirroring out, and tried to do Backup\Restore for the same database more than one time and the same behavior happens, please find below the steps followed:

    - Backup\Restore MySite host to the DR using SQL Management Studio

    - Created Web Application on the DR on different ports, Removed the dummy database from the web application

    - Created the required Managed Pathes

    - Mounted the new content database to the web application (Tried both, GUI, and Powershell)

    - Here i can see the new content DB in CA, but when i try to see the site collections inside it, all the my sites are fine, EXCEPT Of the ROOT SITE , it looks to be corrupted\not reachable

    > It shows no details on the right side of the page

    > I can't assign administrator for it

    > And i can't delete it using the GUI (i can do that only with stsadm)

    > Sure My site functionality is not working at all

    - (Note), same database is perfect in the production, and also when i try to access the same database using the View Un-Attached Database (In DR), it is accessible fine and i can see the lists and content inside it

    - The issue happens only with the ROOT Site Collection

    - No Single error shows in event log, or ULS

    I have tried all the below solutions:

    - Refreshed the Config DB sitemap using ($contentDB.RefreshSitesInConfigurationDatabase())

    - Mount\Dis-Mount multiple times

    - Run Configuration Wizard

    - Deleted the Web Applications and created it again

    Appreciate any idea's or Help in this regard, thank you in advance,

    SoftWare Engineer

    Friday, July 12, 2013 4:23 AM


  • It could be the way you're re-provisioning the MySites Web App. You're re-creating the Web Application using one database, then swaping it out for a new one which happens to have the same URL.

    What happens if you restore the DB that holds the root SC to the DR SQL instance before you build the DR web app, then when you specify the name of the Web App you give it the pre-existing database? I believe that it should automatically pick up the contents and work with them rather than re-creating.

    It saves a step over your current approach for a start and might fix the issue.

    Another option would be to try to backup the existing SC on the live system and restoring that over the top of the destination one, it's far from ideal but if that kicks it to life you might be able to hack some workaround into place.

    Monday, July 15, 2013 7:28 AM