none
permission to create list items but not edit them RRS feed

  • Question

  • I am trying to set up a list where users can create items, but not edit them, even their own.

    I thought this would be easily achieved by giving the users Contribute right to the list and then change the Advanced Settings to "Edit access: none". However, if I do that and I create a new list item, as soon as I hit "Ok" to save the list item I get an Access Denied error.

    Is there any way to do this?
    Tuesday, September 29, 2009 6:44 AM

Answers

  • Hi,

    You should be able to do this by creating a new Permission level within your site.

    1. From the site settings page, click the Advanced permisisons link, then from the settings menu, click the "Permission Levels" menu item

    2. Click on the Contribute permission level, and scroll to the bottom of the page. Click the Copy Permission Level button to take a copy of it.

    3. Call the new copy of the permission level "CreateButNotEdit" or something similar.

    4. Uncheck all the checkboxes in the list permisisons, except for "Add Items" and "View Items"

    5. Click the create button to save the new permission level.

    6. Go to your list and Manage Permissions for your list

    7. Break the inheritance of permissions for the list, if necessary

    8. Add a group, or click a group name or user to modify their permissions

    9. Assign the groups you wish to be able to create but not edit items the "CreateButNotEdit", and "Read" permission

    10. That's it!





    • Marked as answer by andreasbbbbb Tuesday, September 29, 2009 10:58 PM
    Tuesday, September 29, 2009 5:10 PM

All replies

  • That is simple. Go to "Advanced Settings" in the list settings. Set the edit permission to None there.

    Cheers
    Satheesh
    Tuesday, September 29, 2009 7:03 AM
  • That's what I did, but then I cannot seem to create new list items anymore at all. I can still click "New" on the list, but when I click "Ok" to save it, I get an Access Denied error.
    Tuesday, September 29, 2009 7:14 AM
  • Maybe can you take a look at SPListDisplaySetting from Laurent Cotton:  http://www.codeplex.com/SPListDisplaySetting/Release/ProjectReleases.aspx?ReleaseId=11136
    Serge Luca; blog: http://www.redwood.be
    Tuesday, September 29, 2009 10:47 AM
  • Hi,

    You should be able to do this by creating a new Permission level within your site.

    1. From the site settings page, click the Advanced permisisons link, then from the settings menu, click the "Permission Levels" menu item

    2. Click on the Contribute permission level, and scroll to the bottom of the page. Click the Copy Permission Level button to take a copy of it.

    3. Call the new copy of the permission level "CreateButNotEdit" or something similar.

    4. Uncheck all the checkboxes in the list permisisons, except for "Add Items" and "View Items"

    5. Click the create button to save the new permission level.

    6. Go to your list and Manage Permissions for your list

    7. Break the inheritance of permissions for the list, if necessary

    8. Add a group, or click a group name or user to modify their permissions

    9. Assign the groups you wish to be able to create but not edit items the "CreateButNotEdit", and "Read" permission

    10. That's it!





    • Marked as answer by andreasbbbbb Tuesday, September 29, 2009 10:58 PM
    Tuesday, September 29, 2009 5:10 PM
  • Wohoo, thanks Paul, that worked!

    I had to play a little bit with the permission settings for the new Permission Level, but in the end I had it going. It seems in addition to read and view I also had to enable the permission to "View Application Pages", otherwise the user wouldn't get through to the View or Create list item page. The disadvantage of enabling that is that now the user can see the Site Actions dropdown with a link to "List all Site Content" in it, but that's the least of my troubles.
    Tuesday, September 29, 2009 10:58 PM
  • I have the same problem but in reverse. I need my users to be able to edit but not add. I created the custom permission level and they can  edit the documents and the document properties. However, if they try to change the name of an existing document, they get an access denied error. So apparently changing the name of the document=adding a new document for sharepoint.

    Help! Any ideas?

    Anna


    A. Fagan

    Wednesday, February 26, 2014 8:14 PM