Virtualizing GPT Partition RRS feed

  • Question

  • I’m trying to do a P2V of a Server 2012 Standard edition machine which uses UEFI using SCVMM 2012 and I’m running into issues. The server is setup as a RAID 1 which consists of a 300MB Recovery Partition, 99MB System Partition and a 100GB NTFS partition (Boot, Page File and Primary Partition).  The partition style is GPT which I believe is part of the issue. While trying to perform the P2V using the wizard for SCVMM 2012 I can’t get past the “Conversion Information” screen. I receive an error that “The bus location for the object “SERVERNAME” at (IDE, 0, 255) is not valid (error 658). I’ve tried using both Dynamic and Fixed disks. I’ve also tried leaving the Channel blank and marking it as the Primary Channel (1).

    I’ve tried using “Microsoft Virtual Machine Converter 3.0” which did not work. I read that MVMC does not support converting servers with GPT disks.

    I’ve used Disk2VHD to convert the disks which completed successfully. I built a GEN1 VM, attached the disk and started the VM. Upon startup I receive this error “Boot failure, Reboot, and select proper boot device or insert boot media in select boot device…” I mounted the Server 2012 DVD and issued a repair command using diskpart to make the boot disk active but this did not work either. I read this is not accepted because the .VHD is a GPT disk and only works on an MBR disk.

    Running out of options I downloaded “VMware vCenter Converter Standalone”. I was going to try converting the server to .VMDK disks and then converting those disks to a VHD. I installed the converter on the source machine but the service would not start. I rebooted the server and the service still will not start. I removed the VMware converter agent and installed the application on a remote server and tried connecting remotely to the source server but I receive a 1603 error while trying to authenticate to the source server.

    Does anyone know of any other tools I can try or where I might be going wrong? I’ve successfully completed about 50 P2V’s and never had this issue before. Any help or advice is appreciated.


    Tuesday, June 12, 2018 4:53 PM

All replies

  • Hello Pat,

    Please open the Disk Management, and assign assign a drive letter to the 300M Recovery Partition. Then, please perform the P2V again.

    By the way, is there any third-party disk management tool installed on the server, such as SnapDrive? If so, please check out the missing volume in the Disk Management, and assign a drive letter to it.

    Best regards,

    Andy Liu

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 13, 2018 6:47 AM
  • Thank you for your response. I'm unable to assign a drive letter to that volume. When I right-click on it my only option is "Help" and we do not have any other disk management tools installed. If I right click on the 99MB volume all my options are grayed out. Do you know of another way to assign a drive letter to the recovery partition?


    Wednesday, June 13, 2018 12:08 PM