none
Misconfiguration of the MOSS State Service RRS feed

  • Question

  • Hi,

    when I start a Workflow, this Message appears:

    The form cannot be rendered. This may be due to a misconfiguration of the Microsoft Office SharePoint Server State Service. For more information, contact your server administrator.

    But all Features on the Server are activated.
    How can i fix this?
    Wednesday, October 7, 2009 2:04 PM

Answers

  • you need to make sure that the state service is started and associated with your web application that will be used to publish your WF into it.
    check the configuration through Central administration--> service application association
    Monday, November 2, 2009 4:43 PM

All replies

  • You may have a form with a lot of data. As a test, try reducing the size of the form and see if problem goes away.
    Wednesday, October 7, 2009 6:58 PM
  • No, it's just a small file, and I want to start a Workflow.
    Wednesday, October 7, 2009 7:06 PM
  • How about the data that the form is passing?
    Thursday, October 8, 2009 2:21 PM
  • Just a few KB .. the size can't be the reason.
    Because on another server, with the same configuration, Workflows do work..
    Friday, October 9, 2009 7:53 AM
  • Can anyone help me please??
    Tuesday, October 27, 2009 10:05 AM
  • you need to make sure that the state service is started and associated with your web application that will be used to publish your WF into it.
    check the configuration through Central administration--> service application association
    Monday, November 2, 2009 4:43 PM
  • if you are still looking for this problem then follow, follwoing steps:

    1. Run Central Administration
    2. Click on Configuration Wizard right hand side navigation links and then Launch the Farm Configuration Wizard.
    3. Start the Wizard
    4. Make sure checkbox along with State Service is checked.
    5. Click Next.

    or follow step given in following article.

    http://sharepointnotes.wordpress.com/ 


    SI
    Friday, April 9, 2010 4:19 PM
  • Thanks, I followed above and could solved it. Actually I was playing with "Application proxy Group" few days back and I created custom group. So now when I configured state service, It was not associated with custom group by default. But I realized that and associated it with "state service proxy", it worked like charm...thanks
    SharePoint
    Wednesday, April 21, 2010 6:31 PM
  • This did the trick for me, thanks Mohannad! To be exact on how to find the option:
    1. Open up Central Administration
    2. Go to Application Management
    3. Under Service Applications click Configure service application associations
    4. Click on the Application Service Proxy Group (2nd column) of the WebApplication you're trying your workflow on
    5. Make sure the checkbox in front of State Service is ticked
    6. Click OK and try your workflow again!

    .NET Software Developer (MCP)
    • Proposed as answer by Koen Zomers NL Wednesday, September 15, 2010 8:35 PM
    Wednesday, September 15, 2010 8:34 PM