none
When RDP using RD Gateway settings, it is not using UDP protocol RRS feed

  • Question

  • Hi all

    When I from a Windows 8 Pro machine RDP, using Gateway settings in Remote Desktop Connection, to a Windows 8 or Windows 7 machine (have updated to RDP 8.0), I can see that it is not using the UDP protocol. But when I RDP, not using Gateway settings in Remote Desktop Connection, to a Windows 8 or Windows 7 machine, it is using the UDP protocol (can I see by clicking on the signal bar on top). I ran the powershell command: dism /online /Enable-Feature:Gateway-UI on my 2012 Essentials server to enable the Gateway console and I can see that UDP is enabled in the properties. Any idea how to turn UDP on when RDP through the Gateway?

    Sunday, October 28, 2012 2:14 PM

Answers

  • Sorry, I was rushing earlier.

    it was a range I had opened, UDP 3389 - 3391

    You just need port UDP 3391 open to the essentials server.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    • Marked as answer by CHanzoy Thursday, November 1, 2012 10:12 PM
    Thursday, November 1, 2012 9:45 PM
    Moderator

All replies

  • Why do you want to use UDP?

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Tuesday, October 30, 2012 10:59 AM
    Moderator
  • Interesting, thanks for the link!

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Wednesday, October 31, 2012 2:45 PM
    Moderator
  • You're welcome :)

    Anyone who has the answer? I'm starting to gues that maybe it isn't supported on 2012 Essentials??


    • Edited by CHanzoy Wednesday, October 31, 2012 3:07 PM
    Wednesday, October 31, 2012 3:06 PM
  • Im looking at this now, im not sure if what we are seeing is right or not.

    Can you tell me how it is you are able to force it to use UDP in your initial question?


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Wednesday, October 31, 2012 3:24 PM
    Moderator
  • I think the key thing here is that the UDP improvements are for RemoteFX  - which requires full RDS - which is not enabled for Essentials.

    I dont know for sure, but i am checking.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Wednesday, October 31, 2012 5:22 PM
    Moderator
  • Im looking at this now, im not sure if what we are seeing is right or not.

    Can you tell me how it is you are able to force it to use UDP in your initial question?


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    When I choose "Automatically detect RD Gateway server settings" in Remote Desktop Connection and enter the ip adress on the Windows 7/Windows 8 vm, it will automatically choose UDP, don't have to do anything else.

    Thank you for your help.

    Wednesday, October 31, 2012 7:38 PM
  • So, are you internal, or external to the LAN at that point?

    I am trying all kinds of ways to connect, and i am not seeing UDP at all anywhere!

    Update - OK a direct RDP between the Server and a client (windows8) shows as running over UDP.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk



    Thursday, November 1, 2012 9:11 AM
    Moderator
  • Both internal and external.
    When I connect internally without RD Gateway setup in Remote Desktop Connection, it shows it use UDP.
    When I connect from WAN without RD Gateway setup in Remote Desktop Connection, it shows it use UDP.
    But when I use RD Gateway internally and from WAN, it doesn't show that is use UDP.

    • Proposed as answer by peterjlay1234 Friday, July 6, 2018 12:39 AM
    Thursday, November 1, 2012 11:08 AM
  • OK, i have it now using UDP - internally when i use the RDP Gateway, will now try externally.

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Thursday, November 1, 2012 4:08 PM
    Moderator
  • Yep, now have it going via UDP from external (WAN)

    Now.. what did i change..


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Thursday, November 1, 2012 4:10 PM
    Moderator
  • OK, so, i had to open UDP Port 3389 on my WAN Router. That is in addition to TCP 443.

    Seems obvious i guess, but took me a while ;o)

    I also set a GPO setting > (not sure if it is needed or not though)

    Computer Configuration > Admin Templates > Windows Components > RDS > RDS Sesion Host > Connections

    Select RDP Transport Protocols - Use both UDP and TCP


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Thursday, November 1, 2012 4:18 PM
    Moderator
  • Did you forward UDP 3389 to your Essentials server or the client you were trying to connect?

    Can't get it to Work. Have also set the GPO setting on the Essentials server.

    Temporary tried to disable firewall's on Essentials server and the client, still no go when using RD Gateway.

    Thursday, November 1, 2012 6:42 PM
  • To the essentials server.

    No it is not a firewall issue, the UDP stuff is negotiated. Apparently it now falls back to TCP.

    So,

    Setup as normal, then just enable UDP 3389... hang on, I need to check my router :)


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Thursday, November 1, 2012 9:38 PM
    Moderator
  • Sorry, I was rushing earlier.

    it was a range I had opened, UDP 3389 - 3391

    You just need port UDP 3391 open to the essentials server.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    • Marked as answer by CHanzoy Thursday, November 1, 2012 10:12 PM
    Thursday, November 1, 2012 9:45 PM
    Moderator
  • Sorry, I was rushing earlier.

    it was a range I had opened, UDP 3389 - 3391

    You just need port UDP 3391 open to the essentials server.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk


    Ahh of course UDP 3391 :) . Have been looking in the RD Gateway properties so many times and seen UDP 3391 so many times, why haven't I thought that it should be open in my WAN router. It all works perfectly now, thank you so much Robert!
    Thursday, November 1, 2012 10:12 PM
  • hey no worries, took me ages to figure it out as well :) and it is not exactly documented... ANYWHERE!!

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Thursday, November 1, 2012 10:15 PM
    Moderator
  • No it really isn't documented anywhere, but now we have all learned something :)
    Thursday, November 1, 2012 10:29 PM