none
WSUS not reporting to WSUS until they have done an initial download online RRS feed

  • Question

  • Hi, hoping someone call help me. Recently we built some new servers (same image we used on older servers). The servers are put in a GP in AD and appear in WSUS console with the number of updates outstanding etc. However the last 5 servers built are appearing in WSUS but with a status of not yet reported. When I kick off the "check for updates" on the server, it will keep checking and checking but never actually pulls any down and the status in WSUS remains the same. If I pull down some updates online and install, the server will change the status in WSUS and from that point on I can install updates from WSUS (managed by admin). This is a recent issue and nothing has changed in either WSUS or how the servers are built. Obviously I would prefer if all the updates installed on servers are managed. I have tried everything like stop and start wuauserv and bits. I have checked registry to ensure the correct WSUS server is displaying. I have tried numerous things. I would be very grateful if anyone could help out

    thanks in advance

    Sharon

    Wednesday, December 4, 2019 1:06 PM

Answers

  • Hi Yic

    My apologies for not getting back to you sooner. As I had tried everything suggested I decided to start over and removed all the roles and features and sql database and reinstalled the roles and features using wid instead of sql. This seems to have sorted the issue as the servers are now downloading once more. 

    thanks for all your help

    Sharon

    • Marked as answer by Sharon D123 Tuesday, December 31, 2019 10:59 AM
    Tuesday, December 31, 2019 10:59 AM

All replies

  • You have to delete WSUS client IDs from servers because you have mentioned that you used same image.

    Please use below troubleshoot guidance ti fix WSUS relevant errors,

    https://gallery.technet.microsoft.com/Troubleshooting-WSUS-d63da113?redir=0

    Wednesday, December 4, 2019 4:47 PM
  • However the last 5 servers built are appearing in WSUS but with a status of not yet reported. When I kick off the "check for updates" on the server, it will keep checking and checking but never actually pulls any down and the status in WSUS remains the same. 

    It takes time for the client to report the status to WSUS.
    If Windows Update prompts any errors during this process, providing error messages will help analyze the problem.
      

    If I pull down some updates online and install, the server will change the status in WSUS and from that point on I can install updates from WSUS (managed by admin). This is a recent issue and nothing has changed in either WSUS or how the servers are built. Obviously I would prefer if all the updates installed on servers are managed. 

    According to your description, that means that these 5 servers must first check and obtain some updates online from Windows Update before they can normally get approved updates through WSUS?
    Please consider telling me the operating system that these 5 servers are using.
      

    Regards,
    Yic


    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 5, 2019 5:26 AM
  • Hi , I am receiving no errors, the servers just keep checking for updates, I have a test one checking and it has been over a week.

    All servers are Server 2012 R2

    Monday, December 9, 2019 10:05 AM
  • Hi, I have done as suggested on your troubleshooting fix. The server is back checking for updates. I will let you know if this works but will give it a day or two to check
    Monday, December 9, 2019 10:06 AM
  • Hi Sharon,
      

    Please refer to the troubleshooting steps mentioned in the following article to check: "Tips for troubleshooting WSUS Agents that are not reporting to the WSUS server".
     

    Reply back with the results would be happy to help.
     

    Regards,
    Yic


    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 10, 2019 2:07 AM
  • Hi Yic

    I have gone through the troubleshooting article and still no joy. I removed one of the servers from the WSUS console and tried again. The server re-appeared in the console but still checking for updates after 3 days. I don't understand why this is happening as all was fine until recently. I even removed AV from the server but this made no difference. Any other ideas?

    Thursday, December 12, 2019 10:00 AM
  • Hi Sharon,
      

    Please consider checking Group Policy client computer is applied. You can prompt execute the following command from an elevated command on the problems of these clients:
       

    gpresult /h c:\result.html
       

    Please check that the generated report contains the correct group policy for Windows Update. If you can't tell, you can provide this part for analysis.
       

    Reply back with the results would be happy to help.
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, December 13, 2019 5:39 AM
  • Your answer will come from

    https://www.ajtek.ca/wsus/client-machines-not-reporting-to-wsus-properly/

    Follow the page downwards, each part contains troubleshooting parts. Run the client side script again (after deleting the computer from the WSUS MMC Console), EVEN THOUGH you probably have done it before. If that doesn't work, keep working down the page.


    Adam Marshall, MCSE: Security
    https://www.ajtek.ca
    Microsoft MVP - Windows and Devices for IT

    Monday, December 16, 2019 1:00 AM
  • Hi,
     

    Any update is welcome here.
    If the issue is resolved, share your solution or find the helpful response "Mark as Answer" to help other community members find the answer.
     

    Thank you for your cooperation, as always.
     

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, December 20, 2019 7:30 AM
  • Hi Everyone,
       

    Since this thread has not been updated for a long time, the following thread summary is provided for reference during subsequent follow-up.
      

    • Issue Symptom
      Some clients (Server 2012R2) did not report status to the WSUS server
         
    • Possible Cause
      Problems caused by duplicate SusClientId or Group Policy errors.
        
    • Troubleshooting Steps so far
      Group policy check recommendations.
      Client Windows Update component reset recommendation.
        
    • Next Step
      Waiting for reply.
          
    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 31, 2019 2:56 AM
  • Hi Yic

    My apologies for not getting back to you sooner. As I had tried everything suggested I decided to start over and removed all the roles and features and sql database and reinstalled the roles and features using wid instead of sql. This seems to have sorted the issue as the servers are now downloading once more. 

    thanks for all your help

    Sharon

    • Marked as answer by Sharon D123 Tuesday, December 31, 2019 10:59 AM
    Tuesday, December 31, 2019 10:59 AM