locked
"The world wide web publishing service failed to start..." RRS feed

  • Question

  • Hi,

    While running configuration wizard after installing MOSS 2007, i am getting the following error,

    The world wide web publishing service failed to start. Ensure that internet information services is installed properly and the service is configured correctly.

    please guide me to resolve this issue.

    • Edited by Mike Walsh FIN Monday, January 10, 2011 3:15 PM No need for entire error message in Title. Cut back and quotes put around what was left ... within the quotes to indicate a longer message
    Monday, January 10, 2011 1:26 PM

Answers

  • hi,

    Thanks all for your guidence.

    the issue is resolved, by giving full control to administrators for svchost in regedit.

    Wednesday, January 12, 2011 5:30 AM

All replies

  • Ensure that the World Wide Web and IIS Admin services are not disabled (from services.msc).

    Thanks,
    Dip

    Monday, January 10, 2011 1:33 PM
  • Hi,

    In Win 2K3

    Please check IIS is installed , if not then follow below steps to install it

    • Click Start, point to Control Panel, and then click Add or Remove Programs.
    • In Add or Remove Programs, click Add/Remove Windows Components.
    • In the Windows Components Wizard, under Components, select Application Server
    • Click Next.
    • After the wizard completes the installation, click Finish.

    In Win 2K8

    Please check IIS is installed , if not then follow below steps to install it

    • Click Start -> All Programs -> Administrative Tools -> Server Manager.
    • In the Server Manager window, scroll down to Roles Summary, and then click Add Roles.
    • Select Web Server (IIS) on the Select Server Roles page. An introductory page will open with links for further information.
    • Select the IIS services to be installed on the Select Role Services page. Add only the modules necessary. In this case, ASP.NET is selected, and a description of ASP.NET appears in the right pane. Once desired modules are added, click Next.

    And then try to run PSConfig wizard


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Monday, January 10, 2011 1:35 PM
  • Hi ,

    Thanks for your responses.

    im not able to find the WWW publishing service in Services.msc, Thought it is installed in IIS (in Add/Remove windows components, the WWW is checked in IIS)

    please Guide me in this.

    Monday, January 10, 2011 1:39 PM
  • Which server you are running ?

    uncheck IIS and complete the wizard and then again check it and run the wizard (for IIS service)

    (Like uninstall and install)


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Edited by Pratik Vyas Monday, January 10, 2011 1:42 PM add
    Monday, January 10, 2011 1:41 PM
  • hi,

    Thanks all for your guidence.

    the issue is resolved, by giving full control to administrators for svchost in regedit.

    Wednesday, January 12, 2011 5:30 AM