none
"Transfer to another location" action for List Based Retention Schedule not working RRS feed

  • Question

  • I have set up List Based Retention Schedule in SharePoint 2010, but I can't seem to get the "Transfer to another location" action to work. Here is what I have done:

    I set up a List Based Retention schedule (rather than a Content Type Policy) through Information management policy settings. I added a retention stage based off a date property on a custom field plus 1 day, with the action "transfer to another location" to copy the item to a destination location that I set up as a target through "Central Admin." For testing purposes, i have set the timer jobs for "Information management policy" and "Expiration policy" to run once per minute. Then I set my custom date field on a few of my items to two days prior to the current date. I have tried forcing the jobs to run by clicking Run Now. Nothing seems to happen, because the items do not appear in the location specified in the retention policy.

    Other than the destination location, the retention policy seems to be configured properly. I say this because I modified the retention stage, changing the action to "Permanently Delete." Once I did this, the items are in fact removed from my list as expected, once every minute, if the custom date field matches the criteria.

    I believe the destination location is valid, because I am able to move my items to it from my source list, using the Content and Structure interface. I can also sucessfully set up a workflow to copy items from the source list to the target location.

    Any ideas on how to solve this, or at least how to troubleshoot, would be greatly appreciated.

    Thursday, March 1, 2012 8:00 PM

Answers

All replies

  • Hello,

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Sally Tang

    Tuesday, March 6, 2012 3:51 PM
  • Hi Scott,

    Does any issues arise without the custom date field? If you could try and remove the custom date field just to eliminate things out of the troubleshooting process would be great.


    Below is also a great article as well that will help just to verify that retention is set up and configured properly for what you need done.


    http://blogs.msdn.com/b/ecm/archive/2011/10/12/policy-and-retention-in-sharepoint-server-2010.aspx

    Gregg


    MSFT

    Monday, March 26, 2012 9:23 PM
    Moderator
  • Were you able to get this to work? I've been trying to do the same thing. I also tried to use workflow to move the document but still not working. The only thing that seems to work is move the documents to recycle bin or delete permanently. I can't find a blog out there that was successfully create a list based retention policy to move documents. Perhaps this functionality is broken ootb?

    Saturday, August 18, 2012 10:41 PM
  • Were you ever able to resolve this? I am having the same issue with list based retention. My list doesn't use any custom date fields and like your case, a policy that sends the items to the recycle bin works but transferring to another location doesn't. This is very frustrating - and I will have to rethink how we are going to track information if I can't archive list items.

    Thanks.

    Monday, April 29, 2013 3:03 PM
  • Nope, we gave up and use custom workflow as a work around instead.

    Monday, April 29, 2013 8:57 PM
  • could you please let me know how did you resolve this. I have the same problem

    Thanks

    Thursday, March 20, 2014 8:44 PM
  • Transfer to another location works only with Document library because it uses the content organizer to send the document.. So anybody trying to get it done for list would net get it working...

    As an alternative use a workflow .. and the steps are here :

    https://www.youtube.com/watch?v=ZAkSEMW89Jw

    Thursday, October 9, 2014 4:29 PM