none
Suspended Workflow in SharePoint 2013 with HTTP 401 Error!

    Question

  • I have a list workflow which starts automatically when creating an item to generate a serial number. But when any user create a new item, the workflow suspend with the following details, and only the users with "Full Control" permissions can make the workflow work:

    RequestorId: eda26c74-95ef-2733-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 401 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["1"],"SPClientServiceRequestDuration":["88"],"SPRequestGuid":["eda26c74-95ef-2733-87b9-028d0512861d"],"request-id":["eda26c74-95ef-2733-87b9-028d0512861d"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"Cache-Control":["max-age=0, private"],"Server":["Microsoft-IIS\/8.0"],"WWW-Authenticate":["NTLM","Basic realm=\"sp.contoso.com\""],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Sun, 27 Apr 2014 11:13:07 GMT"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

    Sunday, April 27, 2014 12:04 PM

Answers

All replies

  • Hi AmrHanmam,

    According to your description, my understanding is that SharePoint 2013 workflow suspend with 401 error.

    For resolving your issue , please do as the followings:

    1. Be sure User profile synchronization is started.
    2. The user by whom you are logged is available in User Profile list.
    3. Final step full synchronization of User Profile Application.

    Here is a similar post for your reference:

    http://social.technet.microsoft.com/Forums/en-US/8671e31e-fde2-454c-aba4-0fc6484dd873/sharepoint-2013-workflow-suspend-with-401-error?forum=sharepointcustomization

    In addition, there is another reason for this issue, please take a look at:

    http://support.microsoft.com/kb/2839070/en-us

    I hope this helps.

    Thanks,

    Wendy


    Wendy Li
    TechNet Community Support

    Monday, April 28, 2014 6:30 AM
    Moderator
  • I checked it,, still same problem, I notice that the user can't open the Workflow settings page, as access denied.

    Any Help :( ?

    Wednesday, April 30, 2014 11:34 AM
  • Hi AmrHamam,

    Please use a user who has full control for the site, and compare the result.

    Please check whether this issue occurres on the entire site.

    Please try to re-register the workflow service using SPWorkflowService PowerShell command.

    If this issue still exsists, I suggest you re-configure the Workflow Manager for SharePoint 2013.

    I hope this helps.

    Thanks,

    Wendy


    Wendy Li
    TechNet Community Support

    Friday, May 02, 2014 3:04 AM
    Moderator
  • Hi Wendy, Thanks for your reply.

    Actually I removed the Workflow Manager and I Re- installed & Re-config it, but same issue.

    And When I use a user with Full Control permission, it works ! but any other user with any other permissions , it suspend !

    I still can't figure out the problem

    Sunday, May 04, 2014 12:34 PM
  • Hi,

    Please check if the link is useful:

    http://sharepointcreations.wordpress.com/2014/02/18/sharepoint-2013-workflow-cancels-automatically/

    Thanks,

    Wendy


    Wendy Li
    TechNet Community Support

    Friday, May 09, 2014 5:57 AM
    Moderator
  • Configure the user profile full service with my sites, feeds, Full synchronization, etc. Perform a search Full Synchronization in sps3.

    http://jaxsharepoint.blogspot.com.br/2013/08/setup-and-start-sharepoint-2013-user.html


    Daniel Fioqui - MCP/MCTS

    Wednesday, May 27, 2015 12:59 PM
  • Thanks, Wendy. My issue was with the sending of an email. I made the change suggested in your 2nd link and it worked for me.

    thanks again,

    David

    Thursday, January 07, 2016 8:02 PM
  • Hi!

    Please check permissions for account in User Profiles service:



    Independent SharePoint Developer, freelancer http://blog.sharepoint-develop.com/

    Thursday, June 30, 2016 5:07 PM
  • Hi,

    • Navigate to the site that the workflow is on in SharePoint 2013 Designer.
    • Go to All Files -> Lists
    • Right click on Workflow History
    • Select Properties
    • Click on Permissions for this list under the ‘Customization’ section (This should open up the edit permissions page in the browser)
    • Break inheritance on this list by selecting Stop Inheriting Permissions in the new opened browser window
    • Use the check box next to the appropriate group (probably the visitors group) to select the group that needs updated permissions
    • Select Edit User Permissions
    • Grant the group ‘Contribute’ permissions
    • Select OK
    • Reset IIS from Command prompt
    • Restart workflow associated services

    Problem will get fix. 

    Friday, July 01, 2016 12:10 PM
  • This helped out. Thanks.
    Friday, October 20, 2017 7:50 AM