none
User not receiving Sharepoint emails

    Question

  • Hi! I have a problem with a user in my Exchange 2010: He doesn't receive ANY sharepoint email.

    For example, I have a list with a simple workflow that sends an email to a "Assigned To" person. It works perfectly with any user of the Active Directory, except with this user.

    I've logged the SMTP server used by Sharepoint and I can see the emails Sharepoint sends for any user. However, when I put this user on the "Assigend To" field, any email message appears in the SMTP server, so, Sharepoint isn't sending any email for this user.

    Then I've enabled logging in Sharepoint, and I can see this message when Sharepoint try to send the email for the problematica user:

    Coercion (MultiEmailAddressSemicolon) warning: E-mail address not found for CONTOSO\Steve

    I've review ten times my AD record for that user, and all is ok. He has his email addres there. I've compared the AD record of one working user with this not-working user and I can't find any differences.

    I have noticed that users who do recieve the emails are shown in the "Assigend to" field with their display name, however users who don't receive the emails are shown in the "Assigned to" fied with their domain name. For example:

    • In the "Assigned to" field, a user that does receive Sharepoint emails looks like: Michael Farrow Logan
    • In the "Assigned to" field, a user that doesn't receive Sharepoint emails looks like: CONTOSO\Steve

    Can you help me?

    PD: We have Sharepoint 2010 + Exchange 2010 + Active Directory


    Thursday, June 27, 2013 10:36 AM

Answers

  • hi Thomas,

    SharePoint store all the user information at site collection level in a list called "User information" and this list is hidden

    deleted users from all the subsite can be find in this list. you can delete users from site collection[it include all the subsites] level using this list.

    to access this list

    >>Site Action>>Site Settings>>Site Permission>> open any group replace URL as shown below

    Original URL

    https://testsite/_layouts/people.aspx?MembershipGroupId=4

    to

    https://testsite/_layouts/people.aspx?MembershipGroupId=0

    then you can able to access user information list, Select user >>Action >delete users from site collection level

    Regards,

    karim


    Please remember to mark your question as "answered" if this solves your problem.

    Friday, June 28, 2013 4:23 PM
  • I've seen stuff in this area in the past but didn't get a good solution. One common thread i found was that the users were missing the email address in the user list. Given the error message you're getting that sounds probable here.

    If that's the case i'd check your AD for email re-direction or any oddities with that user. The second time i saw this problem the users were all imported from another AD forrest but also had email forwarding (i forget the technical term) items in AD. I didn't have time to dig into it in detail but it's worth a look i think.

    Have a look at the users in the hidden user list: http://sharepoint/sites/sites/_catalogs/users/simple.aspx and see if there's anything odd about their AD accounts (in particular check for duplicates or redirections).

    Thursday, June 27, 2013 1:14 PM

All replies

  • I've seen stuff in this area in the past but didn't get a good solution. One common thread i found was that the users were missing the email address in the user list. Given the error message you're getting that sounds probable here.

    If that's the case i'd check your AD for email re-direction or any oddities with that user. The second time i saw this problem the users were all imported from another AD forrest but also had email forwarding (i forget the technical term) items in AD. I didn't have time to dig into it in detail but it's worth a look i think.

    Have a look at the users in the hidden user list: http://sharepoint/sites/sites/_catalogs/users/simple.aspx and see if there's anything odd about their AD accounts (in particular check for duplicates or redirections).

    Thursday, June 27, 2013 1:14 PM
  • How can access the hidden user list??

    That path gives me a 404 not found. Can I access from Central Administration?

    Friday, June 28, 2013 8:20 AM
  • I can't get this page, even replacing sitecollectionA or subsite, or playing with any other. My main sharepoint site is http://sharepoint/default.aspx and the subsites are http://sharepoint/quality/default.aspx, http://sharepoint/garden/default.aspx, http://sharepoint/humanresources/default.aspx ...

    Is there any way to delete a user from sharepoint and then re-add?

    Friday, June 28, 2013 3:59 PM
  • hi Thomas,

    SharePoint store all the user information at site collection level in a list called "User information" and this list is hidden

    deleted users from all the subsite can be find in this list. you can delete users from site collection[it include all the subsites] level using this list.

    to access this list

    >>Site Action>>Site Settings>>Site Permission>> open any group replace URL as shown below

    Original URL

    https://testsite/_layouts/people.aspx?MembershipGroupId=4

    to

    https://testsite/_layouts/people.aspx?MembershipGroupId=0

    then you can able to access user information list, Select user >>Action >delete users from site collection level

    Regards,

    karim


    Please remember to mark your question as "answered" if this solves your problem.

    Friday, June 28, 2013 4:23 PM
  • IT WORKS!!!

    I went to http://mysharepoint/_layouts/people.aspx?MembershipGroupId=0 and delete the problematic user.

    Now he receives sharepoint emails without problem.

    Now, this user in Sharepoint isn't DOMAIN\Steve, now his name is Steve Farrow.

    I think when I delete the user from that Sharepoint list, sharepoint look for it into the Active Directory and then recreate the user.

    Thanks all of you.

    Monday, July 22, 2013 9:41 AM
  • I am facing the same issue and I want to try out the above solution. Could anyone please confirm as to what effect will deleting the problematic user have on the site permissions for that user.

    After deleting the user from here, will I have to add him back to the desired groups again?


    Regards, Pranav Khare

    Monday, February 24, 2014 9:32 AM