none
How to stop automatic login

    Question

  • As my organizations administrator  (I am not sure yet if that is a good thing) of Sharepoint server 2007, I have been attempting to activate or get working various features of Sharepoint.  I have a multiple monitor workstartion which allows me to have different IE windows open for easy viewing of what is going on.
    On one of the windows I may log in as the sharepoint administrator to activate a particular feature and on another monitor I want to run an IE window to test to see if it works for the average anomymous user.

    Sometimes the testing as the anomymous user looks like everything is good and then all of a sudden I am logged in as 'system account' and if I do not notice it I am getting a false impression that things are working good for the anomymous user.

    How do you prevent sharepoint (or IE?) from automatically switching from anomymous to loged in?

    Monday, August 18, 2008 5:55 PM

Answers

  • You can try the following and see if this works in your situation. I use this to login as different users.

    From your IE toolbar --> Tools --> Internet Options --> Security tab --> Select Local Intranet --> Click Custom level --> Scroll all the way down and under User Authentication/Logon  section --> Select prompt for username and password.
    Amit
    • Marked as answer by RAlltuck Monday, August 18, 2008 7:50 PM
    Monday, August 18, 2008 7:02 PM

All replies

  • Hello,
    Generally, this should not happen if you run separate instances of IE. In reality it happened to me few times too.
    What I am doing is using Opera browser to simulate anonymous user. There maybe other solutions but this works for me and it is quick.

    Regards
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Monday, August 18, 2008 6:31 PM
  • You can try the following and see if this works in your situation. I use this to login as different users.

    From your IE toolbar --> Tools --> Internet Options --> Security tab --> Select Local Intranet --> Click Custom level --> Scroll all the way down and under User Authentication/Logon  section --> Select prompt for username and password.
    Amit
    • Marked as answer by RAlltuck Monday, August 18, 2008 7:50 PM
    Monday, August 18, 2008 7:02 PM