none
Cannot backup VM - The filename, directory name, or volume label syntax is incorrect (0x8007007B)

    Question

  • Hello. We're trying to backup a VM running on a host (host-level backup). The operation always fails in DPM with the following error:

    'An unexpected error occurred while the job was running. (ID 104 Details: The filename, directory name, or volume label syntax is incorrect (0x8007007B))'

    Consistency check/reusme backup always ends up with this error. Removing the protected member and recreating it fails too.

    This is the only VM for which the backup is failing. It's running Linux OS. VM doesn't have any checkpoints (even the hidden backup ones). All VSS writers on the host are in stable/no error state.

    Monitoring the DPMRACurr.errlog on the host gives some insight, but no hints on how to solve this:

    (first there's a production checkpoint creation failure, which is to be expected, followed by successful crash-consistent checkpoint creation)

    2F94 1990 12/05 08:23:48.473 22 hypervutil.cpp(268) FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING ErrorDescription Checkpoint operation for '<VMNAME>' failed. (Virtual machine ID 21A51FEB-2C44-499E-B9AD-253834ED2FF6)
    2F94 1990 12/05 08:23:48.473 22 hypervutil.cpp(268) FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING Production checkpoints cannot be created for '<VMNAME>'. (Virtual machine ID 21A51FEB-2C44-499E-B9AD-253834ED2FF6) ErrorCode 32770
    2F94 1990 12/05 08:23:48.473 31 hypervrcthelperplugin.cpp(92) [000001A3D7D8E2E0] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING App Consistent snapshot failed, trying crash consistent snapshot
    2F94 1990 12/05 08:23:53.739 22 hypervutil.cpp(1761) FE7CA82A-5171-4FF6-9990-EB38A3C59E7B NORMAL Snapshot got created with Id: Microsoft:277CB209-2D60-43E0-B9C2-1C51A9F4C643

    (then there are more messages, some errors - not of consequence in my opinion, but later there are these errors):

    2F94 1C08 12/05 08:24:12.473 18 diskfixupreader.cpp(530) [000001A3D7E84D40] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING Failed: Hr: = [0x80070057] Error in Getting checksum buffers, previous failure Hr: = [0x80070057]. Can not continue on failure
    2F94 1C08 12/05 08:24:12.473 18 checksumprovider.cpp(223) [000001A3D801FCF0] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING Failed: Hr: = [0x80070057] : Unexpected end of buffers while reading checksums: lVal : E_INVALIDARG
    2F94 1C08 12/05 08:24:12.473 18 checksumprovider.cpp(223) [000001A3D801FCF0] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING Failed: Hr: = [0x80070057] : Unexpected end of buffers while reading checksums: lVal : E_INVALIDARG
    2F94 1C08 12/05 08:24:12.473 18 diskfixupreader.cpp(414) [000001A3D7E84D40] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING Failed: Hr: = [0x80070057] : Encountered Failure: : lVal : m_pChecksumProvider->GetChecksums(&m_pbInChecksumBuffer, &m_dwInChecksumBufferSizeInBytes)
    2F94 1C08 12/05 08:24:12.473 18 mtfdisk.cpp(665) [000001A3D7FEF700] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING Failed: Hr: = [0x809909d3] GetNextStream failed on disk(D:\vms\<VMNAME>_disk.vhdx)
    2F94 1C08 12/05 08:24:12.473 18 dsmsendersubtaskbase.cpp(588) [000001A3D8109100] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING Failed: Hr: = [0x809909d3] SendData() failed
    2F94 1C08 12/05 08:24:12.473 18 dsmsubtaskbase.cpp(265) [000001A3D8109100] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B NORMAL Hr: = [0x809909d3] CDsmSubTaskBase::ErrorCleanup: subtask state: 1

    and more errors:

    2F94 1990 12/05 08:24:12.473 03 cbackupsubtask.cpp(653) [000001A3D5585A20] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING <?xml version="1.0"?>
    2F94 1990 12/05 08:24:12.473 03 cbackupsubtask.cpp(653) [000001A3D5585A20] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B WARNING <Status xmlns="http://schemas.microsoft.com/2003/dls/StatusMessages.xsd" StatusCode="-2147014842" Reason="Error" CommandID="RAReadDatasetFixup" CommandInstanceID="26b774a3-c5ee-44bb-b285-690b31e23ac0" GuidWorkItem="d67448fb-6a0b-40b8-8c4b-b43418c987fa" TETaskInstanceID="fe7ca82a-5171-4ff6-9990-eb38a3c59e7b"><ErrorInfo xmlns="http://schemas.microsoft.com/2003/dls/GenericAgentStatus.xsd" ErrorCode="998" DetailedCode="-2147014842" DetailedSource="2"/><RAStatus><RAReadDatasetFixup xmlns="http://schemas.microsoft.com/2003/dls/ArchiveAgent/StatusMessages.xsd"><LWVStatus BytesTransferred="1844" NumberOfFilesTransferred="10" NumberOfFilesFailed="0" DataCorruptionDetected="false"/><FixupStatus BytesTransferred="75694080" NumberOfFilesTransferred="8" NumberOfFilesFailed="1" DataCorruptionDetected="false"/></RAReadDatasetFixup></RAStatus></Status>
    2F94 1990 12/05 08:24:12.473 03 runtime.cpp(1373) [000001A3D5658ED0] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B FATAL Subtask failure, sending status response XML=[<?xml version="1.0"?>
    2F94 1990 12/05 08:24:12.473 03 runtime.cpp(1373) [000001A3D5658ED0] FE7CA82A-5171-4FF6-9990-EB38A3C59E7B FATAL <Status xmlns="http://schemas.microsoft.com/2003/dls/StatusMessages.xsd" StatusCode="-2147014842" Reason="Error" CommandID="RAReadDatasetFixup" CommandInstanceID="26b774a3-c5ee-44bb-b285-690b31e23ac0" GuidWorkItem="d67448fb-6a0b-40b8-8c4b-b43418c987fa" TETaskInstanceID="fe7ca82a-5171-4ff6-9990-eb38a3c59e7b"><ErrorInfo xmlns="http://schemas.microsoft.com/2003/dls/GenericAgentStatus.xsd" ErrorCode="536872931" DetailedCode="-2147014842" DetailedSource="2"><Parameter Name="AgentTargetServer" Value="server.domain.com"/></ErrorInfo><RAStatus><RAReadDatasetFixup xmlns="http://schemas.microsoft.com/2003/dls/ArchiveAgent/StatusMessages.xsd"><LWVStatus BytesTransferred="1844" NumberOfFilesTransferred="10" NumberOfFilesFailed="0" DataCorruptionDetected="false"/><FixupStatus BytesTransferred="75694080" NumberOfFilesTransferred="8" NumberOfFilesFailed="1" DataCorruptionDetected="false"/></RAReadDatasetFixup></RAStatus></Status>

    Any idea what the actual problem is and how to fix it?

    Thanks


    • Edited by MarkosP Monday, April 8, 2019 7:57 AM
    Tuesday, December 5, 2017 8:40 AM

All replies

  • Did you fin a fix for this as I am having the same issue on 5 of my backups
    Friday, April 5, 2019 11:36 AM
  • Hi. Don't think I ever had this resolved. We've probably ended up upgrading the guest OS, but I don't remember to be honest.
    Monday, April 8, 2019 7:56 AM
  • Hi..

    we are running in the same problem a several times, after recreating VM backups in DPM.

    I tried many things. The only workaround that works for us:

    Simply move any vhd(x) and avhd files to the root vm folder. You can use the cluster manager to do this at runtime:

    Move Disks from C:\ClusterStorage\...\VM1\Virtual Hard Disks

    to C:\ClusterStorage\...\VM1\

    After that (delete the existing backup set from dpm first) enable dpm protection again and pray :)

    Friday, May 17, 2019 7:33 AM