none
Fresh install SCOM 2016 Web Console - Error 500 RRS feed

  • Question

  • Hi

    I have installed a fresh installation of SCOM 2016 Web Console (http://localhost/OperationsManager/) though when i test the site it throws a "Error 500".

    I tried to verify the settings for Application Pool so that it have access to the directory, and if i change the application pool from .Net 4 to .Net 2 it throws a "

    HTTP Error 500.19 - Internal Server Error

    and "

    Config Error

       The configuration section 'uri' cannot be read because it is missing a section declaration 

    Anyone have any suggestions?

    Regards,

    Stefan

    Friday, November 4, 2016 8:31 AM

Answers

  • we installed the SCOM 2016 webconsole on a separate server (not a management server). Then switched to SSL / windows authentication.

    I was able to open the https://localhost/operationsmanager locally, I also was able to open the https://FQDN/OperationsManager, and on the primary management server I was also able to open it via the FQDN but the site always threw a 500 internal server error from any other system, or on some servers it partially opened the website - only the top bar with my name and monitoring... the rest was empty.

    there is NO need to make any changes to the application pools, on the default website where the Operations Manager is installed into, I also disabled anonymous authentication. and windows authentication has negotiate on top and NTML as second (default setting) for all sites (OperationsManager and MonitoringView)

    the simple fix:

    in the IIS console, open Default website, select Operations manager in the left pane, and in the right pane, at the bottom open Configuration Editor: section: System.webserver/security/authentication/windowsAuthentication:  set "useAppPoolCredentials" to true

    once that is done, reset the website (either commandline IISRESET /restart) or in the IIS console

    that instantly fixed our issues.... now I can open the site via my laptop or any other system...


    • Marked as answer by hulting74 Wednesday, January 4, 2017 3:38 PM
    • Edited by A. Prins Thursday, January 5, 2017 8:45 AM
    Wednesday, January 4, 2017 9:17 AM

All replies

  • Hi,

    The similar issue here :

    https://social.technet.microsoft.com/Forums/systemcenter/en-US/35b77e18-3ce5-4579-b3e5-3eb3c511fc7b/operations-manager-2012-r2-web-console-gives-http-500-error-when-active-alerts-tab-is-selected?forum=operationsmanagergeneral

    PAUL

    Thursday, November 10, 2016 6:50 AM
  • Hi, thanks for the feedback Paul.

    But sadly, no luck.

    The Strange part is that i tried to access the site with a domain admin user, and then it works ???

    Tried with any other user, i get the Error 500 message. Then i tried to escalate a user to domain admin and tried with that = error 500 message again.

    I have followed the iinstallation instruction on microsoft page to install the SCOM 2016 Web Console. 

    I also tried to reinstall the whole Web Console but still no luck.

    Regards,

    Stefan

    Thursday, November 10, 2016 8:42 AM
  • Did you ever fix this? I'm having the same issue too...only Domain Admin works, anyone else gets 500 error
    Wednesday, November 16, 2016 4:27 PM
  • Hi

    Nope :-(

    Though i have successfully done a workaround, by installing the Web Console on the same machine as the Management Server.

    I installed the Web Console with "Windows Integrated" and not the "Mixed Mode".

    I rather would have it installed on a separate machine, but i suspect there is some authentication issue or possibly a delegation issue.

    Regards,

    Stefan

    Friday, November 18, 2016 1:38 PM
  • The same problem standalone (no other roles) machine Windows 2012 R2

    Installation as default as possible:

    - Default Website (no ssl)

    - Network authentication

    and UR1 installed

    Regards Marco


    • Edited by Marc0_ Friday, November 18, 2016 3:17 PM
    Friday, November 18, 2016 3:15 PM
  • When i change the web.config to use mixed instead of network authentication after the installation the site is working.

    Goal is still getting network authentication to work one day

    • Edited by Marc0_ Tuesday, November 22, 2016 2:42 PM
    Tuesday, November 22, 2016 2:40 PM
  • Hi Sir,

    Have you checked the following article regarding SCOm Console installation :

    https://technet.microsoft.com/en-us/library/hh298606(v=sc.12).aspx

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 5, 2016 1:43 PM
    Moderator
  • Not sure if you have moved on from this but it has had me pulling my hair out.

    What I have found is for some reason the WebApp paths for MonitoringView and OperationsManager have been flipped.

    This works fine when using mixed authentication but fails miserably when using Network Authentication.

    Going to https://yourscomserver/MonitoringView will bring up the logon form, and logging on will then bring up a blank page...

    Next up I changed the path for MonitoringView from Program Files\Microsoft System Center 2016\Operations Manager\WebConsole\WebHost to Program Files\Microsoft System Center 2016\Operations Manager\WebConsole\MonitoringView

    &

    OperationsManager from Program Files\Microsoft System Center 2016\Operations Manager\WebConsole\MonitoringView to Program Files\Microsoft System Center 2016\Operations Manager\WebConsole\WebHost

    After doing this the apppools will need to be granted read permissions recursively to the relative directories.

    This put me in the same boat as before, a successful logon and a blank grey page.

    Using Firefox or Chrome I get an unsupported browser page as it depends on Silverlight...I thought the webconsole was HTML5 now.

    Wednesday, December 21, 2016 10:43 PM
  • Looks like the user account you're using for your app pool doesn't have rights to the web site directory, so it can't read config from there.  Check the app pool and see what user it is configured to run as.  Check the directory and see if that user has appropriate rights to it.  While you're at it, check the event log and see if IIS logged any more detailed diagnostic information there.

    Roger

    Thursday, December 22, 2016 4:02 AM
  • we installed the SCOM 2016 webconsole on a separate server (not a management server). Then switched to SSL / windows authentication.

    I was able to open the https://localhost/operationsmanager locally, I also was able to open the https://FQDN/OperationsManager, and on the primary management server I was also able to open it via the FQDN but the site always threw a 500 internal server error from any other system, or on some servers it partially opened the website - only the top bar with my name and monitoring... the rest was empty.

    there is NO need to make any changes to the application pools, on the default website where the Operations Manager is installed into, I also disabled anonymous authentication. and windows authentication has negotiate on top and NTML as second (default setting) for all sites (OperationsManager and MonitoringView)

    the simple fix:

    in the IIS console, open Default website, select Operations manager in the left pane, and in the right pane, at the bottom open Configuration Editor: section: System.webserver/security/authentication/windowsAuthentication:  set "useAppPoolCredentials" to true

    once that is done, reset the website (either commandline IISRESET /restart) or in the IIS console

    that instantly fixed our issues.... now I can open the site via my laptop or any other system...


    • Marked as answer by hulting74 Wednesday, January 4, 2017 3:38 PM
    • Edited by A. Prins Thursday, January 5, 2017 8:45 AM
    Wednesday, January 4, 2017 9:17 AM
  • Hi,

    I have the same error on fresh installed SCOM 2016.

    But your solution did not solve the issue.

    Is there perhaps any other point to be considered?

    Here is my open ticket:

    https://social.technet.microsoft.com/Forums/en-US/b1ef7861-2ef8-4a2a-9bf6-d4c527fb5dbf/internal-server-error-500-scom-2016-web-console?forum=operationsmanagerdeployment

    Best Regards

    Birdal

    Thursday, May 4, 2017 12:05 PM
  • Is there any update on this?

    Seven months later and this issue is still here, even with UR3.

    Considering just how expensive System Centre is, I cannot believe that a product like this can be shipped with glaring, fundamental flaws in it such as in this instance.

    As with the previous people, we have run a fresh install of SCOM Web Console 2016 on a brand new, clean Server 2016 server.... Error 500 upon launch of the console when using Network Auth. We would expect this to work out of the box. There shouldn't be any need whatsoever to go fiddling with IIS to get this to "work to a fashion".

    I am sorry, however to be quite honest with you, this is bollocks. This is incredibly frustrating for us.

    Matthew

    Tuesday, June 20, 2017 2:19 PM
  • Guys,

    Any luck on this? I am also facing this problem in SCOM 2016 environment, we have installed fresh setup of SCOM 2016, but getting 500 error while opening the webconsole remotely or from network. It works fine if we open it from locally (from webconsle) server. your help is appreciated.

    Regards,

    Vaibhavi


    Friday, July 21, 2017 3:06 PM
  • Guys,

    Any luck on this? I am also facing this problem in SCOM 2016 environment, we have installed fresh setup of SCOM 2016, but getting 500 error while opening the webconsole remotely or from network. It works fine if we open it from locally (from webconsle) server. your help is appreciated.

    Regards,

    Vaibhavi


    By any chance have you Installed the Web console on a Stand alone server or is this installed in MS ?

    This is a know issue if this is a standalone Web console server and you will need to register SPN with http and delegate the MS Computer account in AD and the web console server will work.


    Gautam.75801

    Sunday, July 23, 2017 5:08 PM
  • Hi Gautam,

    Thanks for your response. We have installed it on standalone server not on MS server. Ok will try this and confirm.

    Regards,

    Vaibhavi

    Wednesday, July 26, 2017 12:47 PM
  • Hi Vaibhavi,

    So you need to use the below command:

    In this example my Web console server name is "scom_agent" , Hence replace it with your Web console name.

    setspn -a http/scom_agent scom_agent
    setspn -a http/scom_agent scom_agent.systemcenterinfra.net    (used fqdn here for the 2nd one)

    you will need to register the SPN on the Management servers as well for the SDK Account as per Kevin's article:

    https://blogs.technet.microsoft.com/kevinholman/2011/08/08/opsmgr-2012-what-should-the-spns-look-like/

    Now go to your AD and on all the Management servers in the Management group change the delegation as below for the computer account of the Management servers.

    Now do the below change in the AD for the Web console server account:

    NOTE - In the above highlited RED part as i have only 1 Management server i added its SDK SPN in the delegation.

    If you have multiple Management servers, All the Management servers SPN for SDK has to be added here.

    Post this go the SCOM Web console server and do a iisreset and the web console should work.


    Gautam.75801

    Wednesday, July 26, 2017 1:00 PM
  • I've tried every tip in this post, as well as opsconfig

    However, I cannot, for the life of me, get the Web Console (installed on my RMS Server 2016 / IIS 10) to work if installed in Network Authentication mode without getting the 500 error.  I've verified all my SPNs per KH's blog - KH - SPNs (hoping these still apply exactly for SCOM 2016).  The posts marked as answers have not helped me at all. 

    Can anyone please provide a complete step by step to installing a working Web Console for SCOM 2016 in Network Authentication Mode on Server 2016 / IIS 10


    B. Wright


    • Edited by B. Wright Tuesday, November 21, 2017 4:49 PM added web links
    Tuesday, November 21, 2017 4:47 PM
  • Hi There,

    I guess Network Authentication has some issues. So it may not work. Try with Mixed and see if it works.

    I am not sure if that was fixed in any UR's.


    Gautam.75801

    Tuesday, November 21, 2017 5:00 PM
  • I've applied UR4, and Network Authentication is still boned.  The ONLY way I can get it to work is in Mixed Mode, but it's not desirable because my SCOM users are in different forests than my SCOM servers and want to avoid the pop-up login and the need for qualifying the user name (in IE) with the domain.  

    Seems like this should be pretty simple, and Microsoft dropped the ball.... In SCOM 2012 the Web console install in Net. Auth. mode was a no brainier, and it just worked.


    B. Wright

    Tuesday, November 21, 2017 5:09 PM
  • Does ANYONE have an answer for this issue?  Seems to me that there would be one full-proof solution by now, but all the 'pokes and hopes' that I've found on these forums have not solved this 500 error when installing the web console in network authentication mode (on RMS or remote IIS server).  It hasn't mattered what I do.  One, many, or all the above fixes.  Microsoft, please explain!

    B. Wright

    Thursday, November 30, 2017 2:38 PM
  • There's no 1 answer probably.

    I ran into this issue because the SPN of the management servers wasn't correct. What the spn should look like

    Also the SPN of the webserver should be registered. The setting in administration in scom should be the same as this spn and the webserver delegation should be set to "trust this computer for delegation to any service (kerberos only)"

    Gautam is incorrect in setting it to "use any authentication protocol" At least i just want to use kerberos... Also he's probably incorrect about the adding of all management servers spn's, allthough it depends on how you installed your MG, if ppl follow kevin holman's guides the spn is set to an account and not to all servers.

    The use "apppoolcreds" solution could probably work too, but not on a default installed webconsole, only when you use an account for the apppool that has rights in scom. I don't recommend to do this.


    Rob Korving
    http://jama00.wordpress.com/


    • Proposed as answer by rob1974 Thursday, December 21, 2017 10:55 AM
    • Edited by rob1974 Thursday, December 21, 2017 10:59 AM
    Thursday, December 21, 2017 10:55 AM
  • This did not fix or make the configuration consistent.  This is not a valid answer.

    B. Wright

    Wednesday, January 3, 2018 2:50 PM
  • Hi,

    „500 – Internal server error“ is a bug in SCOM 2016 Web Console.

    I found the bug and solved this issue. Perhaps this can be applied also on SCOM 2012.

    https://social.technet.microsoft.com/Forums/en-US/68b6ee3b-ba7c-4dcd-8020-7300db43663e/bug-in-microsoft-scom-2016-web-console-500-internal-server-error-solved-?forum=operationsmanagerdeployment

    I posted my article to the General Operations Manager Feedback:

    https://systemcenterom.uservoice.com/forums/293064-general-operations-manager-feedback/suggestions/33008239-bug-in-microsoft-scom-2016-web-console-500-int

    Good Luck!

    Birdal


    Friday, January 19, 2018 1:21 PM
  • running scom 2016 

    same thing works on web server but does not work on workstations. changed to the settings you recommend same thing still getting page cant display http 500 error, 

    Sunday, November 24, 2019 1:53 AM