MOSS 2007, error 6482 repeating every 30 seconds


  • When I look in the application logs for the machine that's running MOSS 2007 I can see the following error:

    Type: error
    Source: office server shared services
    Event: 6482
    User: N/A


    This error is being logged every 30 seconds since at least a couple of weeks back and I can't get it to stop. I've tried googling for error 6482 but I haven't found a solution for it.


    The server is running windows 2003 R2 Standard Ed. (with SP2),MS SQL 2005 (think it's Enterprise, im 100% sure its not Express version anyway) and MOSS 2007.


    Anyway, the full info when opening one of the errors is the following:


    "Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchAdminSharedWebServiceInstance (0df54aa0-a97a-42b5-9d3e-b875cfce3986).

    Reason: The path specified cannot be used at this time. (Exception from HRESULT: 0x80070094)

    Techinal Support Details:
    System.Runtime.InteropServices.COMException (0x80070094): The path specified cannot be used at this time. (Exception from HRESULT: 0x80070094)
       at System.DirectoryServices.DirectoryEntry.CommitChanges()
       at Microsoft.SharePoint.Metabase.MetabaseObject.Update()
       at Microsoft.SharePoint.Administration.SPProvisioningAssistant.ApplyIisVirtualDirectorySettings(VirtualDirectory virtualDirectory, String path, AccessFlags accessFlags, String applicationName, String applicationPoolId, String[] scriptMaps)
       at Microsoft.SharePoint.Administration.SPProvisioningAssistant.ProvisionIisRootVirtualDirectory(WebSite webSite, String path, AccessFlags accessFlags, String applicationName, String applicationPoolId, String[] scriptMaps)
       at Microsoft.SharePoint.Administration.SPProvisioningAssistant.ProvisionIisWebSite(String serverComment, String[] serverBindings, String[] secureBindings, AuthenticationMethods authenticationMethods, String[] authenticationProviders, String path, AccessFlags accessFlags, String applicationName, String applicationPoolId, String[] scriptMaps, String sslCertificateSubjectName)
       at Microsoft.SharePoint.Administration.SPMetabaseManager.ProvisionIisWebSite(String serverComment, String[] serverBindings, String[] secureBindings, Int32 authenticationMethods, String[] authenticationProviders, String path, Int32 accessFlags, String applicationName, String applicationPoolId, String[] scriptMaps, String sslCertificateSubjectName)
       at Microsoft.Office.Server.Administration.SharedWebServiceInstance.Synchronize()
       at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

    For more information, see Help and Support Center at"


    I would really appreciate some help on how to get rid of this annoying error. I haven't made any changes on this server for a long time, the error just suddenly appeared out of nowhere.


    Any suggestions on what I should try to remedy this?



    • Edited by Mike Walsh FIN Friday, July 03, 2009 4:00 PM ! removed from Title
    Monday, August 06, 2007 7:18 AM


All replies

  • I have the same error...


    Wednesday, August 08, 2007 10:28 PM
  • I may not have had the same problem, but here's a rough description:

    • Event 6482 appearing as you described, every 30 seconds
    • 2 other events (I don't remember what they were) would also appear every 30 seconds
    • Several odd things happening on the farm (e.g. "search settings" page on SSP wouldn't load)
    • We had made MANY configuration/SSP changes in the course of troubleshooting another error

    You won't like to hear this, but a complete farm re-install (new configuration database) fixed the "6482" event logs.

    Thursday, August 09, 2007 3:24 PM
  • Reboot fixed this for me (so far)


    Friday, August 10, 2007 2:26 PM
  • I have rebooted this server several times and it helps a few days, or up to a week, after that the errors always come back again for me. I actually have the same setup on two different servers, and BOTH have this annoying problem, the second server is almost newly installed. I begin to think this is a huge bug in MOSS.


    Also I've noticed another problem related to this (I think). As soon as I get this error on a server (either sometime after a fresh install or recent reboot) I cannot longer open the IIS configuration tool. The IIS tool will load but wont show the usual tree view and I cannot connect manuallt to get it either. The only way to fix this is another reboot and the IIS tool will load as normal until X days later when my logs are being spammed with 6482 error again, after that I get no contents again.


    This is HUGELY annoying and I'm seriously thinking of abandoning sharepoint completely because of it, it' seems SP isnt that finished yet, more of a beta or something (and yes, I am running the full retail MOSS, properly registered.).


    Friday, August 10, 2007 3:18 PM
  • Yes, this is exactly the same problem I'm having.

    I have two completely different MOSS installs, reboot helps for a few days, errors start appearing in the event log, IIS configuration tool stops working, running an IIS reset hangs the service and I have to reboot the server again.

    This only happens on my servers running the search service (search indexer).


    I don't have the option of abandoning MOSS so I need to get this fixed...

    I'm going to send this to Microsoft Support today and see what I get. I'll post anything I find out.

    Friday, August 10, 2007 3:25 PM
  • I hate to tell you two, but this does sound like our problem, especially the "IIS administration breaks every so often" part. And you still won't like to hear that we eventually did a full SharePoint farm reinstall to fix the problem (and yes, we called PSS).


    Best of luck Smile

    Friday, August 10, 2007 5:17 PM
  • The problem is, I have already reinstalled one of theese machines from scratch (HDD formatted, reinstalled OS, SQL, MOSS and so on) and now I have got that dreaded error again on the same machine! It seems this error can start to occur anytime and it really needs to get fixed.


    I work for a consultant company and If we can't get MOSS 2007 to work even on our own internal lab machines used for testing, how are we supposed to sell a solution based on that to any customers ?!


    I really hope MS is aware of this big problem and will release a patch for it asap.


    Friday, August 10, 2007 5:30 PM
  • Some questions and suggestions...


    What configurations have you reproduced this problem with? (How many web front ends and running what services)

    If you have multiple web front ends, do you have a dedicated server for crawling? Is this the only server with the error?

    If you change the search to use all web front ends for crawling and reboot, does the error come back?


    Have you installed KB 923028?

    Have you tried creating a new SSP? (I found some info that suggested this error was due to a "corrupted" SSP)


    I have some other options I'm looking into and Microsoft is also researching...

    Friday, August 10, 2007 6:22 PM
  • Sofar both our test machines have been installed as standalone servers running everything themselves, so they have the roles of front-end, search and sql database all at the same time. We want to try some other scenarios with several servers having different roles also, but we would like to get this standalone setup to work properly first.


    Regarding the KB923028, that was the first thing I tried when we encountered this error a month back or so. It didn't help at all, the error dissappeared a few days (due to the server reboot i think) but then it came back again.


    I currently have three SSP's on one of the servers (the one I'm focusing on right now) but I haven't created any new SSP's on any of those servers since the errors started. Do you suggest I make a new SSP, move the web applications to this one and delete the old SSP ?


    Another thing, I looked closer in the eventlog today and saw that it is in fact two slightly different errors that reappears periodically. They both have the same event nr and similar descriptions though.


    First comes:

    "Error   YYYY-MM-DD   HH:MMTongue TiedS   Office Sharepoint Server   Office Server Shared Services   6482   N/A"

    and looking at the details it says:

    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchAdminSharedWebServiceInstance (0df54aa0-a97a-42b5-9d3e-b875cfce3986).

    Reason: The path specified cannot be used at this time. (Exception from HRESULT: 0x80070094)


    and exactly 30 seconds later the following is being reported:

    "Error   YYYY-MM-DD   HH:MMTongue TiedS   Office Sharepoint Server   Office Server Shared Services   6482   N/A"

    but looking at the details it says instead:

    Application Server Administration job failed for service instance Microsoft.Office.Excel.Server.ExcelServerSharedWebServiceInstance (67f313c3-fdd1-4505-9ee4-43d506df3488).

    Reason: The path specified cannot be used at this time. (Exception from HRESULT: 0x80070094)


    Exactly two minutes later the first error reappears again, then 30 sec later the second one ... and it continues like this forever.



    Monday, August 13, 2007 9:05 AM
  • We have the same problem in our development environment. We currently only have one front-end/application server but the database server is separate. Any fix would be greatly apprcciated.




    Tuesday, August 14, 2007 7:12 AM
  • Did you try to stop "Office Server Search" service on Central Admin console, reboot the box, and try to start this service again.


    After these steps are done, then try to reindex the MOSS site again.  It might be wrong URL of the site.






    Tuesday, August 14, 2007 2:20 PM
  • I did all the mentioned above today, now we have to wait (because of the reboot) and see if the error returns or not.


    I'm not that hopeful though, many people seem to have this problem and being unable to fix it without a complete farm reinstall.

    Wednesday, August 15, 2007 10:59 AM
  • SharePoint 2007 stop working: Errors seen in event viewer are 6482 and 6398. Neither Central Adm site nor the site in service isnt working. And still searching for the solution Sad

    Thursday, August 16, 2007 3:17 PM
  • I'm also getting the same errors as the initial post logged repeatedly. I wish there was a fix for this.

    Monday, August 27, 2007 5:27 AM
  • Hi at all.


    I'm reach some information here:


    So to fix the problem, you have to use the same account for the all service in your MOSS farm and this account must be the dbowner lf all MOSS db



    Monday, August 27, 2007 12:27 PM

    We had 6398 and 6482 repeatingly. We were supported by Microsoft Support Technician but we couldnt solve it. We were suggested to attach the database to a new MOSS server.
    Monday, August 27, 2007 12:40 PM
  • Hello! I have the same problem too.

    Can anybody help me?

    Friday, September 14, 2007 9:38 AM
  • I have the same problem, and if you open IIS you will probably find that it opens but you cannot expand it down to view your web sites.  The only way to get that part working again is to run "IISreset" from the command prompt on the server. Rebooting the server cures this problem for a while, but I have found that it returns.


    Our environment is 2 front end web servers and 2 SQL servers clustered and hardware load balanced.  I have tried the .NET fix, but this did not work, I have tried the " Timer Job Definition" fix


    But that does not work either.  I have found that rebooting works for a few weeks in our environment.  The odd thing is that my servers are load balanced and I do not get the problem on the second server.


    Are thre any updates on this situation as this is a very common problem?





    Monday, October 08, 2007 11:16 AM



    I had the same issue.  I've just added the search Service Accounts to allow "Log on as batch job" in the "local security policy" settings.  This appears to have fixed the error on my servers.


    I hope this helps,



    Wednesday, October 17, 2007 8:40 AM
  • Update: although I mentioned earlier we did a complete farm reinstall to clear out the problems, it turns out that was temporary. These errors resumed sometime later (I don't know when).


    I was able to permanently (thus far) fix this, with minimal work, by following the steps mentioned in this article:



    NOTE: the actual steps I took were:



    stsadm -o updatefarmcredentials etcetc

    iisreset /noforce



    The first iisreset is required to be sure the "stsadm -o updatefarmcredentials" command successfully completes.

    Thursday, November 01, 2007 10:38 PM
  • try this:


    Computer management

    Expand services and applications

    Expand IIS

    Expand app pools

    Right click app pool for moss web app


    The first three options are for recycling worker process based on...


    Make sure these are unchecked, as well, the memory limits and this should fix those errors.


    Wednesday, November 07, 2007 6:49 PM
  • I've seen this error several times: some things I've done to fix it:


    1.0 Some times when it is in a fram it is not fht front end server that seems to be having the problem. But one of the other servers.


    2.0 I've reran the sharepoint configuration tool if that fails then I rerun the asp 2.0 dont net and execute a repair. then rerun the sharepoint configuration tool this almost always fixes this problem.


    The isue seems to be some sort of coruption of files.

    Thursday, January 03, 2008 4:25 PM
  • Just to close out this thread...


    I believe the verified fix is KB 946517. I have installed it on two servers that have experienced this issue and have not seen the errors again.

    • Proposed as answer by David29 Tuesday, November 24, 2009 3:41 PM
    • Marked as answer by Mike Walsh FIN Monday, March 01, 2010 10:18 AM
    Tuesday, February 12, 2008 8:46 PM
  • So far so good, your solution has worked for me


    Making sure that my service account's username and password are correct before running that command


    stsadm -o updatefarmcredentials -userlogin <domain\username> -password <newpassword>


    Now I see my service account's name in the application log.

    Tuesday, June 10, 2008 6:20 PM
  • This worked for me.  I found it in an old email of mine.

    ·         I noticed in the Computer Management – Event Viewer – Application log that there were hundreds of 6398, 6482 and 7076 errors, something to the effect of corrupted data or memory.  Solution: I remember having the problem earlier, so I searched my mail and found the following answer. You have to go and repair the MOSS Program.  This is done by going into control panel>add remove program> clicking the change button on the Microsoft Office Sharepoint Server 2007> and then clicking repair.  After it repairs itself it tells you to reset the server and then run the “Sharepoint Products and Technology Configuration Wizard”.  After resetting the server, go to start>all programs>Microsoft office server> and select the wizard.  It will ask you a bunch of questions which run through the thought of “are you restarting or continuing?”.   After telling them that we are continuing, it will run what it needs to and finish.  The errors will have stopped from running

    Beginner Moss Guy
    Thursday, August 07, 2008 5:55 PM
  • VetteKerry's got the right idea.  The KB article refers to an IIS/AD issue that the hotfix resolves.

    - M
    - Michael Mukalian - MCTS: MOSS 2007 Configuration -
    Thursday, August 07, 2008 6:22 PM
  • Yes, it would work.  However, when I tried installing the hotfix I received some error, which required me to re-install moss.  I am assuming that there might be more than one cause and solution to the issue, but what I tried (above) worked for me.

    Beginner Moss Guy
    Thursday, August 07, 2008 6:25 PM
  •  The Hotfix does not work for Server 2003 x64 R2.  So, I still need a solution.
    Wednesday, August 13, 2008 4:39 PM
    After much research found the following KB and Hotfix for the 6398, 6482 and 7076 errors:

    However, while installing the Hotfix, I received the following error message "Error 1324. The folder 'Program Files' contains an invalid character"
    So I found this KB:

    Error message when you try to install a security update for the .NET Framework 2.0 on a computer that is running Windows Server 2003 x64 Edition: "Error 1324. The folder 'Program Files' contains an invalid character"

    Wednesday, August 13, 2008 8:04 PM
  • You can try this solution :

    1 - Stop "Office SharePoint Server Search" from Central Admin in all your servers farm.
    2 - Reboot all your servers
    3 - Delete Index Folder on yours servers
    4 - Start "Office SharePoint Server Search" on your first server (indexing office server search)
    5 - Create your index folder on your indexing office server search.
    6 - start "Office SharePoint Server Search" on yours others servers (query office server search). Check "Configure share automatically".
    7 - In my case errors are gone.

    Friday, August 29, 2008 2:45 PM
  •  have yopu guys tried the KB946517 this seems like a windows 2003 issue rather then a moss issue, please see

    -Rohit Rajdev

    Sunday, January 25, 2009 5:08 PM
  • have the same issue!
    1. "Log on as batch job" - didn't help me
    2. fix - didn't help

    PS what is "Index Folder" exactly?
    Friday, July 03, 2009 3:48 PM
  • Hi all

    Same problem here

    Did anyone know the solution.

    Monday, March 01, 2010 10:03 AM
  • Hi

    My Problem got sloved

    The password for the WSS Search service was expired. I have re-set the password to old in the AD (LDAP)  and restarted the service the problem is solved.

    • Proposed as answer by Harish D Tuesday, March 02, 2010 3:11 AM
    • Unproposed as answer by Mike Walsh FIN Wednesday, March 03, 2010 11:05 AM
    Tuesday, March 02, 2010 3:11 AM
  • Hi All,

    i am facing an issue with crawling. Incremental crawl is used to happen in an hour now suddenly it taking more then 15 hours and Farmlevel backup is ended with an error saying

    Completed with 2 errors.
    [4/23/2010 2:29:35 PM]: Error: Backup failed for Object Shared Search Index failed in event OnBackup.

    error are as below:

    1) Verbose: Starting object: Shared Search Index.
    [4/23/2010 1:58:31 PM]: Error: Object Shared Search Index failed in event OnPrepareBackup. For more information, see the error log located in the backup directory.
        WebException: The current operation timed-out after 3600 seconds
    [4/23/2010 1:58:31 PM]: Debug:    at Microsoft.Office.Server.Search.Administration.SearchSharedApplication.Microsoft.SharePoint.Administration.Backup.IBackupRestore.OnPrepareBackup(Object sender, SPBackupInformation args)
       at Microsoft.SharePoint.Administration.Backup.SPBackup.RunPrepareBackup(SPBackupRestoreObject node)
    [4/23/2010 1:58:31 PM]: Verbose: Starting object: SharedServices1_Search_DB_PROD.


    2)  Progress: [Shared Search Index] 50 percent complete.
    [23/04/2010 14:24:00]: Error: Object Shared Search Index failed in event OnBackup. For more information, see the error log located in the backup directory.
        Object Shared Search Index failed in event OnPrepareBackup. For more information, see the error log located in the backup directory.
        WebException: The current operation timed-out after 3600 seconds
        WebException: The current operation timed-out after 3600 seconds
    [23/04/2010 14:24:00]: Debug:    at Microsoft.Office.Server.Search.Administration.SearchSharedApplication.Microsoft.SharePoint.Administration.Backup.IBackupRestore.OnBackup(Object sender, SPBackupInformation args)
    [23/04/2010 14:24:00]: Verbose: Starting object: SharedServices1_Search_DB_PROD.


    i think problem is with crawling. total index items are 522181. is there any limit to Index items in sharepoint 2007 sp1.

     is there any hotfix related to this issue. thanks in advance.

    Items in index:




    Friday, April 23, 2010 1:41 PM
  • Long back I resolved the issue by resetting the crawled content and re building the Index once again.

    hope this help others.


    Tuesday, July 27, 2010 10:06 AM
  • You can also build a batch file and put these lines in it:

    net stop "Office SharePoint Server Search"
    net start "Office SharePoint Server Search"

    net stop "Windows SharePoint Services Timer"
    net start "Windows SharePoint Services Timer"

    run this each morning early and the error will go away.  

    Monday, September 24, 2012 8:42 PM