none
Sharepoint Central Administration - Site comes up with "Unexpected Error"

    Question

  •  Hi all,

     

    I have successfully installed Microsoft SharePoint 2007 Server (aka MOSS) on a Windows 2003 Server operating system.  SQL Server is also installed. 

     

    I have successfully run the Configuration Wizard.  When I click on Start->Programs->blah, blah, blah->SharePoint Central Administration, a browser window opens with the following information:

     

           In the caption => Error - Microsoft Internet Explorer

     

             In the URL (web address)  => http://myServerName:13464/default.aspx

       

            In the main browser window => Go back to site (this is a hyperlink)

                                                            => ERROR

                                                           => An unexpected Error has occurred

                                                           => Troubleshoot issues with WSS (this is a hyperlink)

     

    I have opened IIS and found that the SharePoint site exists with a port listening on 13464 and the default website under the wwwroot directory is stopped while the SharePoint site is running.

     

    Also, from a command prompt, I have found that in the C:\INETPUB\... directories that there is no file named default.aspx

     

    Can someone help this rooky to SharePoint, get started.

     

    Thanks much for any help.

     

    Glenn

    Friday, June 15, 2007 12:56 PM

Answers

  • Hi Glenn,

    We had the some error message. To have more details you need to do:
         1. Edit the web.config file for the site Central Administration (C:\Inetpub\wwwroot\wss\VirtualDirectories\....is a number)
         2. Look for “CallStack” in the SafeMode section, change the value from false to true.
         3. Look for “CustomErrors” in System.Web section, change the value from On to Off.
         4. Execute IISReset.

     

    Then when you call the Central administration again you will have more details.
       For us the error was:
          The implementation is not part of Windows platform FIPS validated cryptographic algorithms

    We have installed on our server Windows Server 2003 Enterprise with SP2.
      There is fix from Microsoft for this problem:
    http://support.microsoft.com/kb/911722

    We still had an error because the parameter validation="TripleDES" was not accepeted.
      So we changed with validation="3DES" and it worked !  We can access Central Administration.

     

    Good luck,

    Robin

    • Proposed as answer by Shola Salako Tuesday, May 26, 2009 2:54 PM
    • Marked as answer by Mike Walsh FIN Tuesday, May 26, 2009 5:14 PM
    Friday, June 29, 2007 2:19 PM

All replies

  • Go into the event viewer and look under the applications section.  Sometimes those "unexpected errors" are described better in the event logs and can lead you to a better solution.
    • Proposed as answer by Shola Salako Tuesday, May 26, 2009 2:54 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, May 26, 2009 5:14 PM
    • Proposed as answer by Ram_54 Friday, February 19, 2016 6:35 AM
    • Unproposed as answer by Ram_54 Friday, February 19, 2016 6:35 AM
    Monday, June 18, 2007 3:03 PM
  • Hi Glenn,

    We had the some error message. To have more details you need to do:
         1. Edit the web.config file for the site Central Administration (C:\Inetpub\wwwroot\wss\VirtualDirectories\....is a number)
         2. Look for “CallStack” in the SafeMode section, change the value from false to true.
         3. Look for “CustomErrors” in System.Web section, change the value from On to Off.
         4. Execute IISReset.

     

    Then when you call the Central administration again you will have more details.
       For us the error was:
          The implementation is not part of Windows platform FIPS validated cryptographic algorithms

    We have installed on our server Windows Server 2003 Enterprise with SP2.
      There is fix from Microsoft for this problem:
    http://support.microsoft.com/kb/911722

    We still had an error because the parameter validation="TripleDES" was not accepeted.
      So we changed with validation="3DES" and it worked !  We can access Central Administration.

     

    Good luck,

    Robin

    • Proposed as answer by Shola Salako Tuesday, May 26, 2009 2:54 PM
    • Marked as answer by Mike Walsh FIN Tuesday, May 26, 2009 5:14 PM
    Friday, June 29, 2007 2:19 PM
  • Thanks for the pointers, Robin!

    Regards,
    Shola Salako
    SHQ - Knowledge Is Indeed Power. Share it and empower the world.
    Tuesday, May 26, 2009 2:54 PM