none
Phonetic people search doesn't appear to be working RRS feed

  • Question

  • Hi Guys,

    I've recent built an SP2010 Dev environment using the RTM, but appear to have a problem with the phonetic people search.  It's just not doing it.

    Stemming is kinda working (Peters will return Peter, but Pete doesn't return anything) and I'm not convinced the spelling and suggestions are going either (though suggestions might take a couple of days????)

    Anyone got any ideas? I've ensured that the stemming box is ticked in all the core search result webparts (and in People Matches), but I'm not getting any phonetic results or spelling correction results.

    Help!

    Soon'ish
    Craig

    Friday, June 4, 2010 3:30 AM

Answers

  • I had the same issue using IE 8. My browser language settings were set to English UK, if I changed this to English US the phonetic people search now works correctly.

    Alternatively, on the SharePoint search results page you can configure your own search preferences. Setting the default to be "English" instead of the default "Search using my browser's language" will resolve the problem.

    It looks like English UK is not recognised as English.

     

    Friday, June 11, 2010 1:59 PM

All replies

  • Hi Craig,

    We have the same problem. Also best bets and related searches seems to be "dead". We have the spanish version of Sharepoint Server and, as it is the only version, the English version of FASt Search Server. No warnings or errors in the Application logs, so we understand that the connection between both servers is OK..

    We remember that with the Beta version, all in English versions, all these features were working in a suitable way. 

     

    Izzat

    Friday, June 4, 2010 1:48 PM
  • Hi Izzat,

    hmm... I have best bets working OK.

    Which scope are you searching? As the out-of-the-box People doesn't have a Best Bets.

    Are you getting any search results back?

    Thanks
    Craig

    Tuesday, June 8, 2010 4:18 AM
  • HI Craig,

     

    What do you mean with that "As the out-of-the-box people doesn't have a Best bets"?  In the Microsoft videos, there is an example with a user called Mourice and if you type Morris it will find that user called Mourice. So, this is not ready otb?...Is any kind of order in PowerShell that must be executed in order to initiate the service?

    regards,

    Izzat 

    Tuesday, June 8, 2010 8:43 AM
  • Hi Craig,

    We have discovered that, in Mircrosoft Windows, the phonetic people search in not workin IF WE USE INTERNET EXPLORER 8 ¡¡¡¡¡, but if we use Mozilla Firefox, Safari or even Opera it works great¡¡¡¡¡¡ How this can be happening¡¡¡?????

    Regards,

    Izzat

    Tuesday, June 8, 2010 12:06 PM
  • Check your own client browser settings. IE8 works with phonetic people search without any problem.

    Thursday, June 10, 2010 7:59 PM
  • Hi Ji, We supposed that also. First I thought it was my workstation ie configuration,then probed in other fellow workstation with the same results. So I assumed that could be some kind of local company network directive, so i probed at my home.....and the ame results. Thanks anyway Izzat
    Thursday, June 10, 2010 8:26 PM
  • What is the language setting of your browser, may I ask? The feature relies on this setting. For example if I search for "Jie Lee" with English setting then my name "Jie Li" will be returned. If I use other languages in the browser for example ES-ES then nothing will be there. This is by design.

    If your firefox/safari works, that may also mean they do have a different language setting than your IE.

    Thursday, June 10, 2010 8:38 PM
  • Hi Jie Li, All the browsers have spanish setup. We search in all of them the spanish name "Ignacio". So we put Ignasio with "s", and ie returns nothing but firefox,safari and opera returns Ignacio's profile. Also if we search hignasio, with h (in spanish h here would not be pronounced ) and also with s, all other browsers returns Ignacio's profile but ie does not return anything. Regards, Izzat
    Thursday, June 10, 2010 8:59 PM
  • Can you switch IE to English to check if it works at least with hignacio?
    Thursday, June 10, 2010 9:41 PM
  • Hi Joe Li,

    I have turned on the English language option in my Internet Explorer 8 and it remains not showing any result to the "Ignasio" or "hignasio" search for Ignacio's user profile. Mozilla Firefox, Safari and Opera do.

    Regards,

    Izzat

    Friday, June 11, 2010 8:43 AM
  • I had the same issue using IE 8. My browser language settings were set to English UK, if I changed this to English US the phonetic people search now works correctly.

    Alternatively, on the SharePoint search results page you can configure your own search preferences. Setting the default to be "English" instead of the default "Search using my browser's language" will resolve the problem.

    It looks like English UK is not recognised as English.

     

    Friday, June 11, 2010 1:59 PM
  • Thanks James,

    We're in New Zealand, so most of our locale type settings will be en-NZ. Forcing the Search Core Results (and People Search Core Results) webparts to English, has done the trick.

    I recall reading that this was an issue in the Beta and possibly RC, but it's pretty poor form to still treat non-USA English locales as 2nd class citizens.

    It still doesn't help the People Matches webpart however, as it doesn't have any language/locale setting. [sigh]

    Thanks
    Craig

    Saturday, June 12, 2010 12:10 PM
  • Hi Izzat,

    the search results page that is used for for the People Scope, doesn't have a Best-Bets webpart on it. It's only on the standard (all-sites) search results page.

    If you want best-bets on the People Search Results page, you'll need to edit the page and add it. But I suspect this is not what you're after.

    See my response to James about the People Matches webpart not supporting the language/locale fix.

    Hope that between James and I, we have managed to get you sorted.

    Later'ish
    Craig

    Saturday, June 12, 2010 12:13 PM
  • Hi Jie,

    I've unmarked your response as the answer for two reasons:

    1. Please don't mark your own responses as answers, unless the question you are answering, has been confirmed by the asker as being resolved.  And preferably, they will mark the response as the answer.
    2. Please don't mark responses as answers when they don't answer the original question. This just makes following these threads very difficult, especially if you're looking for answers...

    Thanks
    Craig

    Saturday, June 12, 2010 12:20 PM