none
SharePoint 2010 Sync Calendar with Outlook 2010 Issue

    Question

  • I made a calendar in sharepoint which is http://test/Lists/Calendar/calendar.aspx, set myself as Full Control of the Calendar List Permission.

    Next I click on Sync Calendar with Outlook, this prompts with a link

    stssync://sts/?ver=1.1&type=calendar&cmd=add-folder&base-url=http%3A%2F%2Ftest&list-url=%2FLists%2FCalendar%2F&guid=%7Bf41ce005%2Dda73%2D48d1%2D8c45%2D97e57c01c386%7D&site-name=TestSite&list-name=Calendar

    Now in Sharepoint 2010 itself I am able to create and modify any events and this shows up correctly in both SharePoint and Outlook 2010.  When I go to Outlook 2010, I always keep getting this message "You cannot make changes to contents of this read-only folder." and the stsync permission is always marked as "read".  I have tried deleting and creating new calendar, full new active directory user profile test and played around with the SharePoint 2010 Calendar Advance Settings that has "Item Level Permssion set for Create and Edit Access is marked with Create and edit all items as true".  Still cannot get this to work!

    Help!

    In addition, I have SharePoin 2007 the older version still running and I can Sync SharePoint 2007 calendar without any issues with Outlook 2007 & Outlook 2010.  I just find it odd that SharePoint 2010 would produce problems.

    • Moved by Mike Walsh FIN Saturday, June 04, 2011 10:13 AM Off-Topic. SP 2010 question not pre-SP 2010. (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    Saturday, June 04, 2011 6:16 AM

Answers

  • Issue is solved, Microsoft Framework Sync 1.0 x64 was corrupted/bad. I have not clue how or why but after reinstalling. Everything started working again.
    • Marked as answer by T2011 Friday, July 15, 2011 5:54 PM
    Friday, July 15, 2011 5:54 PM

All replies

  • It works fine for me, so you have to figure out what's different about your environment.  I only get that read-only issue when I have more than 2 calendars open concurrently.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Saturday, June 04, 2011 4:15 PM
  • I had a problem with this recently and unchecked "Use Cached Exchange Mode" in my Outlook Email Account Settings. Deleting and re-adding the Calendar after that worked.
    Wahid Saleemi Sr. Consultant, Avanade http://www.wahidsaleemi.com
    Sunday, June 05, 2011 12:35 AM
  • Use Cached Exchange Mode is disabled.  I found out that Outlook 2010 syncing with SharePoint 2010 fails with this error:


    Task 'SharePoint' reported error (0x80004005) : 'An error occurred in this SharePoint List (Test Calendar). Try updating the folder again. If the problem continues, contact the SharePoint site administrator.  HTTP 500.
    The server returned the following error message: Exception of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown.'


    Sunday, June 05, 2011 4:02 AM
  • Issue is solved, Microsoft Framework Sync 1.0 x64 was corrupted/bad. I have not clue how or why but after reinstalling. Everything started working again.
    • Marked as answer by T2011 Friday, July 15, 2011 5:54 PM
    Friday, July 15, 2011 5:54 PM