Can't export list to Excel - "You do not have adequate permissions..." RRS feed

  • Question

  • Hello,

    SP 2007 (, Office 2010, Win 7 Pro x64.

    When I try to export a list to Excel, I get this error:

    "You do not have adequate permissions to modify this list.  Changes to your data cannot be saved."

    This comes right after I am prompted to enable data connections, and the Import Data dialog.

    I get this error on two different computers; I have tried several browsers (IE8 32-bit, FireFox, Iron).

    How do I fix this problem? 


    Wednesday, August 18, 2010 12:09 PM

All replies

  • What rights do you have in the list you are trying to export? It sounds to me like you may not have permissions in the list to export it to a spreadsheet more than an issue with your computer configuration...


    MCTS: WSS v3, MOSS 2007, and SCOM 2007

    Now Available on Amazon - The SharePoint 2007 Disaster Recovery Guide. Coming Soon - The SharePoint 2010 Disaster Recovery Guide.
    My blog: My Central Admin.
    Wednesday, August 18, 2010 1:09 PM
  • Thanks for the reply.

    When I look at the List Settings->Permissions, I am a "User" with "Full Control".


    Friday, August 20, 2010 11:32 AM
  • Is it always Office 2010? If so, it doesn't happen to be the 64-bit version, does it?

    I'm a bit puzzled honestly, if you've got Full Control you should be able to export it...I've reproduced the steps in a post-SP2 farm w/ Office 2010 x86 on Win7 Pro x64 and seen the dialog boxes you mentioned but no error.

    Out of curiosity, what type of list is it? I can't see how that might matter, but its worth knowing.



    MCTS: WSS v3, MOSS 2007, and SCOM 2007

    Now Available on Amazon - The SharePoint 2007 Disaster Recovery Guide. Coming Soon - The SharePoint 2010 Disaster Recovery Guide.
    My blog: My Central Admin.
    Friday, August 20, 2010 1:49 PM
  • User with full control? Meaning your account is in a user group and you have full control? There's not 2 different sets of permissions for different sites or anything like that is there? 
    Monday, August 23, 2010 5:26 PM
  • Uninstalled Office2010, re-installed Office2007, problem went away.

    I am using 32-bit versions of Office on Win7 Pro x64.

    Tuesday, September 14, 2010 6:33 PM
  • I have the same issues on SP2007, Office 2010, Full control on list I want to export.For 2010, I do no get any prompt for my username and password but straight away get the "You do not have adequate...."

    If I use a PC/laptop running Office 2007, there are no issues, the pop up window to authenticate the user comes out.

    Thursday, October 7, 2010 1:41 AM
  • Had the same with WSS 3.0 and Office 2010 on Win 7 32bit.  Works fine in Office 2007.  Found a workaround in Office 2010 of accessing the SharePoint site through https://fqdn.  (Note: there is a commercial SSL cert on the SharePoint site.  Typing http://hostname presented a certificate error and didn't work either.)
    • Proposed as answer by Dustin G Miller Thursday, October 28, 2010 8:00 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, December 7, 2010 7:07 PM
    Thursday, October 28, 2010 8:00 PM
  • Did you get this resolved? I am having the same problem. 

    However, when logged into the sharepoint host and accessing the site via local address it works. Also works when logging external with the local administrator.  Seems to be an issue with forms authentication and/or SSL.

    Tuesday, December 7, 2010 6:20 PM
  • You need to enable Office 2010 applications to connect to a web server with Basic authentication over a nonSSL connection.  Solution is here
    Wednesday, December 8, 2010 10:11 AM
  • Some comments to your suggestion:

    a. did not work on windows 7 - followed to the T however, BasicAuthLevel instance was already present in the HKLM registry.

    b. no key instance for HKCU/.../Office/12.0/Common/ for Internet or sub registry's on windows XP.


    Ran a test case against a machine with Office 2003 and same issue still persists.

    Wednesday, December 8, 2010 5:31 PM
  • I had the same problem with Firefox.

    Browsing with IE8, there are not problems.

    Wednesday, September 28, 2011 12:10 PM
  • Run IE as Administrator!
    Tuesday, January 24, 2012 9:25 AM
  • http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/45feb132-c304-4521-8b79-42236a829aab/

    Fix: This can be done with the Admin or users's account.  First close all Internet Explorer windows.  Go to this location for the user with the issue: C:\Documents and Settings\%Username%\Application Data\Microsoft\Credentials.  There may be multiple folders and I believe they may safely be renamed.  Rename each folder by adding a “.bac” (no quotations) to it so they can be restored if there is an issue.  Go back to the sharepoint website, login, and test opening an Office document.  It worked for me!

    Thursday, January 26, 2012 6:21 PM
  • These fixes didn't work for me. The list was pointing to a SQL database that my account didn't have permissions to. Using a service account that did, I was able to export the list to Excel. Check your list to see if it is pullling data from sources outside SharePoint, then test by either temporarily giving your account access to that source or by logging into the SharePoint site with an account that has access to the outside source already. See if that lets you export the list to Excel.  -  Good luck!
    Wednesday, May 23, 2012 4:11 PM