none
WLAN AutoConfig service Consuming 50% CPU RRS feed

  • Question

  •  

    After running through every svchost.exe service, I came to determine that wlansvc.dll is constantly eating 50% cpu. Stopping the WLAN AutoConfig service brings things back to normal. Vista Enterprise SP1.

     

    I've removed ThinkAdvantage connections, and verified I have the latest drivers for Intel 4965 AGN wireless card. I would like to keep the service disabled, but this service seems to be mandatory for wireless connectivity, even with the Intel ProSet Wireless software.

     

    Anyone have any ideas what could be causing this? Doesn't even matter if I am not associated to a network, if it is running, it's 50% CPU for svchost.exe in the Taskmanger.

    Sunday, November 16, 2008 7:11 PM

Answers

  • Hi,

     

    The issue sounds like a software conflict problem. Could you please take a clean boot to check it? Thanks.

     

    For your reference:

     

    Clean Boot

    =============================

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    Please monitor the system in the Clean Boot environment. If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You may use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

    Hope it helps.

     

    Tuesday, November 18, 2008 7:46 AM
    Moderator