none
RuntimeBroker.exe takes up all CPU

    Question

  • I just upgraded from Windows 7 to Windows 10

    When doing my monthly backup today, the Laptop basically froze all other applications, other than my Explorer.exe copy, which is doing my copy of files from a network drive to a USB local device.

    On Windows 7 there was no issue (on the same hardware obviously) and the copy took about 30 mins to complete.

    On Windows 10, CPU was running 100% and although the copy was progressing, it was very slowly going through the file names and no other applications would launch (e.g. even launching taskmgr took about 1 min to come up)

    The culprit was RuntimeBroker.exe which was using 50-60% CPU constantly.   When I killed this process, the copy sped up considerably and all other applications would launch normally

    Although I understand what RuntimeBroker.exe is doing, it is not acceptable for my normal working processes for it to take so much CPU so either need to fix the issue or disable it

    1.  I found some references to disabling the process completely.  Is this safe, or am I open to security risks

    2.  If it needs to be left enabled, what can be done to prevent it screwing up my laptop every time I want to copy files

    thanks

    Friday, July 31, 2015 7:34 AM

Answers

  • There is a registry hack that will help fix this until MS addresses it

    Change [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003 to dword:00000004.

    This seems to have resolved the issue for quite a few users in this thread

    http://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/runtime-broker-high-cpu-usage/4302a4dd-44c1-474e-8e6a-3c00889c65a7


    Wanikiya and Dyami--Team Zigzag

    Friday, July 31, 2015 1:36 PM
    Moderator
  • I discover a less hacky way. Turn-off all background Apps! (goto "Start->Settings -> Privacy -> background Apps")

    My RuntimeBroker.exe don't use all CPU anymore. At most it use 20% when Window Defender (MsMpEng.exe) is scanning in background, and 10% when SearchIndexer.exe is indexing new files.


    • Edited by msa_86 Tuesday, August 11, 2015 5:58 PM
    • Marked as answer by Deason WuModerator Thursday, August 13, 2015 1:40 AM
    Tuesday, August 11, 2015 5:49 PM

All replies

  • There is a registry hack that will help fix this until MS addresses it

    Change [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003 to dword:00000004.

    This seems to have resolved the issue for quite a few users in this thread

    http://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/runtime-broker-high-cpu-usage/4302a4dd-44c1-474e-8e6a-3c00889c65a7


    Wanikiya and Dyami--Team Zigzag

    Friday, July 31, 2015 1:36 PM
    Moderator
  • I discover a less hacky way. Turn-off all background Apps! (goto "Start->Settings -> Privacy -> background Apps")

    My RuntimeBroker.exe don't use all CPU anymore. At most it use 20% when Window Defender (MsMpEng.exe) is scanning in background, and 10% when SearchIndexer.exe is indexing new files.


    • Edited by msa_86 Tuesday, August 11, 2015 5:58 PM
    • Marked as answer by Deason WuModerator Thursday, August 13, 2015 1:40 AM
    Tuesday, August 11, 2015 5:49 PM
  • The problem I'm having with runtimebroker.exe is strange. It used 25% cpu on an endless file transfer FROM the old windows home server computer on my LAN.  Using resource monitor, I can see that runtime broker is connected to the WHS computer with a steady stream of data saturating my network connection going from the WHS computer to my win10 computer.

    I have 2 computers that are doing this.

    I have tried turning off all indexing, and have tried to get windows defender to not scan network file locations.  I have disabled all media sharing from the WHS computer.  I deleted the WHS device from my computer.  None of this has helped.

    The strangest part is that I even tried attaching my laptop computer to a new isolated subnet 192.168.1.x, and the WHS computer is on another subnet (192.168.0.4), and the laptop somehow managed to traverse the subnets to continue this thrashing of the WHS computer.  The WHS hard drives are thrashing about madly, and so far over the last 2 weeks it has downloaded over 2TB of data from the WHS computer.

    I do have WHS client installed on both of the computers that are doing this, but it does not appear to be WHS client activity.  These clients (when running windows 7) and WHS computer have been stable for a few years.

    What is going on here?  How can I get my win10 computers to stop this endless file transfer from the WHS computer? 

    Friday, August 28, 2015 1:52 AM