Invalid MS-DOS function


  • Hi all,

    I've looked through all the Sharepoint forums so far and all questions relating to MS-DOS invalid function remain unanswered.

    We're trying to copy or drag and drop excel or word files to a mapped sharepoint drive in Windows XP and the Invalid MS-DOS function error occurs.

    There seems to be no online support for this and we're using all MS products, so why isn't it working? Why is there no solution for this?

    Please help, as we've tried everything we can think of.

    Many Thanks,


    • Moved by Mike Walsh FIN Monday, August 01, 2011 4:20 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Monday, August 01, 2011 3:46 PM


All replies

  • Hello Dean,

    I am assuming that you are using Microsoft SharePoint 2007. 

    1) Is this error happening for all your Word/Excel files or is the issue just for certain files only?

    2) Do you get the same behavior from other Workstations too?

    3) Have you tried the same operation directly on the SharePoint server?

    If you don't have any issues, then can you share the screenshot of this error.

    Thanks & Regards,
    Kamlesh | Blog | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 01, 2011 6:48 PM
  • Hi KSDN,


    Thank you for the reply.

    We are using 2007 yes.

    It is happening mainly with excel files, both 2003 and 2007/2010 format.

    We have this problem on all Windows XP  machines, where a mapped drive to sharepoint is available. User opens mapped drive, tries to copy and paste, or drag and drop or save as to the drive and the error: Invalid MS-DOS function is displayed.

    I am running windows 7 and it seems to work fine for me.

    I have seen other users of sharepoint report this problem with it being something to do with NTFS attributes and windows XP, but nobody has given a clear answer or a fix for it.

    Many Thanks,



    Tuesday, August 02, 2011 7:59 AM
  • Hi,

    Have you tried using the explorer view? This provides same functionality. 

    You can get more information about it here:

    Refer thsi for more information


    I hope this will help you out.


    Rahul Rashu

    • Marked as answer by Pengyu Zhao Wednesday, September 07, 2011 2:34 AM
    Thursday, August 04, 2011 4:02 AM