none
Raid 5 after Windows reinstallation

    Question

  • Hi everyone and good year!

    I recently had so much trouble with my computer with some windows files being corrupted and unfixable with DISM that I decided to reinstall Win10.

    My current setup:
    Windows, a Gigabyte Motherboard, a Samsung 850 SSD drive for windows, 3x 2tb drives in raid 5 using ntfs with _critcal_ data on it.

    Prior to reinstall, I took care to change the rights on it so "everyone" has full control, thinking it would be fine to retrieve the data and nothing is locked.

    The I reinstalled Win10 to realize the Raid was not mounting.


    After the windows updates are finished, here what is how in Manage Storage Space :
    Drives with an unrecognized configuration

    "the following drives contain an unrecognized configuration and can<t be used with storage spaces. Reset the drives to make them usable. If the drives continue to be unrecognized, you might need to replace them."

    AMD 2 + 1 Disk RAID5 SCSI Disk device
    Attached via RAID
    3.63 TB

    "Error Unrecognized configuration; reset drive"

    And the Reset button is greyed out.


    Then in the Disk Management console I see:
    Disk 0 partition 2 healthy, storage spaces protective partition  1862gb (my raid)
    Disk 1 partition 2 healthy, recovery Partition 463mb (on SSD)
    Disk 1 partition 3 healthy, recovery Partition 865mb (on SSD)
    Windows C: NTFS Healthy, etc. 237.17gb (on SSD)


    PS C:\WINDOWS\system32> Get-PhysicalDisk
    FriendlyName          SerialNumber                                     MediaType   CanPool OperationalStatus     Health
                                                                                                                     Status
    ------------          ------------                                     ---------   ------- -----------------     ------
    AMD 2+1 Disk RAID5    0808be0d0000000400000000000000000000000000000000 Unspecified False   Unrecognized Metadata Unh...
    Generic Physical Disk                                                  Unspecified False   OK                    Hea...


    PS C:\WINDOWS\system32> Get-VirtualDisk
    (nothing)

    PS C:\WINDOWS\system32> Get-StoragePool
    FriendlyName OperationalStatus HealthStatus IsPrimordial IsReadOnly    Size AllocatedSize
    ------------ ----------------- ------------ ------------ ----------    ---- -------------
    Primordial   OK                Healthy      True         False      3.87 TB       1.82 TB



    So what can I do to 1. keep the data at all means
    2. rebuild the raid.

    I can even try to restore data from linux if I can get instructions, I already have a ubuntu machine accessible for my home theater if needed.

    Help me start the year positively :)

    THANKS
    Monday, January 01, 2018 8:00 PM

All replies

  • Hi,

    It is suggested that you can run get-virtualdisk, get-physicaldisk, get-storagepool command, and upload the screen cut to a network drive, so that we can see it completely.

    What is the UI in the Control Panel >System and security> storage spaces, you can also provide a screen cut.

    Have you tried to unplug the RAID, plug it again? Meanwhile, could you please export the system and application as well as Applications and Services Logs\Microsoft\Windows\Spaceport log to a evtx and CSV format, upload to a network drive and share the link here.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 03, 2018 1:41 AM
  • Any updates?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 04, 2018 1:56 AM