locked
Sharepoint 2010 Alerts an Hour off after Daylight Savings Time. RRS feed

  • Question

  • Old Alerts are an hour off after Daylight Savings Time.  All servers are showing the correct time and all setting are on the correct time zone.  New alerts created to not have the hour early problem.  Do anyone have a fix for this? I tried the  invoke alert fix but it didn't do anything.  Not sure if we ran it at the correct spot.  We are on SP1 with the December CU.
    Thursday, November 8, 2012 5:16 PM

Answers

  • Finally found a fix that works.  The alerts always showed as skipped when I ran the invoke-alertfix command so I did a little more research and found this site - http://msmvps.com/blogs/shane/archive/2011/08/22/after-sharepoint-2010-database-attach-upgrade-alerts-have-the-wrong-urls.aspx and ran the

    Get-SPweb -site http://portal/sites/new -limit all |ForEach-Object {$_.alerts|foreach-object{$_.properties["siteUrl"] = "http://portal/sites/new";$_.update()}} .  I wasn't sure if this fixed the problem so I ran the invoke alert fix again.  It worked correctly this time and didn't skip the alerts.  Now the alerts are showing up at the correct time.

    • Marked as answer by star.wars Thursday, November 15, 2012 1:38 AM
    Wednesday, November 14, 2012 5:06 PM

All replies

  • Deleted
    Friday, November 9, 2012 1:35 AM
  • Hi ,

    Please also try to re-set the timer job Job-immediate-alerts schedule via the stsadm command line, then check if the older alerts send immediately,

    Stsadm.exe -o setproperty -pn job-immediate-alerts -pv "every 5 minutes between 0 and 59" -url http://ProblemSite

    http://sharepoint-geek.com/2009/11/05/sharepoint-alerts-not-working/

    Thanks


    Daniel Yang

    TechNet Community Support

    • Edited by star.wars Friday, November 9, 2012 7:45 AM
    Friday, November 9, 2012 7:44 AM
  • We have been having the same issue and all sources point to the below script:

    http://technet.microsoft.com/en-us/library/cc508847.aspx

    It should work in 2010 and for just fixing alerts leave the site url and old url the same, to fix multiple sites you  can just write a ps script to loop through all sites.


    Colin Cook.


    Apologies, I have just re-read your question and noticed you have tried the above, the script should be run on one of your farm servers and should be completed for each site collection which has the issue.
    • Edited by ColCook Friday, November 9, 2012 10:30 AM
    Friday, November 9, 2012 10:18 AM
  • Not sure if we are running the script wrong but it doesn't seem to show anything fixed when it is run.  Is is suppose to?
    Friday, November 9, 2012 6:43 PM
  • Not sure if we are running the script wrong but it doesn't seem to show anything fixed when it is run.  Is is suppose to?

    My understanding of the script is that it will remove and re-add the alert which will fix any timing issues caused by DST, the output will just either be an error that the alert cannot be fixed or an output showing the count of alerts which have been fixed (Write-Host -ForegroundColor Green "Alerts Fixed: $FixCount")

    This has worked for me. If the script does not even display a count of alerts make sure the url you are giving is the Site Collection and that there were actually alerts set up on the site.

    NOTE: The script provided on the site is simply a funtion, once you have run the .ps1 you will need to call the function from the same powershell instance as per the example in the script below, as said before to just fix alerts the -site and -Oldurl parameter should be the same:


    ## Commit changes to update all alerts (in all subwebs) in the given SPSite.  This operation can not be undone! 
         
    PS >  Invoke-AlertFixup -site "http://teams/sites/newteam"  -Oldurl "http://teams/sites/oldteam

    ## Preview all alerts that would be updated with the given command. 
             
    PS >  Invoke-AlertFixup -site "http://teams/sites/newteam"  -Oldurl "http://teams/sites/oldteam" -whatif




    • Edited by ColCook Monday, November 12, 2012 2:27 PM
    Monday, November 12, 2012 2:08 PM
  • We had the same problem. I runned the code and I didn't see anything fixed after I runed it. But just wait, you'll see that the alerts are send on the correct time.

    ( http://social.technet.microsoft.com/Forums/en-US/sharepointgeneralprevious/thread/3b2c94ff-bc66-45f8-8ef9-349cd044edb7 )

    And if you don't have a new and old url, use the same URL for both <NewURL> and <OldURL>

    • Edited by endeka Monday, November 12, 2012 2:30 PM
    Monday, November 12, 2012 2:29 PM
  • Finally found a fix that works.  The alerts always showed as skipped when I ran the invoke-alertfix command so I did a little more research and found this site - http://msmvps.com/blogs/shane/archive/2011/08/22/after-sharepoint-2010-database-attach-upgrade-alerts-have-the-wrong-urls.aspx and ran the

    Get-SPweb -site http://portal/sites/new -limit all |ForEach-Object {$_.alerts|foreach-object{$_.properties["siteUrl"] = "http://portal/sites/new";$_.update()}} .  I wasn't sure if this fixed the problem so I ran the invoke alert fix again.  It worked correctly this time and didn't skip the alerts.  Now the alerts are showing up at the correct time.

    • Marked as answer by star.wars Thursday, November 15, 2012 1:38 AM
    Wednesday, November 14, 2012 5:06 PM
  • The fix doesn't seem to have fixed the issue totally.  Time changed and again we are having problems with alerts going out late.  Is there a permanent fix for this?
    Thursday, March 14, 2013 5:57 PM