none
The formula contains a syntax error or is not supported RRS feed

  • Question

  • I have a production environment where I can't seem to make any calculated column whatsoever. I used a formula that worked fine in the test environment which was simply a datedif, and not even that works. Example of a formula I try to use:

    =DATEDIF([Start Date], [End Date], "d")

    All I get is:

    The formula contains a syntax error
    or is not supported

    The error also appears in the ULS logs, but provide really no more detail.

    Thursday, September 6, 2012 2:02 PM

All replies

  • Try simple: =[Date End]-[Start Date] and tell us if it works. Check if your fields have the correct names.

    http://valygreavu.com/

    Thursday, September 6, 2012 2:24 PM
  • Yes that works with the same fields, the DATEDIF() doesn't seem to work at all however.
    Monday, September 17, 2012 7:28 AM
  • Check your regional settings! I was having problems with a calculated column using the =TEXT([datefield], "dddd") formula and it was due to the fact the locale was NL instead of UK.
    • Proposed as answer by tfedina Wednesday, September 10, 2014 2:22 PM
    Monday, June 23, 2014 8:28 AM
  • Thank you so much it worked like a charm.I was racking by brains all day trying to figure out what was wrong with my formula syntax and why it works on one site and not the other

    Mitz Sanil

    Tuesday, May 21, 2019 6:29 AM