none
Unable to Publish InfoPath forms on Production Server.

    Question

  • Hi !!

    I am facing a weird problem related to InfoPath form Publishing. From last few months, I am not able to publish any type of form to my Production server. on Development server I can publish them smoothly and working fine.

    As my all previous InfoPath form are working fine on production server. Now I want to add and upgrade the form, but not able to publish them on live server.

    I have already do some practice i.e. root site for web application, host file entry, but still not working. Even I have created an InfoPath form direct on production server and try to publish, but still facing same problem.

    I also tried to create a new web application on production server on different port, on which I'm able to publish the same forms and they are working fine without any error.

    My production server web application is deployed on 80 port and I'm facing a very critical problem, please any one help me as soon as possible.

    Below is my error snapshot: -

    Error Message for Publishing InfoPath form.

    Thanks in Advance.

    Wednesday, January 29, 2014 4:28 AM

All replies

  • Hi Sandeep,

    Are you trying to publish to virtual path like yourserver/sites

    If you don't have a root site, this could be the one of reason for the error you are getting.

    Compare the new webapplication(new site collection url) that you have newly created with the one which has the problem.

    See the below link for more information - http://support.microsoft.com/kb/981854

    and this forum http://social.technet.microsoft.com/Forums/en-US/6944e55e-16b5-4601-9621-24cc5373a3a6/error-the-following-url-is-not-valid-unable-to-publish-infopath-form?forum=sharepointcustomizationlegacy

    Let me know if the above resolves your issue.



    MCITP: SharePoint 2010 Administrator
    MCTS - MOSS 2007 Configuring, .NET 2.0
    | SharePoint Architect | Evangelist |
    http://www.sharepointdeveloper.in/
    http://ramakrishnaraja.blogspot.com/



    Wednesday, January 29, 2014 4:34 AM
  • Thanks for quick reply, But I have tried to publish using root site like http://server/ , http://ipaddress/http://ipaddress:80, http://servername:80 etc to publish my form but still not working.

    I also tried all solutions given in the link but still have same problem.

    Note: I have no any tag found in web.config "<remove verb="*" Path="*.asmx" />  for http handlers.

    Wednesday, January 29, 2014 4:48 AM
  • Can you try running SPInfoPathFormsService  and let know the result.



    MCITP: SharePoint 2010 Administrator
    MCTS - MOSS 2007 Configuring, .NET 2.0
    | SharePoint Architect | Evangelist |
    http://www.sharepointdeveloper.in/
    http://ramakrishnaraja.blogspot.com/

    Wednesday, January 29, 2014 5:49 AM
  • Dear Ramakrishan,

    I got below result on my production server

    AllowUserFormBrowserEnabling                              True                                  AllowUserFormBrowserRendering                            True

    Thursday, January 30, 2014 6:27 AM
  • Hi Sandeep,

    Did you recently change any host header of your site collection in which the form is not publishing?

    Can you go to IIS and check the IIS binding for that webapplication and share the snap shot, like I want to see if there is multiple binding for the webapplication.

    I know it wont be much fruitful in case of infopath debugging  but what the error log says if you can find anything.

    Also can you provide the information like  In which way you are publishing the form to SharePoint.

    Is there any custom code written with the form and what about property promotion field are you using.

    Did you change the site column in SharePoint site which is mapped with your form is property promotion field. It would be very helpful to nail down the cause of the issue.


    Krishana Kumar http://www.mosstechnet-kk.com

    Thursday, January 30, 2014 6:42 AM
  • Dear Krishana,

    I just created a blank form without any code behind, any other binding or rules (just add a label), saved it, then try to publish for production server. it is giving error as the above snap shot. but working fine at our development server, as both server have same configuration, version and settings for all services.

    Please find the below snapshot for binding of production server site: -

    Thursday, January 30, 2014 6:52 AM
  • one more thing, I'm able to create data connections using same production URL in InfoPath. but during publishing against any site collection (including top) error message is displayed.

    Thursday, January 30, 2014 6:56 AM
  • Hi Sandeep,

    Did you try to publish the form from some different machine, if not can you try once.

    secondly plz. check the host header of your site collection from the Prod. compare with DEV is that same and get back to us, we would be glad to assist further and sorry for the inconvenience you have.



    Krishana Kumar http://www.mosstechnet-kk.com

    Sunday, February 9, 2014 10:43 PM
  • Sandeep,

    I was getting the same message after I tried disabling prompting for documents in libraries by adding the following to my web.config. 

    <verbs allowUnlisted="true">

            <add verb="OPTIONS" allowed="false" />

            <add verb="PROPFIND" allowed="false" />

            </verbs>

    When I remove the above from the web.config then "URL is not valid" message went away and I am able to publish InfoPath forms without a problem.  If this isn't in your web.config on production, you may want to check for an xml file that may be merged with the web.config on your system, for more and where to find the xml go to http://msdn.microsoft.com/en-us/library/ms439965.aspx .


    hope this helps.


    trockwell@sharepointexperts.org

    Monday, February 10, 2014 5:44 PM
  • I have tried all these things at production server itself. still not working. Host header is same as in DEV, all services are running...
    Tuesday, February 25, 2014 11:25 AM
  • No, configuration files have no any tag like this. I have seen all config and xml files related to production site. Still it stuck..!!!
    Tuesday, February 25, 2014 11:39 AM
  • Please keep this in mind that on the same server, for any other web application InfoPath forms are publishing properly. but not working for 80 port web application's all site collections.
    Tuesday, February 25, 2014 11:40 AM
  • Hi Sandeep,

    I was searching the same issue with multiple webapplication host on 80 port and find out that  HTTP PUT requests can be  blocked on the server and that can be cause this issue. So can you check the http put request is blocked for your server? You can used Fiddler tool to get web request logs  Solution 

    Allow all HTTP Verbs in IIS and do IISRESET after that publish the form


    Krishana Kumar http://www.mosstechnet-kk.com

    Thursday, February 27, 2014 6:58 AM
  • Hi Sandeep,

    +krishna

    I did a blog on this issue few weeks ago, hope that helps you resolve the issue-

    We have to enable HTTP Verbs in IIS server to publish the Form, also to know how to for Verbs, here is a link http://www.iis.net/configreference/system.webserver/security/requestfiltering/verbs

    here is the blog - http://www.sharepointdeveloper.in/#!/2014/01/infopath-2013-publishing-error.html 


    Hope this helps!
    Ram - SharePoint Architect
    Blog - SharePointDeveloper.in
    Please vote or mark your question answered, if my reply helps you



    Thursday, February 27, 2014 3:03 PM
  • I have done what you said. but it is still not working. please get the below snapshot from fiddler. PUT is not blocked.
    Tuesday, March 11, 2014 7:56 AM