none
The content processing pipeline failed to process the item issue

    Question

  • Hi,

    I have a issue with sharepoint search server. I have several lists and they contain many items with attachments. When i try to crawl site i get below error for every list item which have attachments.

    The content processing pipeline failed to process the item. ( Object reference not set to an instance of an object.; ; SearchID = 2314D954-8919-4F6E-A493-0F33626C3307 )

    The sp log error for this correlation id is show in below

    Transaction failed in plugin IPOC Url sts4://altin/siteurl=/siteid={6bcd74ae-7a45-4398-8daa-d20dfbadfe14}/weburl=/webid={10d22ce1-4526-47c8-a4bc-47bc44ed4c8c}/listid={90da349c-ec5e-4020-aae6-5eb1234dde1f}/folderurl=/itemid=8985 Error 0x80040dcb  [gthrtrx.cxx:950]  search\native\gather\gthrsvc\gthrtrx.cxx

    However, i don't get this error for the other list items which don't have  any attachment and they is crawled successfully.  I tried to delete search application and create it again but it didn't solve my problem. I have Sharepoint 2013 server + Turkish Language Pack + June 2013 CU. I can navigate the url on item cause this issue without any problem. I can access attachments. My search account  has full read permission on web application. 

    Regards

    Berkay


    Tuesday, July 23, 2013 9:11 AM

All replies

  • I faced this issue once and end up recreating search service application  to solve the issue. try restarting the server after deletion and before creating the SSA.

    Regards

    Roy Joyson


    Roy Joyson

    Wednesday, July 24, 2013 4:59 PM
  • We have a similar, possibly related,  issue, involving OOTB entity extraction and list item attachments; this may provide some insight:

    We also have a number of lists having list items with one or more attachments.  In our case, we enabled the OOTB entity extraction to produce some additional refiners. If you have enabled entity extraction on the "body" managed property, entity extraction will fail on any list item with an attachment and that list item and its attachments will NOT be indexed, and as a result, will not appear in search results.

    Microsoft is in the process of developing a hotfix for this. When we successfully apply it, I will post our results

    Wednesday, July 24, 2013 7:01 PM
  • Hi,

    as a customer is having the same configuration regarding entity extraction to produce refiners for documents which are mapped to the "body" managed property, I would like to reopen the pending question.

    We are facing the same error, as a custom list with enabled attachments throws an error message in the crawler log

    "The content processing pipeline failed to process the item.  ( Object reference not set to an instance of an object."

    for every list item with an attachment. Any list item without an attachment is crawled perfectly. As "C Chance" rote in July 2013 that Microsoft is in the process of developing a hotfix I would like to know if this hotfix is already available?

    kind regards
    David

    Monday, April 07, 2014 8:50 AM
  • Hi,

    Are you getting the same issue for all the list having an attachment, or some of list items? Please check the document attachment content by checking the document spy.. by using the  that custom stage http://sharepoint-community.net/profiles/blogs/blogged-custom-fast-esp-like-pipeline-stages-are-possible-with  please check the document size (check the document size throttling).

    Regards,

    Sharepoint For Developer

    Basant Pandey


    Monday, April 07, 2014 5:39 PM