locked
Datasheet view is always read-only RRS feed

  • Question

  • I have a list on a site.  The list has a few fields from the BDC, but the rest are either numeric or choice lists.

     

    I created a datasheet view on it, and I can edit the items in the list.

     

    But once I enable content approval on the list, the web part showing the list in datasheet mode becomes read-only for all fields.

     

    If content approval is enabled, is there any way to use a datasheet view in a web part and allow the user to edit the data?  (if the answer is no, why not!)

     

    Wednesday, July 18, 2007 2:13 AM

Answers

  • I was wrestling with this problem for the last hour.  It was working.  Then stopped working. 

    I fixed it by changing the column type of a text column from 'Multiple Lines of Text' set to six with hyperlinks back to single line of text and I was able to paste back and forth to and from Excel again. 

    Note that there was never more than a single line of actual content in the cells (or any special formatting to begin with). 

     

    • Edited by Mike Walsh FIN Wednesday, June 9, 2010 4:01 AM Moderator Note: I'm marking this as answer as it is *one* possible reason. The original poster is long gone so won't be around to say whether this helped him or not.
    • Marked as answer by Mike Walsh FIN Wednesday, June 9, 2010 4:02 AM
    Tuesday, June 8, 2010 8:49 PM

All replies

  •  

    I have the same issue. I did not put it together with the content approval, however, the list does require approval (as did yours).

     

    I am looking for a solution to this and hoped that by posting, it might shake out a response from someone else who has experienced the same thing.  Thanks.

    Wednesday, November 28, 2007 1:54 PM
  • Did you check the "My submissions" or the "Approve/reject Items" views in Datasheet View? They are NOT read only.. so far didn't figure out why the All Items view is read-only in DS view when content approval is enabled on the list.
    So if somebody finds out the secret, spit it out! :-)

    Thanks.

    Monday, October 27, 2008 7:07 AM
  • The explanation is in Help (click on the "This view is read-only"). Still, it is still useful to edit in Datasheet view even when content approval is enabled:

    Status bar displays 'Read-only' or 'This view is read-only'

    The selected cell, column, row, or the entire view is read-only. You cannot edit a cell, column, or row that is marked read-only. If the entire view is read-only, you cannot edit any portion of the view.

    Portions of a view, or an entire view, might be read-only due to one or more of the following reasons:

    • Certain columns, such as Created By and Modified, are always read-only. Values for these columns are entered automatically.
    • The changes you made to the selected row or column have been submitted to the server. If there is no conflict or error, you will be able to edit the row or column after the changes have been saved.
    • There is an unresolved conflict or error in the selected row or column. Resolve the conflict or error before attempting to edit the selected row or column.
    • The list is set up to require content approval, and you are viewing the list in the All Items view.
    • In the My Submissions view of a list that requires content approval, the Approval Status and Comment column are read-only. Only a user with Manage Lists right can edit these two columns.
    • Attachments are read-only in a list that requires content approval. You cannot view or edit attachments in any of the views.
    • The document in the current row has been checked out by a user. You cannot edit the columns in the row until the user checks the document in.
    • You do not have permission to edit the column or row. Contact the list author for more information.
    • Proposed as answer by PANoone Wednesday, October 21, 2009 11:58 PM
    • Unproposed as answer by Mike Walsh FIN Wednesday, June 9, 2010 4:00 AM
    Monday, October 27, 2008 7:14 AM
  • We are not using All Items View and this still happens.  We created a custom view with datasheet access and the users still see the view as read-only.  In fact, the All Items view IS editable.
    Wednesday, July 22, 2009 2:07 PM
  • We don't even have content approval enabled and are having the same problem!

    We have a datasheet view that we use to paste metadat afrom an Excel spreadsheet for bulk uploads. This used to work like a charm and saved hours of work.

    For some reason the Content Type column has suddenly decided to become READ ONLY and none of the reasons described in Help can explain this phenomenon.

    My suspicion is that it was caused by a sofwtare update but who knows.
    If at first you don't succeed, ask an MVP.
    • Edited by PANoone Friday, July 2, 2010 1:40 AM
    Wednesday, October 14, 2009 11:52 PM
  • This issue has been resolved.

    It was caused by a list template feature which inlcuded custom views referencing the Content Type column.

    Upgrading the feature by removing these then caused the following error on ANY view in document libraries:

    "Can not complete this action, please try again." Useful, eh?

    Somehow, despite claims to the contrary, schema changes made to the list schema XML affected all list instances previously created via this feature. Deactivating and reactivating the feature did not help. Worse still, it affected ALL document libraries, not just those provisioned by the feature.

    The resolution was to delete the custom views via SharePoint Destroyer. Weird, weird, weird...
    If at first you don't succeed, ask an MVP.
    • Proposed as answer by PANoone Wednesday, October 21, 2009 11:58 PM
    • Unproposed as answer by Mike Walsh FIN Wednesday, June 9, 2010 3:57 AM
    • Edited by PANoone Friday, July 2, 2010 1:41 AM
    Wednesday, October 21, 2009 11:56 PM
  • I was wrestling with this problem for the last hour.  It was working.  Then stopped working. 

    I fixed it by changing the column type of a text column from 'Multiple Lines of Text' set to six with hyperlinks back to single line of text and I was able to paste back and forth to and from Excel again. 

    Note that there was never more than a single line of actual content in the cells (or any special formatting to begin with). 

     

    • Edited by Mike Walsh FIN Wednesday, June 9, 2010 4:01 AM Moderator Note: I'm marking this as answer as it is *one* possible reason. The original poster is long gone so won't be around to say whether this helped him or not.
    • Marked as answer by Mike Walsh FIN Wednesday, June 9, 2010 4:02 AM
    Tuesday, June 8, 2010 8:49 PM
  • PANoone:

    Please do not propose your own posts as answers. It's not helpful.

    Propose the good answers of other people. Wait for someone else to propose your posts.

    (Moderator)

     

    P.S The above applies always. In this case you are not the original poster, so marking a post saying that *your* problem has been solved doesn't help the Original Poster whose thread it is. The marked as answer is to indicate that the *original* question has been answered.

     


    2010 Books: SPF 2010; SPS 2010; SPD 2010; InfoPath 2010; Workflow etc.
    2007 Books: WSS 3.0; MOSS 2007; SPD 2007; InfoPath 2007; PerformancePoint; SSRS; Workflow
    Both lists also include books in French; German; Spanish with even more languages in the 2007 list.
    Wednesday, June 9, 2010 3:59 AM
  • Hi,

    I have the same problem. If the column type is defined as single line of text, it can be edited, while if it is specified as multiple lines of text (Enhanced Rich text), the cell in datasheet view is seen as read-only.

    The proposed solution does not work for me, because in the cell I want to collect a list of hyperlinks, so I need "multiple lines" and "rich text" available.

    Interesting to note is that other people, our company IT support guys, are able to input data in the cell, while I cannot, and I am owner of the page and have full control over it.

    best regards,

    Mark

    <input name="AllowHyperlink" type="hidden" value="TRUE" />

    Tuesday, July 27, 2010 9:11 AM
  • I came across this issue today myself.

    The solution was to go into the list settings.

    select the list column e.g. "Notes" and double click on it to expose the column settings.

    Specify the text to allow as "Plain text".

    Click ok to save the settings.

     

     

     

    Monday, August 16, 2010 11:07 AM
  • I came across this problem today and I could not find a real fix for it.

    I did however decide to add a column of my own called "IsApproved" (Yes/No) field. This list data gets transferred to our website based on the View that I assign. So I setup a view that filters on the "IsApproved" column so that only those items get transferred to the website.

    It's not a great solution, but it accomplishes my task.

    Wednesday, October 13, 2010 8:48 PM
  • Thanks for this tip, this solved the same issue I was having.  Just wanted to add that I found that changing the Multiple Lines of Text field to either Plain text or Rich text allowed me to copy/paste to the view.
    • Proposed as answer by bdhahn Thursday, June 23, 2011 2:23 AM
    Wednesday, October 20, 2010 4:28 PM
  • I noticed one more thing..when you are in the Approve / Reject mode and edit in data sheet ..It allows you to update the Approval Status column (the column I need to modify) to Approved unless the Created by and Modified By are different users .
    Friday, October 28, 2011 2:34 PM
  • We are having this same situation even if we use only 'single line of text' -fields. We can edit most rows but some rows gives status bar 'Read-Only' after we try to edit column information. Editing item from Standard view works ok.

    Has anyone solved this?

    Wednesday, December 7, 2011 8:53 AM
  • Hey My Problem was also solved by

     

    select the list column e.g. "Notes" and double click on it to expose the column settings.

    Specify the text to allow as "Plain text".

    Click ok to save the settings.

    Wednesday, January 11, 2012 10:07 AM