none
Alerts not working in Sharepoint 2016 RRS feed

  • Question

  • Hello. I have tried troubleshooting why Alerts aren't working in my SP environment for several weeks. I tested via telnet from my SP server to the correct SMTP server. I believe the problem is in my SP setup. Does "My Sites" have to be setup in order for Alerts to work? I think that maybe the Alerts aren't working due to My Sites not being configured, or not configured correctly. Any articles or help would be appreciated. Thanks. John
    Friday, January 10, 2020 5:53 PM

All replies

  • Hi John,

    I don't think My Sites need to be congifured for Alerts to work.

    Please make sure you configure the outgoing emails in CA correctly: https://docs.microsoft.com/en-us/sharepoint/administration/outgoing-email-configuration

    You could check if outgoing Email settings applied on SharePoint central Administration site are valid with the following powershell:

    Add-PSSnapin Microsoft.SharePoint.PowerShell -ErrorAction SilentlyContinue
     
    #Configuration Parameters
    $SiteURL="http://sp/ "
    $Email = "michael@contoso.com"
    $Subject = "Test Email from SharePoint"
    $Body = "Test Email Body"
     
    #Get the Web 
    $Web = Get-SPWeb $SiteURL
     
    #Send Email using SPUtility SendEmail method
    [Microsoft.SharePoint.Utilities.SPUtility]::SendEmail($Web ,0,0,$Email,$Subject,$Body)

    Best Regards,

    Michael Han




    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, January 13, 2020 7:25 AM
    Moderator
  • Thanks Michael. I read the link you posted really carefully, and something clicked this time. I got it working. Thanks again for your reply. J
    Monday, January 13, 2020 10:33 PM
  • Hi John,

    I'm glad that your issue got solved. If my suggestion is helpful to you, you could mark it as an answer. 

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, January 14, 2020 12:46 AM
    Moderator
  • Hi, John,

    Is there anything update on your issue?

    Please remember to mark the reply as an answer if it helps you.

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, January 20, 2020 8:19 AM
    Moderator