none
Give access to document library only but not entire site

    Question

  •  Hello,

    We currently have SharePoint 2007 deployed at our company. I would like to create a Site and create multiple document libraries within the site with own permissions.  How do I go about giving users access to specific document library without the need to give permissions to entire site?

    For example, I create site called “Testing”. I have created the following permission groups for the site:

    Full Control

    Approve

    Contributor

    Read – Can view only

    Restricted Read

    View Only

     

    When I created the site the “Shared Document” folder was created by default. I  would like to create the following additional document libraries;

    Library 1

    Library 2

    Library 3

     

    I created a group called “Engineering” and would like to give access to Library 1. It seemed that I need to give users in engineering some type of access to Testing site in order for them to the Library 1 folder. Even I give them View Only access to Test Site and contribute access to Library 1, they can still view files in in Shared Document folder. Can I block access to Shared Document folder?

    Monday, October 17, 2011 10:21 PM

Answers

  • Hi Bluem1,

    From your description it seems to me you have not broken permission for the 'shared documents' library. Once you break inherience for this library and remove the un-necessary group they should not see this. Also it is normal that for those groups has added directly to the list level (say Library 1) would have 'limited access' at the root site level 'in your case Testing'. Idea here is you don't put secured content at the root site level.

    Hope this helps!


    BlueSky2010
    Tuesday, October 18, 2011 2:58 AM
  • Hi,

    Sharepoint gives you the flexibility to define permissions at any level you want.

    You can create separate permissions for your doc librraiea nad the users will be able to access them only and no other portion of the site.

    If you want users not to access the shared document then break the permissions of shared document from site and create its own.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Tuesday, October 18, 2011 3:46 AM
  • As the guys have suggested, you can break off permissions on both library and item level, but should this turn into something larger, you'll be looking at a permissions nightmare unless you architect it properly.

    I'd take the time to clarify your security arrangements over Library one and think about the access requests for it over the next 12-24 months.  If you suspect you'll get lots of traffics, set up a sub-site or a workspace with unique permissions, as you'll still be able to use groups for managing permissions and will also be able to scale out the library as needed.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Tuesday, October 18, 2011 9:18 AM
    Answerer
  • Hi Bluem1,

    I feel that it just something little missed in operation. Here is a solution may solve your problem, you can check the steps:

    1.       Log on the site, and go to Library1, click Settings > Document Library Settings > Permissions for this document library.

    2.       On the “Permissions: Library1” page, click Actions > Edit Permissions, then click OK on the prompt box.

    3.       Add Engineering Group and grant at least view only permission to it.

    4.       Check permissions of the Engineering group on the site, and make sure it only has “Limited Access” permission.

    5.       Then the users in Engineering group can visit the Library1 via http://Server/site/Library1 (assume your site is http://Server/site).

    Please try this. I look forward to your reply.

    Thanks,
    Emir

    Tuesday, October 18, 2011 10:05 AM

All replies

  • Hi Bluem1,

    From your description it seems to me you have not broken permission for the 'shared documents' library. Once you break inherience for this library and remove the un-necessary group they should not see this. Also it is normal that for those groups has added directly to the list level (say Library 1) would have 'limited access' at the root site level 'in your case Testing'. Idea here is you don't put secured content at the root site level.

    Hope this helps!


    BlueSky2010
    Tuesday, October 18, 2011 2:58 AM
  • Hi,

    Sharepoint gives you the flexibility to define permissions at any level you want.

    You can create separate permissions for your doc librraiea nad the users will be able to access them only and no other portion of the site.

    If you want users not to access the shared document then break the permissions of shared document from site and create its own.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Tuesday, October 18, 2011 3:46 AM
  • As the guys have suggested, you can break off permissions on both library and item level, but should this turn into something larger, you'll be looking at a permissions nightmare unless you architect it properly.

    I'd take the time to clarify your security arrangements over Library one and think about the access requests for it over the next 12-24 months.  If you suspect you'll get lots of traffics, set up a sub-site or a workspace with unique permissions, as you'll still be able to use groups for managing permissions and will also be able to scale out the library as needed.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Tuesday, October 18, 2011 9:18 AM
    Answerer
  • Hi Bluem1,

    I feel that it just something little missed in operation. Here is a solution may solve your problem, you can check the steps:

    1.       Log on the site, and go to Library1, click Settings > Document Library Settings > Permissions for this document library.

    2.       On the “Permissions: Library1” page, click Actions > Edit Permissions, then click OK on the prompt box.

    3.       Add Engineering Group and grant at least view only permission to it.

    4.       Check permissions of the Engineering group on the site, and make sure it only has “Limited Access” permission.

    5.       Then the users in Engineering group can visit the Library1 via http://Server/site/Library1 (assume your site is http://Server/site).

    Please try this. I look forward to your reply.

    Thanks,
    Emir

    Tuesday, October 18, 2011 10:05 AM