none
WLAN Service issue: intermittent wireless ping spikes to the router with 100% signal... unless I restart the WLAN Service. RRS feed

  • Question

  • Been pulling my hair out over this one for a while. What it boils down to is this - I can sit my Dell Windows 7 Home Premium 64-bit laptop next to my router, I have 100% signal, I ping the router X times, and while most of the pings are <1ms, inevitably every 10 seconds it will spike to around 150ms, then 70ms, 50ms, and back to <1ms for the next 10 seconds. This is directly to the router I am sitting next to. Which means add those times onto actual internet browsing. I exhausted all my router settings (DLink DIR-655 rev. 1.34), and have the latest device drivers (Dell 1520 Wireless-N WLAN Mini-Card 5.30.21.0), and when I say 100% signal that's what is reported by both the router and the Dell WLAN monitor on the laptop. Now here's the crazy part. I started searching online for the WLAN Service issue where it occasionally causes ping spikes. I can't run wireless without that service, but after trying to stop and restart it, my problems vanished. 100% <1ms pings, no spikes.

     

    I have since tried this again and again. When I boot the laptop, I can wait for hours, doesn't matter how long it has been on, I will always get these ping spikes every 10 seconds. If I stop and restart the WLAN Service, the ping spikes disappear, and I can run for hours with a perfect connection. I have tested this many times. Also if I set the service to Manual startup, reboot, then manually start the service myself (using a sc start call from a batch file), it works. Bottom line: if WLAN Service auto-starts, it causes me problems. Manual start, works great.

     

    Any thoughts? I wanted to try Automatic (Delayed Start) but the service won't let me select that option.

    Thursday, May 27, 2010 5:19 PM

Answers

  • Connect to a more preferred network if available is unchecked, and there are no other stored networks on the system. Latest firmware on router, latest driver. Roaming aggressiveness has been changed to be "conservative", and there was another roaming preference that was changed to "optimize bandwidth". Although the driver documentation states that neither setting is used unless the signal drops to something far weaker than what I am registering. I have now gone several days with no ping spikes as I have not rebooted since after I performed the tests I mentioned in my first post. So right now, my performance is excellent. If I reboot, I'll have the ping spikes again. Craziness.
    • Marked as answer by Vivian Xing Friday, June 4, 2010 7:29 AM
    Tuesday, June 1, 2010 8:35 PM

All replies

  • That's the whole problem - it's not interference. For example, I can rip batteries out of my phones, and turn off all electrical equipment in the room except for the cable modem, the router, and the laptop, and multiple apps that scan wireless channels state no strong signals but my router, and more importantly multiple apps state I have a 100% signal and 0% noise. And yet, sitting next to the router, I reliably get 150ms pings every 10 seconds. I'd expect this sort of thing if I was 150 feet away with a 50% signal and noise, but not in this test environment. It is far too predictable and non-random.

     

    UNLESS I manually restart the WLAN AutoConfig service. Alternately, if I set that service to Manual, then start it myself after booting, I have consistent results for hours on end. For some reason, my problem is specifically caused by WLAN AutoConfig launching with Windows 7. If the service is started after Windows has finished booting, then my wireless is pristine after that.

     

    And it's no fluke. I can have multiple PCs powered up, 2.4ghz phones nearby, a window A/C unit running, and move two floors away until I get an 80% signal.... and I can still get 100 <1ms pings in a row to the router. Everything is tied to this bizarre step of manually starting WLAN AutoConfig.

    Thursday, May 27, 2010 8:49 PM
  • If any firmware update is available for this router, please download and install it. You can also test it in Clean Boot mode.
    Vivian Xing - MSFT
    Tuesday, June 1, 2010 3:19 AM
  • Connect to a more preferred network if available is unchecked, and there are no other stored networks on the system. Latest firmware on router, latest driver. Roaming aggressiveness has been changed to be "conservative", and there was another roaming preference that was changed to "optimize bandwidth". Although the driver documentation states that neither setting is used unless the signal drops to something far weaker than what I am registering. I have now gone several days with no ping spikes as I have not rebooted since after I performed the tests I mentioned in my first post. So right now, my performance is excellent. If I reboot, I'll have the ping spikes again. Craziness.
    • Marked as answer by Vivian Xing Friday, June 4, 2010 7:29 AM
    Tuesday, June 1, 2010 8:35 PM
  • Hi Puablo,

    Thank you for your update. If the issue reoccurs after rebooting, you can test it in Clean Boot mode as suggsted. Please take your time testing.


    Vivian Xing - MSFT
    Wednesday, June 2, 2010 3:20 AM