none
stsadm AddContentDB command fails with "Failed to Acquire a session to upgrade this object" error at Content DB upgrade step. RRS feed

  • Question

  • I'm trying to attach a WSS 3.0 content database to a new (new after I uninstalled and started over) SharePoint Server 2010 farm. I followed the Attach Database procedure and saw no issues with the preupgradecheck. Installation and general setup of the farm was flawless, but I've been stuck for hours trying to attach this content database. 

    I'll run this at the command-line:

    stsadm -o addcontentdb -url {url of default port 80 web application created during install and farm config} -databasename {databasename} -assignnewdatabaseid

    It follows with the following error: Failed to acquire a session to upgrade this object (name = {connection string}). The same object is being upgraded on server ={servername}, and command line = "C:\Windows\System32\WindowsPowerSHell\v1.0\PowerShell.exe" -NoExit " & ' C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\POWERSHELL\Registration\\sharepoint.ps1 ' "

    The content database shows up in the Manage Content Databases section of the Central Admin and no Upgrade Sessions are listed on the "Upgrade Status" page of the Central Admin. Though, the database is listed under the "Manage Database Upgrade Status" page with a Status of "Database is too old and upgrade is required". 

    As I mentioned above, this is a restart after all this crapped out and I tried re-installing the farm. I tried running the Mount-SPContentDatabase powershell command with the earlier installation and that failed a few times as I resolved errors. Now I don't get any informative error messages in the trace or Event Viewer....well I do get this: "The DELETE statement conflicted with the REFERENCE constraint "FK_Dependencies1_Objects". The conflict occurred in database "{content database name}", table "dbo.Dependencies", column 'ObjectId'. The statement has been terminated. 

    Ideas?

    - Lou


    Monday, November 5, 2012 11:57 AM

Answers

  • Hello Lou,

    Do you have at least SP2 on the WSS 3.0 database schema ?

    You must have at least SP2 in order to attach the database to SP2010.

    Also make sure you run the pre-upgrade and it does not fail before you try to attach the database.

    Let me know if this helps.

    Regards,

    Nick

    Monday, November 12, 2012 2:21 PM