'<', hexadecimal value 0x3C, is an invalid attribute character. Line 1, position 19355.


  • I really don't remember what I did that caused the problem, but I cannot simply run the configuration wizard successfully, do some powershell commands, or even open my central administration.

    The exception I receive is is follows:

    Server Error in '/' Application.
    '<', hexadecimal value 0x3C, is an invalid attribute character. Line 1, position 19355. 
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    Exception Details: System.Xml.XmlException: '<', hexadecimal value 0x3C, is an invalid attribute character. Line 1, position 19355.
    Source Error: 
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  
    Stack Trace: 
    [XmlException: '<', hexadecimal value 0x3C, is an invalid attribute character. Line 1, position 19355.]
       System.Xml.XmlTextReaderImpl.Throw(Exception e) +95
       System.Xml.XmlTextReaderImpl.ParseAttributeValueSlow(Int32 curPos, Char quoteChar, NodeData attr) +5031103
       System.Xml.XmlTextReaderImpl.ParseAttributes() +916
       System.Xml.XmlTextReaderImpl.ParseElement() +378
       System.Xml.XmlTextReaderImpl.ParseElementContent() +199
       System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace) +229
       System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc) +61
       System.Xml.XmlDocument.Load(XmlReader reader) +134
       Microsoft.SharePoint.Administration.SPConfigurationDatabase.GetObject(Guid id, Guid parentId, Guid type, String name, SPObjectStatus status, Byte[] versionBuffer, String xml) +238
       Microsoft.SharePoint.Administration.SPConfigurationDatabase.FetchObject(Guid id) +1396
       Microsoft.SharePoint.Administration.SPConfigurationDatabase.GetObject(Guid id, Boolean checkInMemoryCache, Boolean checkFileSystemCache) +406
       Microsoft.SharePoint.Administration.SPConfigurationDatabase.Microsoft.SharePoint.Administration.ISPPersistedStoreProvider.GetObject(Guid id) +59
       Microsoft.SharePoint.Administration.SPPersistedObjectCollection`1.get_Item(Guid objId) +50
       Microsoft.SharePoint.Administration.<GetEnumeratorImpl>d__0.MoveNext() +239
       Microsoft.SharePoint.Administration.Enumerator`1.MoveNext() +23
       Microsoft.SharePoint.Administration.SPWebApplication.AcquireAlternateUrlCache(SPFarm farm) +402
       Microsoft.SharePoint.Administration.SPWebApplication.Lookup(SPFarm farm, Uri requestUri, Boolean fallbackToHttpContext, SPAlternateUrl& alternateUrl, SPSiteLookupInfo& hostHeaderSiteInfo, Boolean& lookupRequiredContext) +237
       Microsoft.SharePoint.ApplicationRuntime.SPRequestModule.EnsureInitialize(HttpRequest request) +646
       Microsoft.SharePoint.ApplicationRuntime.SPRequestModule.BeginRequestHandler(Object oSender, EventArgs ea) +164
       System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +80
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +171
    Version Information: Microsoft .NET Framework Version:2.0.50727.5420; ASP.NET Version:2.0.50727.5420 

    I have tried overriding an old working web.config file of the central administration web.config in IIS, resetting the IIS and rebooting the server and nothing worked.

    Did any one face such a problem or has a clue where It could relate to?

    I suspect that there is some thing wrong with the configuration database, would restoring back an old copy of the database resolve the issue, I'll have to try this as well.

    Ahmed Abuabdou, Senior SharePoint Developer, Bank AlBilad

    Monday, December 03, 2012 8:09 AM