none
Service Pack 2 Upgrade failed on configuration wizard for front end server RRS feed

  • Question

  • health analyser is reporting the following error

    Product / patch installation or server upgrade required.

    Severity

    1 - Error

    Category

    Configuration

    Explanation

    All required products must be installed on all servers in the farm, and all products should have the same patching and upgrade level across the farm.

    Upgrade is required on server VSRSP10WEB01. Without the upgrade, the server is not in a supported state.

    Remedy

    On server VSRSP10WEB01, once all required products and/or patches are installed, perform an upgrade by either running PSConfigUI.exe or by executing the command "PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures". If a former upgrade attempt has failed, you may need to resolve upgrade specific issues before attempting upgrade again. Refer to the upgrade status page (http://evemoss01:9999/_admin/UpgradeStatus.aspx) for information about current and prior upgrade attempts, and to determine issues that may be preventing upgrade from succeeding. For more information about this rule, see "http://go.microsoft.com/fwlink/?LinkID=142700".

    Also the windows sharepoint administration service will not start on this server

    we have tried re-starting the timer server and re-running the configuration wizard but it fails at the same point each time

    Failed
    Server VSRSP10WEB01
    Start 26/09/2013 20:40:45
    Last Updated 26/09/2013 20:40:45
    Errors 1
    Warnings 0
    Starting object  
    Current object  
    Current action  
    Step within the action 0
    Total steps in this action 0
    Elapsed Time 00:00:00
    Percentage completed 10.00%
    Process Name psconfigui
    Thread Id 4132
    Process Id 5708
    Command Line C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\psconfigui.exe
    Log File C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\Upgrade-20130926-204045-198.log
    Remedy This upgrade session has been stopped. Possible causes include the process being terminated abruptly or the OS has rebooted. Please restart the upgrade again.
    Friday, September 27, 2013 2:40 PM

Answers

  • I had this error in a few environments when installing SP2.  I rebooted the server in question and it went away.  These were are multi server farms though, so not sure if that will help.
    • Marked as answer by Paul-3994 Monday, September 30, 2013 10:17 AM
    Friday, September 27, 2013 8:23 PM

All replies

  • I also ran the following command

    PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

    Installing the SharePoint Web Application content files...

    Successfully installed the application content files.

    Performing configuration task 5 of 6

    Upgrading SharePoint Products...

    10.00%Failed to upgrade SharePoint Products.

    An exception of type System.InvalidOperationException was thrown.  Additional ex

    ception information: Cannot start service SPAdminV4 on computer '.'.

    Total number of configuration settings run: 5

    Total number of successful configuration settings: 4

    Total number of unsuccessful configuration settings: 1

    Successfully stopped the configuration of SharePoint Products.

    Configuration of SharePoint Products failed.  Configuration must be performed be

    fore you use SharePoint Products.  For further details, see the diagnostic log l

    ocated at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\1

    4\LOGS\PSCDiagnostics_9_27_2013_16_9_55_126_1847135864.log and the application e

    vent log.

    Friday, September 27, 2013 3:26 PM
  • You should look at the log files generated at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\1

    4\LOGS\PSCDiagnostics_9_27_2013_16_9_55_126_1847135864.log , it should be very detailed about what is causing problems.


    Please mark my response as an answer if appropriate.
    Learn.SharePoint.com

    • Marked as answer by Paul-3994 Monday, September 30, 2013 10:17 AM
    • Unmarked as answer by Paul-3994 Monday, September 30, 2013 10:17 AM
    Friday, September 27, 2013 7:40 PM
  • I had this error in a few environments when installing SP2.  I rebooted the server in question and it went away.  These were are multi server farms though, so not sure if that will help.
    • Marked as answer by Paul-3994 Monday, September 30, 2013 10:17 AM
    Friday, September 27, 2013 8:23 PM
  • yes i ended up rebooting the server after running this command

    PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

    re-ran the gui wizard and it completed successfully

    thanks

    Monday, September 30, 2013 10:17 AM