none
Cannot save site as template SharePoint 2010 Exporting List Announcements error

    Question

  • SharePoint 2010 is our first environment, there have been no migrations from 2007.

    I am having a problem saving a site as a template.  When saving the site as a template, I get an error that says "Error exporting the list named "Announcements" at the URL: Lists/Announcements

    I have removed all templates from the solutions gallery.  I have also deleted them from the recycle bin and the site collection recycle bin-there is no trace of another solution in the site collection.  

    I have moved the solution from my development environment to the production environment, but they are setup the same-different farms.

    Thank you for your assistance in advance.

    Additional logging information I found says this:

    SPSolutionExporter: CDATA inside CDATA blob

    SPSolutionExporter: System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.SharePoint.SPContentType.Serialize(XmlTextWriter xwtr, Boolean needsFields, Boolean isForDb, Boolean useParentContentTypeIdForList, Boolean includeOverwriteAttribute, Boolean includeVersionAttribute, Boolean tokenizeTemplatePath)    
     at Microsoft.SharePoint.SPSolutionExporter.ExportListContentTypes(SPList list, XmlWriter schemaWriter, ListExportSummaryInfo summaryInfo)    
     at Microsoft.SharePoint.SPSolutionExporter.ExportList(SPList list) at Microsoft.SharePoint.SPSolutionExporter.ExportLists()

    SPSolutionExporter: Microsoft.SharePoint.SPException: Error exporting the list named "Announcements"
     at the URL: Lists/Announcements    
     at Microsoft.SharePoint.SPSolutionExporter.ExportLists()    
     at Microsoft.SharePoint.SPSolutionExporter.GenerateSolutionFiles()    
     at Microsoft.SharePoint.SPSolutionExporter.ExportWebAsSolution()Microsoft.SharePoint.SPException: Error exporting the list named "Announcements"
     at the URL: Lists/Announcements   
     at Microsoft.SharePoint.SPSolutionExporter.ExportLists()    
     at Microsoft.SharePoint.SPSolutionExporter.GenerateSolutionFiles()    
     at Microsoft.SharePoint.SPSolutionExporter.ExportWebAsSolution()    
     at Microsoft.SharePoint.SPSolutionExporter.ExportWebToGallery(SPWeb web, String solutionFileName, String title, String description, ExportMode exportMode, Boolean includeContent, String workflowTemplateName, String destinationListUrl)    
     at Microsoft.SharePoint.SPSolutionExporter.ExportWebToGallery(SPWeb web, String solutionFileName, String title, String description, ExportMode exportMode, Boolean includeContent)    
     at Microsoft.SharePoint.ApplicationPages.SaveAsTemplatePage.BtnSaveAsTemplate_Click(Object sender, EventArgs e)    
     at System.Web.UI.WebControls.Button.OnClick(EventArgs e)    
     at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)    
     at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)    
     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



    Jesse A. Brandenburg

    Thursday, October 4, 2012 4:13 PM

Answers

  • I found the answer!!! Thank you Serious SharePoint

    Here is the answer:

    Resolution:

    Run the SharePoint 2010 Management Shell as Administrator.  Run the following command to disable the default content type feature:

    Disable-SPFeature –Identity ctypes –url http://SiteCollection

    Then enable the content type feature:

    Enable-SPFeature –Identity ctypes –url http://SiteCollection

    If you look at your content types, they should now all be there.  Try saving the subsite as a template again, it should succeed.


    Jesse A. Brandenburg

    • Marked as answer by 1brandeja5 Monday, October 8, 2012 10:16 PM
    Monday, October 8, 2012 10:16 PM

All replies