none
Sorry, we couldn't open your file using this feature. Visio Web Access is not available on this site.

    Question

  • Recently installed Service Pack 1 in SharePoint Server 2013 Farm, post upgrade we are experiencing issue when opening visio documents:

    I am trying to open .vsdx (visio 2013) file but encounter following issue:

    Sorry, we couldn't open your file using this feature. Visio Web Access is not available on this site.

    Under Document library-->Library settings-->Advanced Settings

    Still I cant open file in browser as we always used to. Unfortunately we don't have Visio services in Farm.

    can you share your experiences regarding this issue post Sp1 SharePoint Server 2013.

    Thank You

     

    Friday, January 30, 2015 3:23 PM

Answers

  • Hi Octopus,

    I recommend to repair the Visio client application to see it works.

    And make sure that the Open in client application is set on the library settings.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    • Marked as answer by octopus123 Tuesday, April 07, 2015 3:14 PM
    Friday, February 13, 2015 2:45 AM
    Moderator

All replies

  • Hi Octopus,

    Based on the error message, it seems that the Visio Graphics Service is not started or the Enterprise feature is not enabled.

    I recommend to check the things below:

    1. Go to Central Administration > System Settings > Manage service on server > check if the Visio Graphics Service is started > then click Application Management > Manage service applications > check if the Visio Graphics Service application is created.
    2. Go to the root site settings page of the site where you got this error, click Site collection features to check if the SharePoint Server Enterprise Site Collection Features is enabled.
    3. Go to the site settings page of the site where you got this error, click Manage site feature to check if the SharePoint Server Enterprise Site Features is enabled.

    More information about the Visio Graphics Service:

    http://tutorial.programming4.us/windows_server/microsoft-sharepoint-2013---looking-at-visio-services-(part-3)---visio-graphics-service-service-application.aspx

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    • Proposed as answer by Sudip Misra Tuesday, February 10, 2015 5:01 PM
    • Unproposed as answer by Sudip Misra Tuesday, February 10, 2015 5:02 PM
    Monday, February 02, 2015 6:24 AM
    Moderator
  • Thank You for your response Victoria, but we never had Visio services started in our farm. Prior to Service Pack 1 upgrade we had no issues opening Visio files in browser. I don't know what changed. Also under site collection features, and Site features page, I have SharePoint Server Standard Site  features Activated.

    Thank You

    Monday, February 02, 2015 2:00 PM
  • Hi Octopus,

    Per my test, no matter if the SP1 is installed or not, the error will occur if the Visio service is not started or there is no Visio service application associated with the web application where the .vsdx file exists when we open the .vsdx file in the browser.

    So we need to start the service and make sure that the Visio service application is connected with the web application where the .vsdx file exists.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    Tuesday, February 03, 2015 2:07 AM
    Moderator
  • Do we really need Visio Service Application Running in CA to just Render Visio Files in document library? We have standard license and I didn't see the Visio service application in Service Application page. Does that mean users need to have SharePoint Enterprise  license to just view Visio now in SharePoint 2013. How about Visio Web Access  Feature that used to available in Sp2010, is that still available in sp2013. I used sp2010 foundation version to open visio.

    Thank You

    Tuesday, February 03, 2015 2:47 PM
  • Hi Octopus,

    If you want to open the .vsdx file in the browser in SharePoint, then the Visio service must to be running.

    And only SharePoint Enterprise edition support the Visio service.

    The Visio Web Access web part is supported by the Visio Service, so if you are using foundation or standard version, then the web part will not be available.

    The link below shows the supported feature in different versions of SharePoint:

    http://blog.blksthl.com/2013/01/14/sharepoint-2013-feature-comparison-chart-all-editions/

    More reference about Visio Service:

    https://technet.microsoft.com/en-us/library/ee663485(v=office.15).aspx

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    Wednesday, February 04, 2015 6:44 AM
    Moderator
  • Thank you for your reply again Victoria, I believe in our case we have Visio client installed in each computer to open the file in client instead. But when opening the file in client we are still receiving such error in IE browsers, although it is not the case in Firefox. Have you came across such issues in past, are there specific add-ons we require to open Visio files in Visio reader or client itself for it to work?
    Thursday, February 05, 2015 1:42 PM
  • Hi Octopus,

    I recommend to set the documents to be opened in client application in the library.

    Please go to the library settings > Advanced settings > select Open in the client application.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    Friday, February 06, 2015 7:28 AM
    Moderator
  • Hi Octpous,

    How is everything going?

    Is there anything else that I can help?

    If you have any questions, please feel free to let me know.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    Tuesday, February 10, 2015 2:37 AM
    Moderator
  • Victoria, I am still getting same error while attempting to open Visio document using client application Visio reader in Internet explorer 8,9,10. It works will in Firefox. can you suggest something I can look for to resolve this issue.

    Thank You

    Tuesday, February 10, 2015 4:44 PM
  • Hi Octopus,

    Please check if the SharePoint OpenDocuments Class add-on is enabled in Internet Explorer.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    Wednesday, February 11, 2015 12:13 PM
    Moderator
  • Yes it is

    Wednesday, February 11, 2015 8:09 PM
  • Hi Octopus,

    I recommend to repair the Visio client application to see it works.

    And make sure that the Open in client application is set on the library settings.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    • Marked as answer by octopus123 Tuesday, April 07, 2015 3:14 PM
    Friday, February 13, 2015 2:45 AM
    Moderator