none
master page in sharepoint 2013 blog site. RRS feed

  • Question

  • I Created a publishing SharePoint 2013 site and created a custom master page using design manager. Now i created Blog site with in the same site collection and when i try to go to site settings master pages and try to configure the custom master page which i created to publishing site to the blog site i couldn't see that option. 

    How can i apply that custom master page to the blog site. 

    Thanks,

    M.M

    Monday, August 26, 2013 3:38 PM

Answers

All replies

  • Can you try setting the CustomMasterURL property of the blog subsite via PowerShell?

    http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.spweb.custommasterurl.aspx

    $w = get-spweb http://<yourserver>/sites/parentsite/blogsite

    $w.CustomMasterURL = <<your custom master page>>

    $w.update()


    val it: unit=()

    Monday, August 26, 2013 3:46 PM
  • Make sure the master page you have created is published and approved.

    Please remember to mark your question as "answered"/"Vote helpful" if this solves/helps your problem.

    Monday, August 26, 2013 4:12 PM
  • Hey,

    I beleive the option for setting the master page from the site settings appears only for those sites for which the publishing feature is enabled.

    The other options for setting the master page would be

    1. Open the site in SharePoint designer - navigate to _Catalogs/MasterPage - right click on the master page and set is as the custom master page

    2. Use powershell as suggested above

    3. Write a feature event receiver that sets the custom master page.

    you can use the below code for setting the custom master page using the feature event receiver.

    SPWeb web = properties.Feature.Parent as SPWeb;
                    web.AllowUnsafeUpdates = true;               
                    web.CustomMasterUrl = web.ServerRelativeUrl.ToString() + "/_catalogs/masterpage/something.master";
                    web.Update();
                    web.AllowUnsafeUpdates = false;

    Regards,

    Sharath


    sharath kumart shivarama

    Monday, August 26, 2013 4:33 PM