locked
Setup issue: SP2013 RTM MSDN ISO + Win2008R2 + SQL 2012 SP1 CTP4 RRS feed

  • Question

  • Hello,

    Can't pass the preparation check for 'Error when enabling ASP.NET v4.0.30319'. The server is in the domain with other ASP.NET 4.0 web Application installed.

    My domain account is in the Local Admin group. 

    2012-10-30 15:33:01 - Install process returned (0X3EB=1003)
    2012-10-30 15:33:01 - [In HRESULT format] (0X800703EB=-2147023893)
    2012-10-30 15:33:01 - "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i
    2012-10-30 15:33:02 - Request for install time of Application Server Role, Web Server (IIS) Role
    2012-10-30 15:33:06 - Request for install time of Application Server Role, Web Server (IIS) Role
    2012-10-30 15:33:06 - Install process returned (0)
    2012-10-30 15:33:06 - [In HRESULT format] (0)
    2012-10-30 15:33:06 - "C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v4.0.30319"
    2012-10-30 15:33:07 - Request for install time of Application Server Role, Web Server (IIS) Role
    2012-10-30 15:33:07 - Install process returned (-2146646015)
    2012-10-30 15:33:07 - [In HRESULT format] (-2146646015)
    2012-10-30 15:33:07 - Error when enabling ASP.NET v4.0.30319
    2012-10-30 15:33:07 - Last return code (-2146646015)

    I have seen others posted same issue at CTP version.
    Does it mean SP 2013 RTM can't be installed on servers which has joined any domain?

    Don't kidding me on this.

    Thanks,

    Bob





    • Edited by Bob Zhao Wednesday, October 31, 2012 4:32 AM
    Tuesday, October 30, 2012 11:25 PM

Answers

  • Hi, Bob,

    I have come across this issue when I installing SP2013, so you can check your IIS manager and click the computer name in the left panel, Under features view, double click ISAPI and CIG restrictions. In this window, you should check the 4.0 aspnet_isapi.dll's description, if it's same with "ASP.NET v4.0.30319" in the command "C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v4.0.30319", in my server, the description is "ASP.NET v4.0.30319(32-bit)", changing it to "ASP.NET v4.0.30319" resolves my issue.

    Hope this can help you

    BR

    • Marked as answer by Lhan Han Friday, November 9, 2012 7:00 AM
    Wednesday, November 7, 2012 7:58 AM
  • For those still experiencing the problem... the solution is simple after much searching, was a matter of running "cmd.exe" as administrator and record the "framework 4.0 64bit" in IIS the command is:

    "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i -enable

    • Marked as answer by Bob Zhao Tuesday, August 13, 2013 9:02 PM
    Monday, March 25, 2013 7:16 AM
  • Hi Bob,

      I am using Hyper-V VMs and the image which i was trying to install SPS2013 RTM used to have the Preview installed. So I think it may have something to do with it not cleaning up IIS properly when removed.

    One additional steps which I failed to mention is that i have tried to remove and reinstall the asp.net registration  - not sure if that helps.

    aspnet_regiis -r

    aspnet_regiis - i

     

    Which went through without a glitch - but it always errored out when I try to run this line (taken from the log):

    C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v4.0.30319"

    So when I checked IIS extensions - it was not enabled. Enabling it (like described in my earlier post) helped in my case.

    Perhaps, someone else has more insight on what might be truly wrong here.

    Thanks,
    Sailendra
    • Marked as answer by Lhan Han Friday, November 9, 2012 7:00 AM
    Sunday, November 4, 2012 7:48 AM

All replies

  • I had a similar error with SharePoint 2013 on Windows 2008 R2 SP1.

    Enabling the ASP.NET web service extensions from IIS manager helped fix the issue.

    To enable the ASP.NET extension, open IIS manager and click on the computer name in the left pane.

    Under features view double click ISAPI and CGI restrictions. In this window, look for aspnet_isapi.dll file in the path column. On my system there are two entries. Double click each entry and click the checkbox 'Allow extension path to execute'. Click ok.

    Now try installing the pre-requisites.

    Wednesday, October 31, 2012 3:51 PM
  • Hi Sailendra,

    Thanks for your help, but this method still doesn't work.

    I have begun to install SP2013 on a brand new Win 2012 RTM, I didn't meet any issue then, just several click.

    Seems like they didn't support or test my previous scenario before.

    The tip is:

    Must use the guide to install those pre-requisite before join any domain.

    But you can join domain immediately just after finish the pre-requisite installation.

    It works for my second case:

    Windows 2012 RTM

    SharePoint 2013

    SQL 2012 SP1 CTP4

    Thanks,

    Bob 



    • Edited by Bob Zhao Thursday, November 1, 2012 2:47 AM
    Thursday, November 1, 2012 2:46 AM
  • Hi Bob,

      I am using Hyper-V VMs and the image which i was trying to install SPS2013 RTM used to have the Preview installed. So I think it may have something to do with it not cleaning up IIS properly when removed.

    One additional steps which I failed to mention is that i have tried to remove and reinstall the asp.net registration  - not sure if that helps.

    aspnet_regiis -r

    aspnet_regiis - i

     

    Which went through without a glitch - but it always errored out when I try to run this line (taken from the log):

    C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v4.0.30319"

    So when I checked IIS extensions - it was not enabled. Enabling it (like described in my earlier post) helped in my case.

    Perhaps, someone else has more insight on what might be truly wrong here.

    Thanks,
    Sailendra
    • Marked as answer by Lhan Han Friday, November 9, 2012 7:00 AM
    Sunday, November 4, 2012 7:48 AM
  • Hi, Bob,

    I have come across this issue when I installing SP2013, so you can check your IIS manager and click the computer name in the left panel, Under features view, double click ISAPI and CIG restrictions. In this window, you should check the 4.0 aspnet_isapi.dll's description, if it's same with "ASP.NET v4.0.30319" in the command "C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v4.0.30319", in my server, the description is "ASP.NET v4.0.30319(32-bit)", changing it to "ASP.NET v4.0.30319" resolves my issue.

    Hope this can help you

    BR

    • Marked as answer by Lhan Han Friday, November 9, 2012 7:00 AM
    Wednesday, November 7, 2012 7:58 AM
  • Hi Jackie, Thanks for your help. I will try to verify your approach while get sql 2012 sp1 RTM. The powerview installation failed either on sp1 CTP4. They need do more installation testing on whole 2012 & 2013 series . Thanks, Bob
    Saturday, November 10, 2012 4:08 PM
  • Hi Bob,

    I hit this same issue, I noticed this file: C:\Windows\system32\iisext.vbs did not exist.

    I was able to get that file setup by manually adding the Application Server and Web Server Role (IIS)

    More specifically, when adding role services for IIS, I had to check IIS 6 Scripting Tools.

    After doing this I noticed iisext.vbs was in C:\Windows\system32 I then ran the prerequisite installer and it completed successfully!

    Sezai.

    Tuesday, November 20, 2012 7:57 AM
  • Another issue I hit with the prerequisite installer related to install of Windows Identity Foundation failing and another way to resolve this missing iisext.vbs file...

    It seems you need to install the .NET Framework 3.5 Feature for the prerequisite installer to complete successfully.

    Adding this via Server Manager also doesn't work for me, could only get .NET Framework 3.5 installed using the steps described here:

    http://social.technet.microsoft.com/Forums/en-GB/winserver8setup/thread/5a786052-38a1-46f9-add2-e6487bc6a8aa

    dism /online /enable-feature /featurename:NetFX3 /all /Source:d:\sources\sxs /LimitAccess

    Where D:\ is your Windows Server 2012 Install media location.

    Wednesday, November 21, 2012 3:47 AM
  • Hi Sezai,

    Here is an interesting post might help you.

    You need to run prerequisite installer TWICE.

    SharePoint 2010: Prerequisite installer fails on Windows Server 2008 R2 SP1

     

    From <http://support.microsoft.com/kb/2581903?wa=wsignin1.0>

     

     

    Thursday, March 21, 2013 10:51 PM
  • For those still experiencing the problem... the solution is simple after much searching, was a matter of running "cmd.exe" as administrator and record the "framework 4.0 64bit" in IIS the command is:

    "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i -enable

    • Marked as answer by Bob Zhao Tuesday, August 13, 2013 9:02 PM
    Monday, March 25, 2013 7:16 AM
  • For those still experiencing the problem... the solution is simple after much searching, was a matter of running "cmd.exe" as administrator and record the "framework 4.0 64bit" in IIS the command is:

    "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i -enable


    Thanks this worked for me :)
    Tuesday, May 28, 2013 5:06 PM
  • it worked for me.

    great. thanks.


    Learning is a never ending process.

    Wednesday, July 3, 2013 9:38 AM
  • For those still experiencing the problem... the solution is simple after much searching, was a matter of running "cmd.exe" as administrator and record the "framework 4.0 64bit" in IIS the command is:

    "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i -enable

    This is the correct Answer!

    I ever seen this issue existed in other MS products. But they handle this well.

    http://social.technet.microsoft.com/wiki/contents/articles/2390.troubleshoot-installation-and-configuration-issues-master-data-services-in-sql-server-2012.aspx#SVCHandlerMappingError

    Thanks,

    Bob

    Tuesday, August 13, 2013 9:10 PM
  • thanks a lot, we spend 3 days looking for a solution for that.

    many thanks.

    Thursday, August 22, 2013 11:33 AM