none
Databases not completely monitored RRS feed

  • Question

  • Hello

    I have a problem with two Database Servers. I monitor my DBs with the SCOM MP for SQL Server 2016. This works for all Server except two. The have a lot of Databases (approximately 130 per Server). But only approximately 20 Databases are "Healthy", the others are "Not Monitored". But in the Eventlog i have no Warnings or Errors. Do anybody know what the problem could be with this Servers?

    (I hide the Name and Path because of security reasons) 

    Kind Regards

    Monday, November 18, 2019 1:41 PM

All replies

  • Hi,

    Do you use the "old" version specific MP or the "new" version agnostic MP?
    Do you use dedicated user account for the SQL monitoring or Local System respectively Health Service SID?
    Usually this could bed due to the discovery not being triggered and this is to 95% result of missing permissions (hence the questions regarding the accounts).

    You mentioned that "in the Event Log I have no Warnigs or Errors", do you mean the Operations Manager event log?
    What about alerts (like faling MSSQL Discoveries or failing PowerShell scripts) related to the server?

    Regards,


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov


    Monday, November 18, 2019 1:49 PM
    Moderator
  • Hi

    I'm not sure, I used the old version specific MP, but since the 2017+ came out, I also imported this for my 2017 Servers. But i don't know which monitors now my 2016 Servers.

    The view I use is in the marked folder:

    I use the way with the SID.

    But when I have a permission problem, normally I get a Warning in the SCOM Console. But this two Servers has no Warnings and Errors in the SCOM Console. I mean the Log in the Event Viewer--> Applications and Services Log--> Operations Manager. But now I found some Warnings, but i don't know if they have anything to do with this problem:

    In PerfDataSource, could not resolve counter instance SQL Server 2016 XTP Databases, IoPagePool64K Total Allocated, _Total. Module will not be unloaded.

    One or more workflows were affected by this. 
    Workflow name: Microsoft.SQLServer.2016.CollectionRule.DBEngine.XTPIopagepool64kTotalAllocated
    Instance name: XXXXXXXX
    Instance ID: XXXXXXXXX
    Management group: XXXXXXXXXX

    Kind Regards

    Monday, November 18, 2019 2:41 PM
  • Hi,

    this event seems related only to some collection rule, so I wouldn't pay great attention to it, while investigating the DB monitoring issue.
    Since you mentioned that you have the "old" and also the "new" MPs, I need to stress out that there is certain procedure that needs to be followed when trasitioning to the new MP and it is descried here:

    How to transition to the SQL Version Agnostic MP

    Did you follow all th steps from it? If not, please make sure you do so, otherwise you might end up rnning duplicated discoveries and monitors and who know also what.

    I would really advice you to get rid of the old MPs, once you have transitioned to the new MP.

    Regards,


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Monday, November 18, 2019 2:59 PM
    Moderator
  • I followed the steps up to the step with the override. So at the moment 2012, 2014 and 2016 are discovered by the old version. I will do the migration next Week. But the problem was also before I importet 7.0.15.0.

    But maybe the migration will solve the Problem. I will write here if it worked or not.

    Regards

    Monday, November 18, 2019 3:28 PM