locked
SharePoint prompts user to login RRS feed

  • Question

  • I do not work with SharePoint often, but I know that I had this problem before.  Do not remember and cannot find how to fix it.

    I have SharePoint 2013 setup.  In Alternate Access Mapping, I have:

    Default: http://sp_servername
    Internet: http://intranet.domain.com

    As far as I remember the problem is related to this setting.  If I go to http://sp_servername, everything looks good.  If I go to http://intranet.domain.com, it asks user to login.  Every time.

    Can someone help?  We have to use http://intranet.domain.com in the office and when we are outside of the office.

    Thank you.


    Thank you. Eric.

    Thursday, January 24, 2013 4:55 PM

Answers

All replies

  • Try this,

    Solution 1 (Preferred): Specify which host names that does not cause loopback check.

    1: Open up the registry editor by typing regedit under Run.
    2: Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3: Right-click MSV1_0 and click New and choose to make it a Multi-String Value.
    4: Enter BackConnectionHostNames as name for the entry, and double-click it to modify it.
    5: Type the hostnames you need to use (code-journey.com for instance).
    6: Restart IISAdmin Service (“Start” -> “Administrative Tools” -> “Services”)

    Solution 2 (Not recommended):
    1: Open up the registry editor by typing regedit under Run.
    2: Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3: Right-click Lsa and click New and choose to make it a DWORD Value.
    4: Enter DisableLoopbackCheck as name for the entry, and double-click it to modify it.
    5: Set the value to 1 and click OK

    Thursday, January 24, 2013 5:10 PM
  • Thank you for your reply.

    I used Solution 1 and it did not work.  Still asking for user name and password.

    The hostname that I used is intranet.domain.com.  Is this correct?

    Thank you.


    Thank you. Eric.

    Thursday, January 24, 2013 5:17 PM
  • The domain name can be anything, However, your Networking team should add this name in the DNS server to route the request to the SharePoint Server

    Examples,

    Intranet.YourDomainName.com 

    Intranet.Microsoft.com

    stage-intranet

    Intranet

    Thursday, January 24, 2013 5:32 PM
  • The name intranet.domain.com is in the DNS and it points to the SharePoint Server's IP address.

    Thank you.


    Thank you. Eric.

    Thursday, January 24, 2013 5:33 PM
  • in the AAM change the default to http://intranet.domain.com and let me know

    Thursday, January 24, 2013 5:37 PM
  • When I try to change default zone, I receive the following error:


    Sorry,
    something went wrong

    You must specify the default
    zone URL for all Web applications. To delete the Alternate URL Collection,
    remove the public URLs in all other zones, and then remove the default zone
    URL.


    Thank you. Eric.

    Thursday, January 24, 2013 5:40 PM
  • I was able to change it, but it prompts me anyway.

    Thank you.


    Thank you. Eric.

    Thursday, January 24, 2013 5:42 PM
  • When you browse to http://intranet.domain.com  which zone does internet explorer detect it as? Trusted, Intranet or Internet? Try and add http://*.domain.com to trusted sites.

    My CodePlex - My Blog - My Twitter

    • Marked as answer by KPABA Thursday, January 24, 2013 9:32 PM
    Thursday, January 24, 2013 7:31 PM
  • I do not know how to check the zone that IE detects it, but I added http://*.domain.com to trusted and intranet zones on my workstation and it is not asking me anymore.

    Is there a way to do in on the SharePoint side, so I do not have to make any changes to the workstations?

    Thank you.


    Thank you. Eric.

    Thursday, January 24, 2013 8:51 PM
  • It's a client side setting. You can push this through using group policy to all client systems though, here's a tutorial that goes through how to setup the GPO: http://www.wincert.net/tips/windows-server/2716-how-to-add-a-site-to-the-trusted-sites-using-group-policy someone that manages active directory in your organization will need to do this.

    My CodePlex - My Blog - My Twitter

    Thursday, January 24, 2013 9:11 PM
  • Thank you everyone for the help.

    Thank you. Eric.

    Thursday, January 24, 2013 9:32 PM