Failed to backup some cluster VMs - The filename, directory name, or volume label syntax is incorrect (0x8007007B) RRS feed

  • Question

  • Hi..

    we use DPM to backup VMs on our Hyper-V Cluster. There are many VMs without any backup issue, but 5 of them failed with error:

    An unexpected error occurred while the job was running. (ID 104 Details: The filename, directory name, or volume label syntax is incorrect (0x8007007B))

    * DPM can successfully create the backup Snapshot but revert them after 50 sec

    * No equal Eventlog errors

    I've tried many steps: rejoined VMs to cluster, removed any snapshots, export -> delete -> import (with new ID), reinstalled DPM Agent, rebooted Cluster Nodes...

    The error still persists.


    * Cluster Nodes: Hyper-V Server 2016

    * DPM: Host OS: Win Server 2016, DPM 2016 RU4

    Please help me :)


    Thursday, November 9, 2017 9:17 AM

All replies

  • Hi all!

    We have the same problem but with DPM 1801.

    Does anybody know how to prevent this?

    Thursday, May 3, 2018 9:43 AM
  • Hi a_g_w,

    Firstly have you checked that all DPM agents are up-to-date?

    How does your VSS providers look?

    Open up a command prompt and type: vssadmin list providers

    Kind regards,

    Please remember to mark the replies as answers if they help.

    Thursday, May 3, 2018 8:53 PM
  • Leon Laude, I could answer for myself.

    We have two Hyper-V clusters with 2 nodes in each cluster.

    All nodes are Windows Server 2016 with the latest updates, all nodes are protected with recently installed DPM 1801, all DPM agent the same and have the latest version.

    The problem occurs on two VMs which sits on two separate(independent) clusters.

    VSS providers are the same on all HV servers:

    C:\WINDOWS\system32>vssadmin list providers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2013 Microsoft Corp.

    Provider name: 'Microsoft CSV Shadow Copy Helper Provider'
       Provider type: Software
       Provider Id: {26d02d81-6aac-4275-8504-b9c6edc5261d}

    Provider name: 'Microsoft CSV Shadow Copy Provider'
       Provider type: Software
       Provider Id: {400a2ff4-5eb1-44b0-8a05-1fcac0bcf9ff}

    Provider name: 'VSS Null Provider'
       Provider type: Software
       Provider Id: {8202aeda-45bd-48c4-b38b-ea1b7017aec3}
       Version: 5.1.363.0

    Provider name: 'Microsoft File Share Shadow Copy provider'
       Provider type: Fileshare
       Provider Id: {89300202-3cec-4981-9171-19f59559e0f2}

    Provider name: 'Microsoft Software Shadow Copy provider 1.0'
       Provider type: System
       Provider Id: {b5946137-7b9f-4925-af80-51abd60b20d5}

    Provider name: 'VSS Null Provider'
       Provider type: Fileshare
       Provider Id: {f4a69dd4-f712-40e3-a6b3-faeff03cb2b8}
       Version: 5.1.363.0

    Friday, May 4, 2018 11:18 AM
  • Hi,

    Update Rollup 5 is released, you could always try to see if it fixes the issue.

    Kind regards,

    Don't forget to visit my blog The System Center Blog

    Tuesday, May 8, 2018 6:34 PM
  • Hi.

    I have the same problem with VM first generation, version 8.0 and vhd disk.

    The problem was solved after converted vhd to vhdx and recreate this object in DPM.

    I hope this helps you


    • Edited by Kirill Zykov Thursday, December 13, 2018 11:32 AM
    Thursday, December 13, 2018 10:30 AM