none
WSUS Failing to update 100% due to a license terms not been completely downloaded RRS feed

  • Question

  • Cut over to a new WSUS server a few months ago and all was working fine until a week ago.  Getting the following error consistently in the wsyncmgr.log every synch (which is every 59 minutes on retry):

    Synchronizing update 9e8a0009-e9df-4a4c-8c14-2d348a160adb:  Microsoft Silverlight (KB2636927)

    Failed to sync update 9e8a0009-e9df-4a4c-8c14-2d348a160adb. Error: The Microsoft Software License Terms have not been completely downloaded and cannot be accepted. Source: Microsoft.UpdateServices.Internal.BaseApi.LicenseAgreement.GetById

    We have accepted and downloaded nearly every Silverlight patch and accepted the EULA.

    Any help would be greatly appreciated.

    Thanks

    Dave

    Friday, June 8, 2012 8:19 PM

Answers

All replies

    • Marked as answer by Sabrina Shen Wednesday, June 27, 2012 7:15 AM
    Saturday, June 9, 2012 12:38 AM
  • Hi,

    Have you set WSUS to download content locally?

    Try wsusutil.exe reset command. Also check the WSUS content folder setting is same form WSUS console and WSUS database.

    Have you checked IIS log? Not only the error messages, but also warning messages like "LicenseAgreement file does not exist:".

    Also take the following thread as a reference:

    http://social.technet.microsoft.com/forums/en-US/configmgrsum/thread/57256496-5f65-4f4c-bd75-e388c11151cb/

    Thanks

    • Marked as answer by Sabrina Shen Wednesday, June 27, 2012 7:15 AM
    Monday, June 11, 2012 8:24 AM
  • We have the exact same issue. I have tried granting Network Service User account read permission on the WSUS install partition as per the scug.dk blog, didn't work. Tried giving Network Service account modify permissions, still no joy, full control, still no luck. Nothing shows up in the iis log. That update does not show up in the SCCM console as requiring acceptance of License Terms. Eulas are being downloaded, but no English ones, only Japanese, German, or Polish or something.

    I even tried deleting that Silverlight update, and unchecking Silverlight as one of the products for the SUP component configuration. But still the error persists!

    Tuesday, June 12, 2012 12:38 AM
  • So, if you don't download content locally, then you'll always get synchronization failures? In the case that I'm using SCCM System Updates it seems redundant to download files locally with WSUS and then to create packages with said downloaded updates. You're basically just copying the downloaded files from one location to another in that scenario. Which is inefficient for obvious reasons. I can understand why the failure would occur, but seems like if I download files from the internet anyway, there should be an option to ignore those failures, or suppress them.
    Monday, January 26, 2015 9:40 PM