locked
Getting initial confirmation mails but not the Alert mails RRS feed

  • Question

  • Hi All,

    I am getting initial confirmation mail as "Alert has been craeted for Tasks list successfully", but when i change anything there then no alert is triggered. I have tried all the below commands, but no joy

    Use STSADM to verify properties

    Note – To add to STSADM’s to paths use SET PATH=%PATH%;"c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN\"

    STSADM -o getproperty -url http://YourSiteURL -pn alerts-enabled
    You should see  <Property Exists=”Yes” />
    
    STSADM -o getproperty -url http://YourSiteURL–pn job-immediate-alerts

    You should see something like the default (but can be changed) <Property Exists=”Yes” Value=”every 5 minutes between 0 and 59” />

    Use STSADM to reset properties

    Some users have reported that even though these properties are listed correctly above, simply resetting them solved the problem. Be aware, some but not all have reported that this can remove existing alerts.

    stsadm –o setproperty –url http://YourSiteURL –pn alerts-enabled –pv False
    
    stsadm –o setproperty –url http://YourSiteURL –pn alerts-enabled –pv True
    
    stsadm –o setproperty -url http://YourSiteURL –pn job-immediate-alerts –pv “Every 5 minutes between 0 and 59"

    Reference for alerts-enabled and job-immediate-alerts properties

    Use STSADM to re-register the alert templates

    Again, some people have reported that this works with no agreement on the cause.

    stsadm -o updatealerttemplates -url http://YourSiteURL -f "c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\XML\alerttemplates.xml" -LCID 1033 

    Can anyone help me, how can i resolve this issue.....?

    Thanks

    Shailu.


    Success is not to be pursued; it is to be attracted by the person we become.
    Friday, May 20, 2011 9:31 AM

Answers

  • HI,

    It clearly shows that there is some issue with the SMTP you are using.

    First of all check the primary IP of your WFE servers and verify whether the primary IP of your servers are added in allow relay list of your SMTP server.

    I hope this will help.

    Thanks,

    Rahul Rashu

    • Marked as answer by Shailu123 Wednesday, May 25, 2011 4:28 PM
    Tuesday, May 24, 2011 6:11 AM
  • Thank you for your responses.

    My issue has been resolved by adding all the web front end server IP's to relay settings in Exchange Server.


    Success is not to be pursued; it is to be attracted by the person we become.
    • Marked as answer by Shailu123 Wednesday, May 25, 2011 4:27 PM
    Wednesday, May 25, 2011 4:27 PM

All replies

  • Hi Shailu,

    how many servers are there in farm ?

    Please check SMTP settings and outgoing email settings in CA.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Friday, May 20, 2011 11:20 AM
  • I have 2 servers in the farm.

    I have checked outgoing mail settings. Its all fine, i am able to get intial confirmation mails. But i am getting alerts....


    Success is not to be pursued; it is to be attracted by the person we become.
    Friday, May 20, 2011 1:28 PM
  • Shailu,

    The initial email is sent by SharePoint and for the sub sequent emails are fired from SMTP, so please check SMTP settings and if required please configure relay on SMTP server 


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Friday, May 20, 2011 2:03 PM
  • Hi,

    You need to check SMTP settings on each WFE in farm.

    You can do one easy thing to verify.

    1. Log on to the server

    2. Add yourself in any site's user group.

    3. While adding check the checkbox "Send welcome mail". In the body write some text like serverName to track it better. Check if you receive any alerts or not.

    I hope this will help.

    Thanks,

    Rahul Rashu

    Friday, May 20, 2011 2:10 PM
  • I have checked the SMTP settings using "telnet" command it says ready but when i try adding user by checking the check box to send a mail it throws an error saying...

    "The user or users have been added successfully, but there was an error in sending the e-mail message. The server may not be set up correctly to send e-mail. To verify that e-mail is configured correctly, contact your server administrator."

    Can anyboy tell me what i am missing....????


    Success is not to be pursued; it is to be attracted by the person we become.
    Monday, May 23, 2011 10:08 PM
  • HI,

    It clearly shows that there is some issue with the SMTP you are using.

    First of all check the primary IP of your WFE servers and verify whether the primary IP of your servers are added in allow relay list of your SMTP server.

    I hope this will help.

    Thanks,

    Rahul Rashu

    • Marked as answer by Shailu123 Wednesday, May 25, 2011 4:28 PM
    Tuesday, May 24, 2011 6:11 AM
  • Since the initial email gets sent fine, I suspect that the SMTP settings are fine. The initial email and the alerts should go through roughly the same mechanisms.

    A lot of the actual alerts are closely linked with the search service and I suspect that's where your problem lies. One commone issue is that when someone resets their search index they get the option to disable alerts (otherwise when the index is rebuilt a huge number of alerts would be triggered). It's very easy to forget to enable it again. To check this go to your Shared Service Provider's administration page (if you don't know where this is, go to Central Administration and click on the name of the Shared Service Provider). On the admin page, click on Search Settings, and then there shold be a link for "Search-based alerts", make sure these are active. Also check the "Content sources and crawl schedules" to make sure there is a crawl of your main sites happening at some point. And check the crawl logs to make sure it definitely runs.

    With the alerts enabled and the crawls running correctly you should then start getting the alerts.

    Tuesday, May 24, 2011 8:55 AM
  • Thank you Rahul. Now i am not getting any error while adding user and the mail is sent immediately to the user when he/she is added.

    But alerts are still not working, no mail triggers when any change occurs in a List/Library.

    Can anyone please help me in this regard.

     

    This worked fine without any issue in Test server, but it is troubling in the Production.... :(


    Success is not to be pursued; it is to be attracted by the person we become.
    Tuesday, May 24, 2011 4:06 PM
  • Hi,

    If you have followed the steps specified by me I suggest you to remove the alerts and then create them once again.

    Then carry out the changes to see if you get any alerts or not. This you should do from each WFE to find out if anything is wrong in any WFE.

    Thanks,

    Rahul Rashu

    Tuesday, May 24, 2011 4:23 PM
  • Shailu,

    Is this a problem with every list or just one?  I have run into problems in the past where there was a permissions issue on the task list. It allows you to assign a task to the person and the verbage of the e-mail makes it look like if you don't have access to the list you can request access to it but it doesn't send the e-mail to a user who doesn't have permissions to the task list.

     


    Kevin
    Tuesday, May 24, 2011 6:08 PM
  • I would check your recieve connectors in Exchange. You can either enable anonymous access in the defult recieve connector (not recommended because of security), or you can put the IPs for all of your web front end servers in the "Recieve mail from remote server" section.
     
    To explain, the inital email is sent out from a specific email related to your SharePoint site. The change alerts are sent out as anonymous. Also, the timer job that sends out these change alert emails switches servers from time to time. So, if you dont enable the recieve connector to recieve email from all of your web front end servers, there is a chance that exchange could just drop these emails which are technicaly sent from "anonymous users".

    You can test this by temporarily enableing anonymous access on the default recieve connector, then turning it back off when you confirm. Leaving this on is not recommended because of security, but it is a good test.
    Keep in mind that the timer job that sends out immediate alerts runs about every 5 minutes. When you test, it may take some time for the user to get the alert.
     
    Here are the steps for Exchange 2010. You can use this as a guidline if you are not running 2010.

    1. Open up the Exchange Management Console
     
    2. Expand the "Server Configuration" Category in the left category menu.
     
    3. Click "Hub Transport"
     
    4. In the center section on the bottom box there should be a "Recieve Connectors" tab. Find the connector named "Default <Exchange Server Name>", Right click and select properties.
     
    5. To test the theory, Click Permission Groups and tick the Anonymous users check box, click apply, and then re-test the issue. (Remember to turn this back off if the test is successful as it is a security risk.)
     
    6. If the test works, you can click on the "Network" tab and under the "Recieve mail from remote servers that have these IP Addresses:" heading, click add.
     
    7. Add the IP addresses of all of the servers in the farm, Click Apply, then retest the issue.

     

    Hope this helps!


    Tuesday, May 24, 2011 7:49 PM
  • Thank you for your responses.

    My issue has been resolved by adding all the web front end server IP's to relay settings in Exchange Server.


    Success is not to be pursued; it is to be attracted by the person we become.
    • Marked as answer by Shailu123 Wednesday, May 25, 2011 4:27 PM
    Wednesday, May 25, 2011 4:27 PM