none
Windows Time Service Issues RRS feed

  • Question

  • Server 2008 R2 - DC - PDU

    C:\>w32tm /config /manualpeerlist:time.windows.com /syncfromflags:manual /reliab
    le:yes /update
    The command completed successfully.

    C:\>w32tm /resync
    Sending resync command to local computer
    The computer did not resync because no time data was available.

    C:\>w32tm /stripchart /computer:time.windows.com /samples:5 /dataonly
    Tracking time.windows.com [207.46.232.182:123].
    Collecting 5 samples.
    The current time is 7/13/2010 3:55:46 PM.
    15:55:46, -190.8127554s
    15:55:48, -190.8183836s
    15:55:50, -190.8219135s
    15:55:52, -190.8119167s
    15:55:54, -190.8086833s

    My DC is 3 minutes fast and I can't get it to sync with time.windows.com.  I've also tried time.nist.gov.

    Thoughts?

     

     

    C:\>w32tm /query /configuration
    [Configuration]

    EventLogFlags: 2 (Policy)
    AnnounceFlags: 10 (Policy)
    TimeJumpAuditOffset: 28800 (Local)
    MinPollInterval: 6 (Policy)
    MaxPollInterval: 10 (Policy)
    MaxNegPhaseCorrection: 172800 (Policy)
    MaxPosPhaseCorrection: 172800 (Policy)
    MaxAllowedPhaseOffset: 300 (Policy)

    FrequencyCorrectRate: 4 (Policy)
    PollAdjustFactor: 5 (Policy)
    LargePhaseOffset: 50000000 (Policy)
    SpikeWatchPeriod: 900 (Policy)
    LocalClockDispersion: 10 (Policy)
    HoldPeriod: 5 (Policy)
    PhaseCorrectRate: 1 (Policy)
    UpdateInterval: 100 (Policy)


    [TimeProviders]

    NtpClient (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)
    CrossSiteSyncFlags: 2 (Policy)
    AllowNonstandardModeCombinations: 1 (Local)
    ResolvePeerBackoffMinutes: 15 (Policy)
    ResolvePeerBackoffMaxTimes: 7 (Policy)
    CompatibilityFlags: 2147483648 (Local)
    EventLogFlags: 0 (Policy)
    LargeSampleSkew: 3 (Local)
    SpecialPollInterval: 3600 (Policy)
    Type: NT5DS (Policy)

    NtpServer (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 0 (Local)
    AllowNonstandardModeCombinations: 1 (Local)

    VMICTimeProvider (Local)
    DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)

     

    Tuesday, July 13, 2010 10:55 PM

Answers

All replies

  • Hi,

    What’s the result of w32tm /query /source?

    Please try the "Configuring the Windows Time service to use an external time source" section of "How to configure an authoritative time server in Windows Server" on your DC.
    http://support.microsoft.com/kb/816042

    Make sure to run "net stop w32time && net start w32time". Is there any progress?

    Thanks.
     


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 14, 2010 6:15 AM
    Moderator
  • Hello,

    have a look into my blog about domain time configuration:

    http://msmvps.com/blogs/mweber/archive/2010/06/27/time-configuration-in-a-windows-domain.aspx


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Wednesday, July 14, 2010 6:19 AM
  • Mervyn - I've read that article and I've done my best to follow the instructions, but I'm still getting the "The computer did not resync because no time data was available." error.  Did you notice the 2nd "fix it" link doesn't work, but instead sends you to a bing page? I'm talking about the link that should auto fix the time to sync off an external time source.
    Wednesday, July 14, 2010 8:58 AM
  • Meinolf - I read your blog, did you read my post?  I posted that I ran the commands below in the same fashion that your blog suggests and I'm still getting the resync error.  I've unregistered the time service, rebooted, and registered it, rebooted, and ran the commands below and restarted the service, yet same error.

    C:\>w32tm /config /manualpeerlist:time.windows.com /syncfromflags:manual /reliab
    le:yes /update
    The command completed successfully.

    C:\>w32tm /resync
    Sending resync command to local computer
    The computer did not resync because no time data was available.

    Wednesday, July 14, 2010 9:05 AM
  • Hello,

    please check the following registry key for "Type":

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters

    Is it NT5DS or NTP or NoSync?

    Check also that no GPO is the source:

    http://support.microsoft.com/kb/929276/en-us


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Wednesday, July 14, 2010 10:57 AM
  • Meinolf - Type = NTP.  The domain controller GPO's are the default GPO's.  The Windows Time section is all set to Not Configured.
    Wednesday, July 14, 2010 6:06 PM
  • Hi,

    Yes, the link is not working. Thank you for feedback. We will try to fix as soon as possible.

    If all settings are correct, it may be caused by Firewall/port settings. Check your Firewall, router, make sure port 123 UDP is opened.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, July 15, 2010 2:26 AM
    Moderator
  • We don't block outgoing packets.
    Thursday, July 15, 2010 2:31 AM
  •  

    Thank you for update. It looks like there is some wrong with time components, please try:

    w32tm /unregister and w32tm /register

    Run "net stop w32time && net start w32time" again, what’s the result?

    If the error persists, I suggest trying " Configuring the Windows Time service to use an internal hardware clock" of KB 816042, could " w32tm /resync" work? If it doesn’t work, it may be system file corruption.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, July 15, 2010 2:42 AM
    Moderator
  • It there a reason you are using time.windows.com?  Try contacting your ISP and see if they have a time server. Conecting to one that is close to you will reduce the chance of issues. 

    Also, do you have a firewall on your network? Ours was blocking the comunucations until I put in a specific allow rule.

    Is this a pysical server or a VM?  If your DC is a Hyper V VM you will need to uncheck the time sync option between the VM and the host server.  This causes a lot off issues for some people.


    Stephen Bloomer
    Thursday, July 15, 2010 4:18 AM

  • Also, not only outgoing packets, syncing time involve incoming packets. Please make sure the port 123 is allowed on your network.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, July 15, 2010 4:30 AM
    Moderator
  • Hi,

    Is the suggestion helpful? If not, please let us know more information for research. Any update is welcomed.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, July 19, 2010 2:48 AM
    Moderator
  • Mervyn - 123 is allowed on the Windows firewall.  There are no rules on the hardware firewall to block 123.

    Wouldn't the command below fail if it couldn't communicate over the correct ports?

    C:\>w32tm /stripchart /computer:time.windows.com /samples:5 /dataonly
    Tracking time.windows.com [207.46.232.182:123].
    Collecting 5 samples.
    The current time is 7/13/2010 3:55:46 PM.
    15:55:46, -190.8127554s
    15:55:48, -190.8183836s
    15:55:50, -190.8219135s
    15:55:52, -190.8119167s
    15:55:54, -190.8086833s

    I'm going to set it to sync off the internal hardware clock.

    Monday, July 19, 2010 6:18 PM
  • Hi,

    Could the system sync with the internal hardware clock successfully? Any update is welcomed.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 21, 2010 1:33 AM
    Moderator
  • I ran the fix it tool to set the PDU to use its internal hardware clock as the time source.  After I ran w32tm /resync.  Here is the output.

    C:\Users\Administrator.DC1>w32tm /resync
    Sending resync command to local computer
    The computer did not resync because no time data was available

    Thursday, August 5, 2010 9:44 PM
  • I set the time server to my ISP's NTP server and it works.
    Thursday, August 5, 2010 11:07 PM

  • Glad to hear you have fixed the problem. If you have more questions in the future, you’re welcomed to this forum.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, August 6, 2010 12:53 AM
    Moderator